summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-02-14 11:15:07 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-14 22:19:00 +0100
commit1070db148f68baf9de30b1b0344710b166693ee3 (patch)
tree1773ef16ee451d29d61a6fb25ac212f4c36a53cb
parentdev-python/ipython: drop old. (diff)
downloadgentoo-1070db148f68baf9de30b1b0344710b166693ee3.tar.gz
gentoo-1070db148f68baf9de30b1b0344710b166693ee3.tar.bz2
gentoo-1070db148f68baf9de30b1b0344710b166693ee3.zip
dev-python/ipython: version bump to 5.2.2.
Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3952
-rw-r--r--dev-python/ipython/Manifest1
-rw-r--r--dev-python/ipython/ipython-5.2.2.ebuild139
2 files changed, 140 insertions, 0 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index c73e79471ac0..d6a900525791 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -3,3 +3,4 @@ DIST ipython-4.0.3.tar.gz 6207899 SHA256 3a928f59e8ac8dd97858c28390867c87c09510f
DIST ipython-4.1.2.tar.gz 4953949 SHA256 052f9692a227f285febecec856d749811ac6a20b32c7629b4de31f04ea701692 SHA512 2a28a82cbc5d11cb1f1c88e452f52dbc6b196ac12d46cdec1f35d49e7f97aa8ee5c2a90a6f02f072297c4ef17f84a4454100a4b2594968ec46995c4fd459c09b WHIRLPOOL 1ae1fb4a88d9fd73c93ce096cdb4754d3153e156d87760b48825a2af3ec7eec3d3232b2b0f59f5fce94fb4e14b8c51361781527d9f5320a336ed786fc339567f
DIST ipython-4.2.0.tar.gz 4935042 SHA256 dba42f182b5f6f26630d2202efd30383712d9f7d8d8d9896b37ae2145deca616 SHA512 01c931a9745af7d43d174b761b506b78840ac9484007741665ff3d4a448131384194869552957353d07beb35e29187743353002c7c0a31f3b336f3b01a64a323 WHIRLPOOL 62468bef537d7533eaf9c89106bd7587dae70c921d623374c0ea796262e304cbf53020375c1876ebefb8b42e7d896b8b071afbcd5e1c710dac4a0a00783f3d82
DIST ipython-5.1.0.tar.gz 4945490 SHA256 7ef4694e1345913182126b219aaa4a0047e191af414256da6772cf249571b961 SHA512 84dbb5629d7a781abdadb9015dc637551bd57427d3187a55de3fb7f50d3d36afb1a8c0a5aaf75da95a8ff41ab623a3c6216373b2145914b960983ba0bf52c3c2 WHIRLPOOL 298e5c248a9d56ec3d9d9824ecee67da95c48d664a44643b8eede8e1719c7d6566b8dcc1fbf8cd4ae8f2829218ad189e9415fb931151b71402a40f326ca9cf01
+DIST ipython-5.2.2.tar.gz 4948601 SHA256 6ee1c89f6031e0c86727820ad394c6eb4d3ac28de48e0df3b9367ccf92e212e2 SHA512 ca4663adca98ce6e1a7e6d3a4e7050e64e73ab2ffeb49ad35322f002ee88fdb9db68ecd591cbadaf00d47df22890f70042d8671affed1a86dd24e609667c6d5c WHIRLPOOL ab6fb9b362b3697884df0c1d5208253fe8e341f6cce552bd4d74268f8fe76d0355ba7749d9f7defad641eafce2db0d35000850b4bb796aa4a2024564ddcaa472
diff --git a/dev-python/ipython/ipython-5.2.2.ebuild b/dev-python/ipython/ipython-5.2.2.ebuild
new file mode 100644
index 000000000000..03d9e02f0d9d
--- /dev/null
+++ b/dev-python/ipython/ipython-5.2.2.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE='readline,sqlite,threads(+)'
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Advanced interactive shell for Python"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc examples matplotlib mongodb notebook nbconvert qt4 +smp test wxwidgets"
+
+REQUIRED_USE="
+ test? ( doc matplotlib mongodb notebook nbconvert qt4 wxwidgets )
+ doc? ( mongodb )"
+
+CDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pickleshare[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-1.0.3[${PYTHON_USEDEP}]
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+ mongodb? ( <dev-python/pymongo-3[${PYTHON_USEDEP}] )
+ wxwidgets? ( $(python_gen_cond_dep 'dev-python/wxpython:*[${PYTHON_USEDEP}]' 'python2*') )"
+
+RDEPEND="${CDEPEND}
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ notebook? (
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ )
+ nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )"
+DEPEND="${CDEPEND}
+ >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2*')
+ test? (
+ app-text/dvipng
+ dev-python/jinja[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ )
+ doc? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/fabric[${PYTHON_USEDEP}]' 'python2*')
+ >=dev-python/jsonschema-2.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ dev-python/rpy[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0[${PYTHON_USEDEP}]
+ )"
+
+PDEPEND="
+ qt4? ( dev-python/qtconsole )
+ smp? ( dev-python/ipyparallel[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/2.1.0-substitute-files.patch
+ )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Remove out of date insource files
+ rm IPython/extensions/cythonmagic.py || die
+ rm IPython/extensions/rmagic.py || die
+
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html_noapi
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ pushd ${TEST_DIR} > /dev/null || die
+ "${EPYTHON}" -m IPython.testing.iptestcontroller --all || die
+ popd > /dev/null || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Create ipythonX.Y symlinks.
+ # TODO:
+ # 1. do we want them for pypy? No. pypy has no numpy
+ # 2. handle it in the eclass instead (use _python_ln_rel).
+ # With pypy not an option the dosym becomes unconditional
+ dosym ../lib/python-exec/${EPYTHON}/ipython \
+ /usr/bin/ipython${EPYTHON#python}
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ optfeature "sympyprinting" dev-python/sympy
+ optfeature "cythonmagic" dev-python/cython
+ optfeature "%lprun magic command" dev-python/line_profiler
+ optfeature "%mprun magic command" dev-python/memory_profiler
+ if use nbconvert; then
+ if ! has_version app-text/pandoc ; then
+ einfo "Node.js will be used to convert notebooks to other formats"
+ einfo "like HTML. Support for that is still experimental. If you"
+ einfo "encounter any problems, please use app-text/pandoc instead."
+ fi
+ fi
+}