summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-27 13:55:57 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-27 14:04:16 +0100
commit1672954ec257c66d0fc7383eba816e0c5f4bcdc6 (patch)
tree0e0419731c94a0463d3658f046d05b3d59a7c683
parentwww-apache/mod_backtrace: update EAPI 5 -> 7 (diff)
downloadgentoo-1672954ec257c66d0fc7383eba816e0c5f4bcdc6.tar.gz
gentoo-1672954ec257c66d0fc7383eba816e0c5f4bcdc6.tar.bz2
gentoo-1672954ec257c66d0fc7383eba816e0c5f4bcdc6.zip
www-apache/mod_whatkilledus: update EAPI 5 -> 7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--www-apache/mod_whatkilledus/mod_whatkilledus-2.01-r1.ebuild (renamed from www-apache/mod_whatkilledus/mod_whatkilledus-2.01.ebuild)17
1 files changed, 11 insertions, 6 deletions
diff --git a/www-apache/mod_whatkilledus/mod_whatkilledus-2.01.ebuild b/www-apache/mod_whatkilledus/mod_whatkilledus-2.01-r1.ebuild
index 29a55422dc59..708ceda8c228 100644
--- a/www-apache/mod_whatkilledus/mod_whatkilledus-2.01.ebuild
+++ b/www-apache/mod_whatkilledus/mod_whatkilledus-2.01-r1.ebuild
@@ -1,23 +1,22 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit apache-module depend.apache
DESCRIPTION="Debug segmentation faults in Apache threads"
HOMEPAGE="https://emptyhammock.com/projects/httpd/diag/"
-SRC_URI="https://emptyhammock.com/downloads/wku_bt-${PV}.zip"
+SRC_URI="https://emptyhammock.com/media/downloads/wku_bt-${PV}.zip"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND=">=www-apache/mod_backtrace-2.01
=www-servers/apache-2*[debug]"
-DEPEND="${RDEPEND}
- app-arch/unzip"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
APACHE2_MOD_CONF="10_${PN}"
APACHE2_MOD_DEFINE="BACKTRACE WHATKILLEDUS"
@@ -26,6 +25,12 @@ need_apache2
S="${WORKDIR}/wku_bt-${PV}"
+# Work around Bug #616612
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
+
src_compile() {
APXS2_ARGS="-c ${PN}.c diag.c -ldl"
apache-module_src_compile