summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-03 22:41:26 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-03 22:28:43 +0200
commit17484591c66a8101f4fed98bb84aaeed8544accd (patch)
tree2c1799a62d6c26a9e71f6db549f2a044d13c5a14
parentdev-python/pillow: Update remote-id (diff)
downloadgentoo-17484591c66a8101f4fed98bb84aaeed8544accd.tar.gz
gentoo-17484591c66a8101f4fed98bb84aaeed8544accd.tar.bz2
gentoo-17484591c66a8101f4fed98bb84aaeed8544accd.zip
media-video/obs-studio: add version 25.0.3
Closes: https://bugs.gentoo.org/715736 Closes: https://bugs.gentoo.org/716048 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/15219 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-video/obs-studio/Manifest1
-rw-r--r--media-video/obs-studio/obs-studio-25.0.3.ebuild145
2 files changed, 146 insertions, 0 deletions
diff --git a/media-video/obs-studio/Manifest b/media-video/obs-studio/Manifest
index cb13b7c1b42a..37f49edf27bc 100644
--- a/media-video/obs-studio/Manifest
+++ b/media-video/obs-studio/Manifest
@@ -1,3 +1,4 @@
DIST obs-studio-24.0.3.tar.gz 6285359 BLAKE2B f799e93e9c35c22e5d7f6e4da04e30b06a3a1ad1b3bfd0a75acdbb5d1f28a717d84809a1f35a858252ff30094fa80521d752a35b5285b0a606d0d77ff88fb3cf SHA512 57cef700076457da1eee344042261e1ada6d6744fcb3033a1d4eaffb9e84dd350aa198984fba3de82d4e727706f562c7c3568d95de6859a4942d9fa6368a02ab
DIST obs-studio-24.0.5.tar.gz 7901198 BLAKE2B 79c9712f3523114a70e0df3e0631c19067fd7ead5fd9031123dd4c82d9b92dee69473fb51a495f938430540505a5cf45258eeee01d61a7aaa6654255fee14aca SHA512 99be46046b70597474f25a85036ebe5a2f704eef47c77bc27e2ba8890b877da346ff6008c5922d7a83a4cead9df7214c6a3be885430693e609a42d9d06fedfaf
DIST obs-studio-25.0.1.tar.gz 8364968 BLAKE2B 4b77cde7d2d995fda8351c3be29e23d451f603e46cdd9137957ed149b17a35e361d00f2bf1b17794b7f30a7d5395cb0a27a50405132d30ad7dbe169a705cc374 SHA512 d62913e1f0f751f6946401e4bf5f10df5f421ff2bc348b067465c8eaea7a2a6b643f27946fb600f502713c5af05d6326342a36003302e614b9ae69d916dfdd80
+DIST obs-studio-25.0.3.tar.gz 8367286 BLAKE2B c87025f57fd2907f01c9b53464ba7174db2e19295bfd030aa8ad21356ef76d934bf9929c92c024f9ed9b96aa29a2e89dd08670baed94d2f4808f23533eec09c7 SHA512 16974bb1fbc54f3239dd92491186e608c14e209a77c485993db5815b50f2d7fd2462168377d7c254ad01c02a7daf30131efd9d2a8fe801628a0856f16e76cee0
diff --git a/media-video/obs-studio/obs-studio-25.0.3.ebuild b/media-video/obs-studio/obs-studio-25.0.3.ebuild
new file mode 100644
index 000000000000..33ca63777c33
--- /dev/null
+++ b/media-video/obs-studio/obs-studio-25.0.3.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit cmake-utils python-single-r1 xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/obsproject/obs-studio.git"
+ EGIT_SUBMODULES=()
+else
+ SRC_URI="https://github.com/obsproject/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Software for Recording and Streaming Live Video Content"
+HOMEPAGE="https://obsproject.com"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex +ssl truetype v4l vlc"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ luajit? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+"
+DEPEND="
+ >=dev-libs/jansson-2.5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtsql:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ media-libs/x264
+ media-video/ffmpeg:=[x264]
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib
+ virtual/udev
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libxcb
+ alsa? ( media-libs/alsa-lib )
+ fdk? ( media-libs/fdk-aac:= )
+ imagemagick? ( media-gfx/imagemagick:= )
+ jack? ( virtual/jack )
+ luajit? ( dev-lang/luajit:2 )
+ nvenc? (
+ || (
+ <media-video/ffmpeg-4[nvenc]
+ >=media-video/ffmpeg-4[video_cards_nvidia]
+ )
+ )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( ${PYTHON_DEPS} )
+ speex? ( media-libs/speexdsp )
+ ssl? ( net-libs/mbedtls:= )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype
+ )
+ v4l? ( media-libs/libv4l )
+ vlc? ( media-video/vlc:= )
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DDISABLE_ALSA=$(usex !alsa)
+ -DDISABLE_FREETYPE=$(usex !truetype)
+ -DDISABLE_JACK=$(usex !jack)
+ -DDISABLE_LIBFDK=$(usex !fdk)
+ -DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
+ -DDISABLE_SPEEXDSP=$(usex !speex)
+ -DDISABLE_V4L2=$(usex !v4l)
+ -DDISABLE_VLC=$(usex !vlc)
+ -DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
+ -DOBS_MULTIARCH_SUFFIX=${libdir#lib}
+ -DUNIX_STRUCTURE=1
+ -DWITH_RTMPS=$(usex ssl)
+ )
+
+ if [ "${PV}" != "9999" ]; then
+ mycmakeargs+=(
+ -DOBS_VERSION_OVERRIDE=${PV}
+ )
+ fi
+
+ if use luajit || use python; then
+ mycmakeargs+=(
+ -DDISABLE_LUA=$(usex !luajit)
+ -DDISABLE_PYTHON=$(usex !python)
+ -DENABLE_SCRIPTING=yes
+ )
+ else
+ mycmakeargs+=( -DENABLE_SCRIPTING=no )
+ fi
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ if ! use alsa && ! use pulseaudio; then
+ elog
+ elog "For the audio capture features to be available,"
+ elog "either the 'alsa' or the 'pulseaudio' USE-flag needs to"
+ elog "be enabled."
+ elog
+ fi
+
+ if ! has_version "sys-apps/dbus"; then
+ elog
+ elog "The 'sys-apps/dbus' package is not installed, but"
+ elog "could be used for disabling hibernating, screensaving,"
+ elog "and sleeping. Where it is not installed,"
+ elog "'xdg-screensaver reset' is used instead"
+ elog "(if 'x11-misc/xdg-utils' is installed)."
+ elog
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}