summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-11-12 16:23:01 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-11-12 16:23:01 +0100
commit1a2f7a84d5c462e837418a1c1238b39d88bbb773 (patch)
tree51f38149a48d44e29435a9d1a99af25ee7cb9403
parentmedia-libs/libde265: Stabilize 1.0.5 arm64, #754036 (diff)
downloadgentoo-1a2f7a84d5c462e837418a1c1238b39d88bbb773.tar.gz
gentoo-1a2f7a84d5c462e837418a1c1238b39d88bbb773.tar.bz2
gentoo-1a2f7a84d5c462e837418a1c1238b39d88bbb773.zip
net-nntp/sabnzbd: bump to v3.1.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--net-nntp/sabnzbd/Manifest1
-rw-r--r--net-nntp/sabnzbd/sabnzbd-3.1.1.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index 04df0d49fd72..9b9c8d156a8e 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -2,3 +2,4 @@ DIST SABnzbd-3.0.0-src.tar.gz 2673275 BLAKE2B 418ffd55c395c9d31e80f087c5e8c47e30
DIST SABnzbd-3.0.1-src.tar.gz 2674117 BLAKE2B 8143e449e70e0d17cc29437ed11a01d2d006f9840eb218d35a72d0da3dfe64d698ea239bbacc11d341b1a82b96e68dd10cff8145b46d41f85d3c3087779695e8 SHA512 0eefff2c9b64ba92b7f550a22aef21a718b603e5aa1f46818d7516e95c446e9edc556d0e2e16d69f9abad1a6f49146dd90331396f4858e8d7a2903890931e8cf
DIST SABnzbd-3.0.2-src.tar.gz 2687984 BLAKE2B 47719c247a1bf7bf16a3df0a0fea430c0cf335598ad8f34e6c7c8e9bd762afafc9fdda76c542d4327f9608ea8a845effa57090e07c511906bd782bf93373bb9c SHA512 023eb5f6ae31dab177584bff7f087269f50079e283d3d7873fc29d5f3438fdf2d0d0d49c8e4844d2b11e214510e1f7a60e635e0c37ca74b153f9ee2a9dede238
DIST SABnzbd-3.1.0-src.tar.gz 2735263 BLAKE2B b01f381c79287db2559176af6bd2409947d0c509e8aa48faf6ac614644e66b4090042eeac3d86b82d8d9b4e2bf92f3f360743d88f45db05f0969de189ac91fd5 SHA512 fb8ccbe82aff763847592668e5423f96dae6e0c70e42e2c7a58de1eb99ff552401df9178b4245d3a09968da1550948e382f65ada9341faeccd58f9b98eb4a680
+DIST SABnzbd-3.1.1-src.tar.gz 2735624 BLAKE2B 411963a49468cb0654be2f586790baaf1f0657491f7f1da848afe2d0fa89750cde8dc06c8a748fe6cb120d27a961881befb1100a234a28d7ec211b4435011576 SHA512 4e8debd2a0ef7379789df035f7d929e2b3dbf13d9394dfebb6075d8b877e610d4ef8953e98eeafd6048952738046bb6b9539e85516f8783c5e06bda1470b3c7e
diff --git a/net-nntp/sabnzbd/sabnzbd-3.1.1.ebuild b/net-nntp/sabnzbd/sabnzbd-3.1.1.ebuild
new file mode 100644
index 000000000000..114184f254fb
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-3.1.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+# Require python-2 with sqlite USE flag
+PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 systemd
+
+MY_PV="${PV/_rc/RC}"
+MY_PV="${MY_PV//_pre*}"
+
+MY_P="${PN/sab/SAB}-${MY_PV}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="https://sabnzbd.org/"
+SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${MY_PV}/${MY_P}-src.tar.gz"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+7za +rar unzip"
+
+# Sabnzbd is installed to /usr/share/ as upstream makes it clear they should not
+# be in python's sitedir. See: https://sabnzbd.org/wiki/advanced/unix-packaging
+
+COMMON_DEPS="
+ acct-user/sabnzbd
+ acct-group/sabnzbd
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_MULTI_USEDEP}]
+ dev-python/cheetah3[${PYTHON_MULTI_USEDEP}]
+ dev-python/cherrypy[${PYTHON_MULTI_USEDEP}]
+ dev-python/configobj[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/feedparser-6[${PYTHON_MULTI_USEDEP}]
+ dev-python/notify2[${PYTHON_MULTI_USEDEP}]
+ dev-python/portend[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/sabyenc-4[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+DEPEND="${COMMON_DEPS}"
+
+RDEPEND="
+ ${COMMON_DEPS}
+ >=app-arch/par2cmdline-0.4
+ net-misc/wget
+ 7za? ( app-arch/p7zip )
+ rar? ( || ( app-arch/unrar app-arch/rar ) )
+ unzip? ( >=app-arch/unzip-5.5.2 )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ MY_HOMEDIR="/var/lib/${PN}"
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ local d
+
+ for d in email icons interfaces locale po sabnzbd scripts tools; do
+ insinto "/usr/share/${PN}/${d}"
+ doins -r ${d}/*
+ done
+
+ exeinto "/usr/share/${PN}"
+ doexe SABnzbd.py
+
+ python_fix_shebang "${ED}/usr/share/${PN}"
+ python_optimize "${ED}/usr/share/${PN}"
+
+ newinitd "${FILESDIR}/${PN}-r1.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ diropts -o "${PN}" -g "${PN}"
+ dodir "/etc/${PN}"
+ keepdir "/var/log/${PN}"
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o "${PN}" -g "${PN}"
+ newins "${FILESDIR}"/${PN}-r1.ini ${PN}.ini
+
+ dodoc ISSUES.txt README.mkd
+
+ systemd_newunit "${FILESDIR}"/sabnzbd_at.service 'sabnzbd@.service'
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ einfo "Default directory: ${MY_HOMEDIR}"
+ einfo
+ einfo "To add a user to the sabnzbd group so it can edit SABnzbd+ files, run:"
+ einfo
+ einfo " usermod -a -G sabnzbd <user>"
+ einfo
+ einfo "By default, SABnzbd will listen on TCP port 8080."
+ else
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 3; then
+ ewarn
+ ewarn "Due to changes in this release, the queue will be converted when ${PN}"
+ ewarn "is started for the first time. Job order, settings and data will be"
+ ewarn "preserved, but all jobs will be unpaused and URLs that did not finish"
+ ewarn "fetching before the upgrade will be lost!"
+ ewarn
+ break
+ fi
+ done
+ fi
+}