summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-27 14:08:42 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-27 14:14:38 -0400
commit1efefa894f56cf96b1eca701f2961e59cc5bd840 (patch)
treeb6b47a497bfe76aed8ca7e5d48b45625bad5304f
parentapp-office/moneyguru: stable on amd64 (diff)
downloadgentoo-1efefa894f56cf96b1eca701f2961e59cc5bd840.tar.gz
gentoo-1efefa894f56cf96b1eca701f2961e59cc5bd840.tar.bz2
gentoo-1efefa894f56cf96b1eca701f2961e59cc5bd840.zip
app-office/moneyguru: bump to 3.0.0
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--app-office/moneyguru/Manifest1
-rw-r--r--app-office/moneyguru/moneyguru-3.0.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-office/moneyguru/Manifest b/app-office/moneyguru/Manifest
index c6fd4179caa3..a06a315af5a3 100644
--- a/app-office/moneyguru/Manifest
+++ b/app-office/moneyguru/Manifest
@@ -1 +1,2 @@
DIST moneyguru-2.13.1.tar.gz 1665892 BLAKE2B 969286130c5336f4c41ccf0ee3cbfe55a13560f753e137ff5370184c5aff3e038995c79ad48620a5653552406ea6fb56d356a209cd36774751db4f8e3777354c SHA512 9544a2fe17d0c1d4a6f1ee6c52c79e66ca76da6a6ac35067f1961fe2b44a8efe20173ee5932a91adeeebcb0a522b544df11ad388cb4c453a0641060d75f2a17c
+DIST moneyguru-3.0.0.tar.gz 1049954 BLAKE2B af411ea9cf965b93e6d3e88c47db74adc87ebb695862bef9a103ece0e56a5ec2c45e929a2a8bd405a41d3388c7561c69f7c54c41ae97e84f405a9c92385a162b SHA512 184d2e042014baea4f05f2f0397818cde4f86d726858ed253caac12e986660f85418c65657cc6fad1e3137195d55da35eceec3e8eaf23a01e81874dc20380e7f
diff --git a/app-office/moneyguru/moneyguru-3.0.0.ebuild b/app-office/moneyguru/moneyguru-3.0.0.ebuild
new file mode 100644
index 000000000000..ffe8516e22b5
--- /dev/null
+++ b/app-office/moneyguru/moneyguru-3.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Future-aware personal finances management"
+HOMEPAGE="https://hardcoded.net/moneyguru"
+SRC_URI="https://download.hardcoded.net/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets,printsupport]
+ dev-qt/qttranslations"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-util/cunit
+ )"
+
+_emake() {
+ emake CFLAGS="\$(DEFAULT_CFLAGS) ${CFLAGS}" \
+ SHEBANG="${PYTHON}" \
+ DESTDIR="${ED}" \
+ PREFIX=/usr \
+ $@
+}
+
+src_compile() {
+ _emake
+}
+
+src_install() {
+ _emake install
+}
+
+src_test() {
+ emake -C ccore CFLAGS="\$(DEFAULT_CFLAGS) ${CFLAGS}" tests
+ pytest -vv core || die "Tests failed with ${EPYTHON}"
+}