summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-05-10 19:50:16 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-05-10 19:50:16 +0000
commit23019ccd147245740efa8d6e9ac4472e9228cece (patch)
tree4673f5b64d7adfd0f3c566868118eafada8820b7
parent2021-05-10 19:05:31 UTC (diff)
parentdev-python/asyncstdlib: Add missing dep on typing-extensions (diff)
downloadgentoo-23019ccd147245740efa8d6e9ac4472e9228cece.tar.gz
gentoo-23019ccd147245740efa8d6e9ac4472e9228cece.tar.bz2
gentoo-23019ccd147245740efa8d6e9ac4472e9228cece.zip
Merge updates from master
-rw-r--r--dev-python/Faker/Faker-8.1.3.ebuild27
-rw-r--r--dev-python/Faker/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild2
-rw-r--r--dev-python/cfn-python-lint/Manifest1
-rw-r--r--dev-python/cfn-python-lint/cfn-python-lint-0.49.1.ebuild52
-rw-r--r--dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild2
-rw-r--r--dev-python/funcy/Manifest1
-rw-r--r--dev-python/funcy/funcy-1.16.ebuild24
-rw-r--r--dev-python/funcy/metadata.xml4
-rw-r--r--dev-python/numpy/Manifest4
-rw-r--r--dev-python/numpy/numpy-1.20.3.ebuild140
-rw-r--r--dev-python/pillow/pillow-8.2.0.ebuild2
-rw-r--r--dev-python/sphinx/Manifest1
-rw-r--r--dev-python/sphinx/sphinx-4.0.1.ebuild125
-rw-r--r--dev-python/watchdog/Manifest1
-rw-r--r--dev-python/watchdog/watchdog-2.1.1.ebuild38
-rw-r--r--dev-python/whatever/Manifest2
-rw-r--r--dev-python/whatever/metadata.xml4
-rw-r--r--dev-python/whatever/whatever-0.6.ebuild11
19 files changed, 435 insertions, 7 deletions
diff --git a/dev-python/Faker/Faker-8.1.3.ebuild b/dev-python/Faker/Faker-8.1.3.ebuild
new file mode 100644
index 000000000000..04ab1b4bc461
--- /dev/null
+++ b/dev-python/Faker/Faker-8.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="https://github.com/joke2k/faker"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/text-unidecode-1.3[${PYTHON_USEDEP}]
+ !dev-ruby/faker"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 9b9354988e20..1937d4de0d94 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -3,3 +3,4 @@ DIST Faker-8.0.0.tar.gz 1143250 BLAKE2B 594b21ab72016cda550e27d53b032b4e7fffa255
DIST Faker-8.1.0.tar.gz 1143544 BLAKE2B aadb12b681f335ff850c20fd9f3202520f265abab9844f4acce51a7c9435e74e5fd8faff8d2ca1d5d0b0ee7c786c05e2968ef84ecead4ab74b65d500876120a1 SHA512 d264b9740e66248b2dbed1331c1d632b9f30e9f7ebce0ff9e03b7f353da14b493a006af1deb0efdccc7911d99e17f741ed3196d76fc17d2b18af42dd01f052cc
DIST Faker-8.1.1.tar.gz 1143636 BLAKE2B 458bd0bc94dbf9dc60f5f1a74824390a3166dab7328274b087f299dfe637cc0ed728485ebc9418c2877bab7c05718ca1d9a592ed66a6bd4385585aabaeced8ea SHA512 705c890bea67176627eccc5a526cf20530485f1503813f09616d33a5407eefdea0416a6813b9efab719728b89d8be77cfef39d7297731ce3324852a9305717bb
DIST Faker-8.1.2.tar.gz 1143566 BLAKE2B bfef745578e2f33aef4ae925f53867e0c6335d03e8d2950d035a17a4e2efde959f841f62097708173ef1acc22511fcb6e2f81666aa8ba6e27aa0e5f1f63714e1 SHA512 da989478b122a6e583fdc1de2481d9c81b5f8c5a9c7274fd49dd057e8f2e417f91f5dbc160b0fd5a4b9ec749d3605e54dc20fb603ff36ae75a9d4fad827e46f7
+DIST Faker-8.1.3.tar.gz 1137819 BLAKE2B 12ff3c4d19df2138c7089d70b311a0191345c09c66ec01fdc961af6d0af069509bee41908eab0ad7af7aefa08e6706f651ff537abc3378c1afa007120bade3db SHA512 bad2d477b4e5225d8e1d1436157cf951f259bbb6ac09d99ddcf38ab953862fdfe953742dbcca0bbb40376f386be41f3a788dd85d57b66f1e19c626e699d23620
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild
index 0c31c6e1105c..9d70f7518c36 100644
--- a/dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild
+++ b/dev-python/asyncstdlib/asyncstdlib-3.9.1.ebuild
@@ -19,4 +19,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+RDEPEND="dev-python/typing-extensions[${PYTHON_USEDEP}]"
+
distutils_enable_tests pytest
diff --git a/dev-python/cfn-python-lint/Manifest b/dev-python/cfn-python-lint/Manifest
index 2d31b28942c4..16480d9935b4 100644
--- a/dev-python/cfn-python-lint/Manifest
+++ b/dev-python/cfn-python-lint/Manifest
@@ -1,2 +1,3 @@
DIST cfn-python-lint-0.48.3.tar.gz 6758651 BLAKE2B a8aeaffb0791789b25c94c630532ced223432f9902cf60664e4b111d162b4379d6307eda5c8f8074f7d2917ff25f44657016894b2140c8ea1dbf3259b24dde38 SHA512 ab1555719edb9b3541bfe60ce2701cca9e2ab9f4627c1b46ab8f4920477531f56f14f393b3575525da81b6aefd087b6c3cac516bdd6eb1db0f31304d7c63e1cb
DIST cfn-python-lint-0.49.0.tar.gz 6797106 BLAKE2B aa60c3e5eb246c45997af57f934d2710b56c4966babb61f56cc538c49606e3befd130f6a4298b124d38401927ae40127e699fba6a1f69ee177c07c9bf5d880e4 SHA512 4b656cda70de686aa3bb404908eac6ff66cabc0ebb064d5ccbe554a10551e8a5a7a308e3480826ec52b87549a8626f2a9cbbf51bd44613d94344db8dcd4443a7
+DIST cfn-python-lint-0.49.1.tar.gz 6906770 BLAKE2B 3115e610a73f072f56f0ed45ab8c88f7a906115437081d8974a135b3a9fbfcec4f677bdc108fa0ed37814caa6f0cc1e22fa7892d715c658e9ef05c8299f377a6 SHA512 4ceda24495aa43ad84ca7e63aa566521aab339f01308f5754372289a7f595d6805d6b1ac9bf637ba20a05bf17b93f8a06d5d1fd4dca3b8955094f54a62e28313
diff --git a/dev-python/cfn-python-lint/cfn-python-lint-0.49.1.ebuild b/dev-python/cfn-python-lint/cfn-python-lint-0.49.1.ebuild
new file mode 100644
index 000000000000..94cd12f60292
--- /dev/null
+++ b/dev-python/cfn-python-lint/cfn-python-lint-0.49.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-python-lint"
+SRC_URI="https://github.com/aws-cloudformation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.35.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' python3_6)
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install unittest
+
+PATCHES=(
+ "${FILESDIR}/cfn-python-lint-0.30.1-tests.patch"
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ # requires git checkout
+ sed -e 's:test_update_docs:_&:' \
+ -i test/unit/module/maintenance/test_update_documentation.py || die
+ # requires Internet
+ sed -e 's:test_update_resource_specs_python:_&:' \
+ -i test/unit/module/maintenance/test_update_resource_specs.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild b/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild
index 45bfb91ec8cf..1f1f660a98e5 100644
--- a/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild
+++ b/dev-python/funcparserlib/funcparserlib-0.3.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Recursive descent parsing library based on functional combinators"
diff --git a/dev-python/funcy/Manifest b/dev-python/funcy/Manifest
index 72cc98b61c01..3dea9a75752d 100644
--- a/dev-python/funcy/Manifest
+++ b/dev-python/funcy/Manifest
@@ -1 +1,2 @@
DIST funcy-1.15.tar.gz 605884 BLAKE2B dbcfe02981a09b2914096c7df9e0f37582dd4250bced71df92a1b10ce655291470f5ecb32ea4557307ba075e121d3199e0928566f9c25256c391ab821363023b SHA512 6e54da954bf11de55251a2732e9cee5617947322ea16a6a918ff3c5d7cb448756d29a39c4e997186cadc30d24270ccf4e6d21af9f108ebaabaed68e0be96f624
+DIST funcy-1.16.tar.gz 619331 BLAKE2B 55773e12356af6c7fac441cae186cb476f2acbba3b22efd902c2be460f0d021f829c5bf4351ce359fd2062ad47ad576bb74413152c64f2540a6a1b5f869f238e SHA512 e08397c49d66e6d0257b4b140483a139ffdb086dd98a277d499e5777474dc0c6d49055ca121fdc5a17964256d4970da495c09c50fdd2aef2af8839a9328a87ae
diff --git a/dev-python/funcy/funcy-1.16.ebuild b/dev-python/funcy/funcy-1.16.ebuild
new file mode 100644
index 000000000000..560dfe845b40
--- /dev/null
+++ b/dev-python/funcy/funcy-1.16.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="A collection of fancy functional tools focused on practicality"
+HOMEPAGE="https://github.com/Suor/funcy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/whatever[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
diff --git a/dev-python/funcy/metadata.xml b/dev-python/funcy/metadata.xml
index c5d6410f12f2..0204e0b82a3b 100644
--- a/dev-python/funcy/metadata.xml
+++ b/dev-python/funcy/metadata.xml
@@ -5,6 +5,10 @@
<email>tupone@gentoo.org</email>
<name>Tupone Alfredo</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">funcy</remote-id>
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index 42d7b76c750c..3d2796e42989 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -1,4 +1,8 @@
DIST numpy-1.20.2.zip 7756879 BLAKE2B 8b76942e04701e164029b145fed1747de72142ea4f5a8aa7472a01caeeed5e0b5b6d9e543106f9786e231df5a8afe3b7ad9256e69873e4f8876c659114bc494e SHA512 337a66d68c965da06f757a89b58d30b83ec0b2f3c7a3bb39496e5031e50fee6c4f2ec090202c3da9a20613864ea46d032ae75af1de5c33eebe515133ef37d40c
+DIST numpy-1.20.3.zip 7761912 BLAKE2B a4da49f7c1aadca299acb1b6d92deb4f50b1881c4b131cd389524a88ffc70179b2acdc88235dccd1ffd09879893db45b16bf2f54ced9b9639b806e85f7346285 SHA512 897be1cd6f3880711149dcedd838357e2d937a3c5f36b2a0db6ceed341654acf96b8b775610e1b43bdb6eacb987bbc51aaa8906244ca02cc8c2eae359ccef405
DIST numpy-html-1.16.4.zip 12097069 BLAKE2B db1f897342fbc80a761fbaee7b0eee3761dbfa04ef6c46a137bb2392caaec8256580467ce06498cceeada2639151a1ec75dafab484d64cb897c008727d6d32a5 SHA512 c44c5e1e0cb22f9dd46fe9e302030292d85e567456178fee296746a414271634e906509fb6665ac63fbfebdd13c5383574f0aa47b4fbc639063da31addc3316a
+DIST numpy-html-1.20.3.zip 22936526 BLAKE2B 9c0bf4edea0c34640a2f2d84f117aa383f8690f5c99eb9c504aa27c07195c1e5a4219efc798398d8de709803b67d4a41a2739b1319b6dd7aeba3e70e817c2488 SHA512 181ff49fcde40f2d260e480d4a90bd8b439aecafef4ea581749b5a432c7e8c163b1714a97fd447c512b550d5bf3d9b104c575b4939eb5c8b7b70bbce1153982a
DIST numpy-ref-1.16.4.pdf 5176571 BLAKE2B 9a875ebd1473b241d463d810a6d191581aef961158f2f82959671b554ace3ad482795e4f3e1cb7dd4632cff926c1e864c675a7624fb0f4e4f297948bf50f0564 SHA512 983ba0f34a70c011886bdbc9fd8f3f75a3a967ca29217acc76fa46e7da391296a5628c9a557ac76efb393271abfb8ee4f376d401c1cc1e5c30622e54b9325d09
+DIST numpy-ref-1.20.3.pdf 7362241 BLAKE2B bf17564d7aea0db25ca9ef6b24dbbd25093c09e2a93bb60b69220d4e666024c50f3373fdb65aac510c06420dc415102d552fb0435e1986330ffdc41e9e356098 SHA512 316e645402125ca41d1e8b4da33374703f4379c31cf572c8ad429e0e89b6968776f480f9159bce53b9fdec918f03b82e5bb6446f127f43f138d6c0990191af5a
DIST numpy-user-1.16.4.pdf 596203 BLAKE2B da3ad1f0ec1c965d20656f73a970911cbb58efa73a5df89e2e6485e0dd763f483e35eea1395ac919bf35d496fb216cee954fc5d31edebc1796a24a2a7a2d12b9 SHA512 3083008547213bfa98ffa5cd8e2cea13f6947f42d83aef61502a2a852b0d5f27d727c76b42d281d7a2f4f76c78e88b12ee3d9b164b39fe1f0213ace7097357d6
+DIST numpy-user-1.20.3.pdf 4977046 BLAKE2B 3548463cc878645bb169255d3332681685d0f05e02abf4cfcdd03773826d34f5a25c020240652839867a76258b25ca601ed292462f80bdf18b92ecfb46710487 SHA512 f6c37152228eac1fb69ddfc3a37454066ed678d57f12a587e0edcfe0adb390cc0b470384c2751033f7407bac44df9f69b0da4f3da1c300e6fc02231035ff634c
diff --git a/dev-python/numpy/numpy-1.20.3.ebuild b/dev-python/numpy/numpy-1.20.3.ebuild
new file mode 100644
index 000000000000..10bbd07b87e7
--- /dev/null
+++ b/dev-python/numpy/numpy-1.20.3.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+FORTRAN_NEEDED=lapack
+
+inherit distutils-r1 flag-o-matic fortran-2 multiprocessing toolchain-funcs
+
+DOC_PV=${PV}
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="https://numpy.org/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.zip
+ doc? (
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-html.zip -> numpy-html-${DOC_PV}.zip
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-ref.pdf -> numpy-ref-${DOC_PV}.pdf
+ https://numpy.org/doc/$(ver_cut 1-2 ${DOC_PV})/numpy-user.pdf -> numpy-user-${DOC_PV}.pdf
+ )"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc lapack"
+
+RDEPEND="
+ lapack? (
+ >=virtual/cblas-3.8
+ >=virtual/lapack-3.8
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ app-arch/unzip
+ >=dev-python/cython-0.29.21[${PYTHON_USEDEP}]
+ lapack? ( virtual/pkgconfig )
+ test? (
+ >=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.14.0[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/numpy-1.20.1-no-hardcode-blasv2.patch
+ "${FILESDIR}"/numpy-1.20.2-fix-ccompiler-tests.patch
+)
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use doc; then
+ unzip -qo "${DISTDIR}"/numpy-html-${DOC_PV}.zip -d html || die
+ fi
+}
+
+python_prepare_all() {
+ if use lapack; then
+ local incdir="${EPREFIX}"/usr/include
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF || die
+ [blas]
+ include_dirs = ${incdir}
+ library_dirs = ${libdir}
+ blas_libs = cblas,blas
+ [lapack]
+ library_dirs = ${libdir}
+ lapack_libs = lapack
+ EOF
+ else
+ export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
+ fi
+
+ export CC="$(tc-getCC) ${CFLAGS}"
+
+ append-flags -fno-strict-aliasing
+
+ # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
+ # with the subtle difference that we don't want to break Darwin where
+ # -shared is not a valid linker argument
+ if [[ ${CHOST} != *-darwin* ]]; then
+ append-ldflags -shared
+ fi
+
+ # only one fortran to link with:
+ # linking with cblas and lapack library will force
+ # autodetecting and linking to all available fortran compilers
+ append-fflags -fPIC
+ if use lapack; then
+ NUMPY_FCONFIG="config_fc --noopt --noarch"
+ # workaround bug 335908
+ [[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
+ fi
+
+ # don't version f2py, we will handle it.
+ sed -i -e '/f2py_exe/s: + os\.path.*$::' numpy/f2py/setup.py || die
+
+ # disable fuzzed tests
+ find numpy/*/tests -name '*.py' -exec sed -i \
+ -e 's:def \(.*_fuzz\):def _\1:' {} + || die
+ # very memory- and disk-hungry
+ sed -i -e 's:test_large_zip:_&:' numpy/lib/tests/test_io.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ export MAKEOPTS=-j1 #660754
+
+ distutils-r1_python_compile ${NUMPY_FCONFIG}
+}
+
+python_test() {
+ distutils_install_for_testing --single-version-externally-managed \
+ --record "${TMPDIR}/record.txt" ${NUMPY_FCONFIG}
+
+ cd "${TEST_DIR}/lib" || die
+ epytest
+}
+
+python_install() {
+ # https://github.com/numpy/numpy/issues/16005
+ local mydistutilsargs=( build_src )
+ distutils-r1_python_install ${NUMPY_FCONFIG}
+ python_optimize
+}
+
+python_install_all() {
+ local DOCS=( LICENSE.txt README.md THANKS.txt )
+
+ if use doc; then
+ local HTML_DOCS=( "${WORKDIR}"/html/. )
+ DOCS+=( "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf )
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pillow/pillow-8.2.0.ebuild b/dev-python/pillow/pillow-8.2.0.ebuild
index dad2ade882c8..26c8aec44163 100644
--- a/dev-python/pillow/pillow-8.2.0.ebuild
+++ b/dev-python/pillow/pillow-8.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
PYTHON_REQ_USE='tk?,threads(+)'
inherit distutils-r1 toolchain-funcs virtualx
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index dbd5fd9b1c9d..1e83dbec4ff8 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -1,2 +1,3 @@
DIST Sphinx-3.5.4.tar.gz 5911093 BLAKE2B 8740714dfaf3733bf57d0b277315b4e7b5cad86247ea30dcbc4f5dadf5f5169329050b7be43ec8625c47df9dcc19afcc6c4d782725c7007f8178b7eb7be7dc05 SHA512 853379f3b0496772846be9beb072c2c8a69ff899ffe4c6435b448ea639a32138c61403f9c14f62f4f78b2e526a2ee7c05b4196eabdeee37bcae6aa98df992125
DIST Sphinx-4.0.0.tar.gz 6104929 BLAKE2B 1f29e9c9e12957ed9c8f058b0b8ac3aa584db3867a6e4de35e73400362c2c25afd087a1048b8b35d59730d5401c51139173bd558a8fb0178f6f0351a5284f7cd SHA512 aa70be0a1a1f136257e253819fe7075116d48f21f2db716f87ca383737ff28c1c3e6a802fbf7ab3e9624c655966b5f02f746fb54f65ee9996da4bbee22294738
+DIST Sphinx-4.0.1.tar.gz 6161183 BLAKE2B 25ddb31a6db4eb1b76054be7026c327b47e33ec3efaa3eec70e5aae747931723baafe4b7b944ec4405589294698995bf7f5988187927f64db00ba77f44dccedc SHA512 a595840af092ce0748055a3112276649f67bdbd7aae05901eb3913fd4e415612f1b8594184c9a96de4f8aac82d21b6b6fb57cacb9cb7073c3799f31dfe244274
diff --git a/dev-python/sphinx/sphinx-4.0.1.ebuild b/dev-python/sphinx/sphinx-4.0.1.ebuild
new file mode 100644
index 000000000000..8dee8dd7b8f4
--- /dev/null
+++ b/dev-python/sphinx/sphinx-4.0.1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python documentation generator"
+HOMEPAGE="https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinx"
+SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="doc latex"
+
+RDEPEND="
+ <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/imagesize[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typed-ast[${PYTHON_USEDEP}]
+ ' python3_7)
+ latex? (
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+BDEPEND="
+ doc? (
+ dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ virtual/imagemagick-tools[jpeg,png,svg]
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.2.1-doc-link.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # disable internet access
+ sed -i -e 's:^intersphinx_mapping:disabled_&:' \
+ doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # Generate the grammar. It will be caught by install somehow.
+ # Note that the tests usually do it for us. However, I don't want
+ # to trust USE=test really running all the tests, especially
+ # with FEATURES=test-fail-continue.
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" -m sphinx.pycode.__init__ || die "Grammar generation failed."
+ popd >/dev/null || die
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
+ local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
+
+ local deselect=(
+ # these tests require Internet access
+ tests/test_build_latex.py::test_latex_images
+ tests/test_build_linkcheck.py::test_defaults
+ tests/test_build_linkcheck.py::test_defaults_json
+ tests/test_build_linkcheck.py::test_anchors_ignored
+ )
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ tests/test_ext_autodoc.py::test_autodoc_inherited_members_None
+ tests/test_ext_autodoc.py::test_automethod_for_builtin
+ tests/test_ext_autodoc.py::test_partialfunction
+ tests/test_ext_autodoc.py::test_autodoc_typed_instance_variables
+ tests/test_ext_autodoc.py::test_autodoc_typed_inherited_instance_variables
+ tests/test_ext_autodoc.py::test_cython
+ tests/test_ext_autodoc_autoclass.py::test_show_inheritance_for_subclass_of_generic_type
+ tests/test_ext_autodoc_autodata.py::test_autodata_type_comment
+ tests/test_ext_autodoc_autofunction.py::test_builtin_function
+ tests/test_ext_autodoc_autofunction.py::test_methoddescriptor
+ tests/test_ext_autodoc_configs.py::test_autodoc_typehints_signature
+ tests/test_ext_autodoc_configs.py::test_autodoc_type_aliases
+ tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module
+ tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module_skipped
+ tests/test_pycode_parser.py::test_annotated_assignment
+ tests/test_build_linkcheck.py::test_connect_to_selfsigned_fails
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index 80f3d0a975e7..d6acd9ca1d42 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -2,3 +2,4 @@ DIST watchdog-1.0.2.tar.gz 91796 BLAKE2B 001cbe82ff8aff0c4e56e4d1f02519047580ccc
DIST watchdog-2.0.2.tar.gz 95452 BLAKE2B e3a071cdf1c47698cd54bbaf925c4eb7e2af7398ced73aa332e57472cba2f5ce2ce1b96a31d3f5f3a525cabf81d5de528d95d0c59148150f407abb8ebc64538e SHA512 6134ad22b350b7b2893b564c4f02bd35b1be515fa18dd7f7000b191994b5ba48c5bf573819d2f363de227481a6bb8a0a14973e7c6611de367df2a3f228656ed1
DIST watchdog-2.0.3.tar.gz 95524 BLAKE2B 568e9d66efbfa98c19dab704681dbc48f869b59d51d7c7ff7ce1fd7465efcc6233f871e7f9276f2732692645491f2fd197a639b17e9a3d8abb76d0148a934796 SHA512 e1c506e4ead8c3ee8d19e456b67623f3a1823007be6c1fad0d76c697205696183e7bd15e46c21bf61abce6dd16d267e55da8986633eeee337d10c609318fb958
DIST watchdog-2.1.0.tar.gz 95833 BLAKE2B f11eb7961885fd0fbf8e6f888a069d77d9ff26b245bd3583e9060044c43a3356d56a334108c8c1a11735fffa779cc750bc390dd1510cf2c549ec9fe064899540 SHA512 65cc291927a61506fd2c26e05b85112e1cc0f26ca851138c62dfa34fae7958ee2b3946ffe586a9d2b7a48d59a6b5ce11c8dac276a3d78dcbeca8da011a880668
+DIST watchdog-2.1.1.tar.gz 96703 BLAKE2B cbcaff41de6111a3c9c2ff00b7c0a9ce1a769bb2b0f8e2af841a0783dd7f3a55f46003863b05eb983531211743fd112a6e63944193e10e8dd296523a1da27d59 SHA512 5b9eb75bc7b8642a8246f426a992265bbe2e5d82a3fcdd543289db7734701bdca1a868b02edfdc26ea239a89d80dd5322e410b949e419c66bdcc0645241d826b
diff --git a/dev-python/watchdog/watchdog-2.1.1.ebuild b/dev-python/watchdog/watchdog-2.1.1.ebuild
new file mode 100644
index 000000000000..0b8865d4eefb
--- /dev/null
+++ b/dev-python/watchdog/watchdog-2.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ default
+}
+
+python_test() {
+ epytest -p no:django
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}
diff --git a/dev-python/whatever/Manifest b/dev-python/whatever/Manifest
index 0a13a32bb428..dc2c8578b57f 100644
--- a/dev-python/whatever/Manifest
+++ b/dev-python/whatever/Manifest
@@ -1 +1 @@
-DIST whatever-0.6.tar.gz 4748 BLAKE2B c0a8b3bff715b61744ca5094c234c24558882d00b0dd8c375b90deef9d68155997cb97fb94435cb6dcfa0ba4674ce61fd6d030dd338409e8aaa5686c3bf9f3b1 SHA512 acdc145b81423908fd2d80bf0e8a0c02bad3a6156ec5a7724cf10b0f447c14354c34ac4ffa4e5a26788a79ce2a6b7bd65bb0ea281a6d8919dacd9a24ee1cde2d
+DIST whatever-0.6.gh.tar.gz 6003 BLAKE2B 410093960b8e17b1e0a7f91d7692bfd9e3f88a73cffb17a9a1763d42674cb1ec75da2b0a6575279c93451f24504086bdb89487bcc44bb116cbb2af89b9a7521b SHA512 f982100f0d6a8bf4c30e452a083c75f4cb2bca07e57e40ba4fd66baca752f039aea9519ffb97b3d43708df0ff5e981d0c4d03773f225106aa2f43e7770ee1975
diff --git a/dev-python/whatever/metadata.xml b/dev-python/whatever/metadata.xml
index 6d676f5f2eab..46d302b3f220 100644
--- a/dev-python/whatever/metadata.xml
+++ b/dev-python/whatever/metadata.xml
@@ -5,6 +5,10 @@
<email>tupone@gentoo.org</email>
<name>Tupone Alfredo</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="pypi">whatever</remote-id>
</upstream>
diff --git a/dev-python/whatever/whatever-0.6.ebuild b/dev-python/whatever/whatever-0.6.ebuild
index f6c9bab53d16..7465513bb9a3 100644
--- a/dev-python/whatever/whatever-0.6.ebuild
+++ b/dev-python/whatever/whatever-0.6.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
-DESCRIPTION="A collection of fancy functional tools focused on practicality"
+DESCRIPTION="Easy anonymous functions by partial application of operators"
HOMEPAGE="https://github.com/Suor/whatever"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+ https://github.com/Suor/whatever/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
+
+distutils_enable_tests pytest