summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:52:05 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:52:05 +0200
commit2c571d70d7686963bcd176851e5f6eaab9d4237a (patch)
treec84c7e228894fcb7b78e423da23a4651cf022c8a
parentsys-devel/bc: drop 1.06.95-r2 (EAPI 5) (diff)
downloadgentoo-2c571d70d7686963bcd176851e5f6eaab9d4237a.tar.gz
gentoo-2c571d70d7686963bcd176851e5f6eaab9d4237a.tar.bz2
gentoo-2c571d70d7686963bcd176851e5f6eaab9d4237a.zip
app-doc/abs-guide: update EAPI 5 -> 7
* Port to EAPI 7 * Add missing die * Use standard ebuild 'block structure' Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--app-doc/abs-guide/abs-guide-10.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/app-doc/abs-guide/abs-guide-10.ebuild b/app-doc/abs-guide/abs-guide-10.ebuild
index 7d403012ca56..0eba92d03470 100644
--- a/app-doc/abs-guide/abs-guide-10.ebuild
+++ b/app-doc/abs-guide/abs-guide-10.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
DESCRIPTION="An in-depth exploration of the art of shell scripting"
HOMEPAGE="https://www.tldp.org/LDP/abs/html"
SRC_URI="http://bash.deta.in/abs-guide-final.tar.bz2
pdf? ( http://bash.deta.in/abs-guide.pdf )"
+S="${WORKDIR}"/abs
LICENSE="public-domain"
-IUSE="pdf"
SLOT="0"
KEYWORDS="~alpha amd64 hppa ~mips ppc sparc x86"
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}/abs"
+IUSE="pdf"
src_unpack() {
unpack abs-guide-final.tar.bz2
- use pdf && cp "${DISTDIR}"/abs-guide.pdf "${S}"
+
+ if use pdf ; then
+ cp "${DISTDIR}"/abs-guide.pdf "${S}" || die
+ fi
}
src_install() {
@@ -30,9 +29,7 @@ src_install() {
}
pkg_postinst() {
- echo
- elog "The HTML docs can be accessed through /usr/share/doc/${P}/HTML/index.html"
- elog "Example scripts from the book are installed in /usr/share/doc/${P}/"
+ elog "The HTML docs can be accessed through ${EROOT}/usr/share/doc/${PF}/HTML/index.html"
+ elog "Example scripts from the book are installed in ${EROOT}/usr/share/doc/${PF}/"
use pdf && elog "along with the pdf version."
- echo
}