summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-02 13:35:23 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-02 14:36:53 +0200
commit3886bce03e5e17ee8bb053054ea09971942cd49c (patch)
treea8e95a619fd0ba39a732555072025bf603f2347d
parentmedia-tv/mythtv: Make repoman more happy (diff)
downloadgentoo-3886bce03e5e17ee8bb053054ea09971942cd49c.tar.gz
gentoo-3886bce03e5e17ee8bb053054ea09971942cd49c.tar.bz2
gentoo-3886bce03e5e17ee8bb053054ea09971942cd49c.zip
media-tv/tvheadend: Use zeroconf instead of avahi USE flag (#477620)
Package-Manager: portage-2.3.1
-rw-r--r--media-tv/tvheadend/tvheadend-4.0.9.ebuild6
-rw-r--r--media-tv/tvheadend/tvheadend-9999.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/media-tv/tvheadend/tvheadend-4.0.9.ebuild b/media-tv/tvheadend/tvheadend-4.0.9.ebuild
index 939aac745cf8..fa2ad2738980 100644
--- a/media-tv/tvheadend/tvheadend-4.0.9.ebuild
+++ b/media-tv/tvheadend/tvheadend-4.0.9.ebuild
@@ -17,13 +17,12 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="avahi capmt constcw +cwc dbus +dvb +dvbscan ffmpeg hdhomerun libav imagecache inotify iptv satip +timeshift uriparser xmltv zlib"
+IUSE="capmt constcw +cwc dbus +dvb +dvbscan ffmpeg hdhomerun libav imagecache inotify iptv satip +timeshift uriparser xmltv zeroconf zlib"
# does not build with ffmpeg-3 - bug 574990
# https://tvheadend.org/issues/3597
RDEPEND="dev-libs/openssl:=
virtual/libiconv
- avahi? ( net-dns/avahi )
dbus? ( sys-apps/dbus )
ffmpeg? (
!libav? ( <media-video/ffmpeg-3:= )
@@ -31,6 +30,7 @@ RDEPEND="dev-libs/openssl:=
)
hdhomerun? ( media-libs/libhdhomerun )
uriparser? ( dev-libs/uriparser )
+ zeroconf? ( net-dns/avahi )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -71,7 +71,6 @@ src_configure() {
--disable-ccache \
--nowerror \
--disable-hdhomerun_static \
- $(use_enable avahi) \
$(use_enable capmt) \
$(use_enable constcw) \
$(use_enable cwc) \
@@ -87,6 +86,7 @@ src_configure() {
$(use_enable satip satip_client) \
$(use_enable timeshift) \
$(use_enable uriparser) \
+ $(use_enable zeroconf avahi) \
$(use_enable zlib)
}
diff --git a/media-tv/tvheadend/tvheadend-9999.ebuild b/media-tv/tvheadend/tvheadend-9999.ebuild
index b7e392858f52..da3f05a55ba7 100644
--- a/media-tv/tvheadend/tvheadend-9999.ebuild
+++ b/media-tv/tvheadend/tvheadend-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,11 +14,10 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="avahi capmt constcw +cwc dbus +dvb +dvbscan ffmpeg hdhomerun libav imagecache inotify iptv satip +timeshift uriparser xmltv zlib"
+IUSE="capmt constcw +cwc dbus +dvb +dvbscan ffmpeg hdhomerun libav imagecache inotify iptv satip +timeshift uriparser xmltv zeroconf zlib"
RDEPEND="dev-libs/openssl:=
virtual/libiconv
- avahi? ( net-dns/avahi )
dbus? ( sys-apps/dbus )
ffmpeg? (
!libav? ( >=media-video/ffmpeg-3:= )
@@ -26,6 +25,7 @@ RDEPEND="dev-libs/openssl:=
)
hdhomerun? ( media-libs/libhdhomerun )
uriparser? ( dev-libs/uriparser )
+ zeroconf? ( net-dns/avahi )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -57,7 +57,6 @@ src_configure() {
--disable-ffmpeg_static \
--disable-ccache \
--disable-dvbscan \
- $(use_enable avahi) \
$(use_enable capmt) \
$(use_enable constcw) \
$(use_enable cwc) \
@@ -72,6 +71,7 @@ src_configure() {
$(use_enable satip satip_client) \
$(use_enable timeshift) \
$(use_enable uriparser) \
+ $(use_enable zeroconf avahi) \
$(use_enable zlib)
}