summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-24 11:14:28 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-24 11:14:28 +0100
commit3cf2955ead5e8fbf1ab435e4dca72150a9a21f3c (patch)
tree2ce348fcecc231232703492e00f25564b8768154
parentdev-util/vbindiff: drop old (diff)
downloadgentoo-3cf2955ead5e8fbf1ab435e4dca72150a9a21f3c.tar.gz
gentoo-3cf2955ead5e8fbf1ab435e4dca72150a9a21f3c.tar.bz2
gentoo-3cf2955ead5e8fbf1ab435e4dca72150a9a21f3c.zip
app-text/lv: bump up to EAPI=8
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--app-text/lv/lv-4.51-r5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/lv/lv-4.51-r5.ebuild b/app-text/lv/lv-4.51-r5.ebuild
new file mode 100644
index 000000000000..b67db19482ea
--- /dev/null
+++ b/app-text/lv/lv-4.51-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+MY_P="${PN}${PV//./}"
+
+DESCRIPTION="Powerful Multilingual File Viewer"
+HOMEPAGE="https://github.com/ttdoda/lv"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="!app-editors/levee
+ sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gentoo.patch
+ "${FILESDIR}"/${PN}-headers.patch
+ "${FILESDIR}"/${PN}-tinfo.patch
+ "${FILESDIR}"/${PN}-xz.patch
+)
+DOCS=( README hello.sample )
+HTML_DOCS=( index.html relnote.html hello.sample.gif )
+
+src_prepare() {
+ default
+
+ cd src
+ mv configure.{in,ac}
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE=src econf
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}