summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-04 03:07:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-04 03:07:58 +0200
commit3d54bca88fd315a9279187421c1608d4c63af39b (patch)
tree2c2253bc64af07dde58467fff846456e793ac2df
parentapp-text/libmwaw: 0.3.16 version bump (diff)
downloadgentoo-3d54bca88fd315a9279187421c1608d4c63af39b.tar.gz
gentoo-3d54bca88fd315a9279187421c1608d4c63af39b.tar.bz2
gentoo-3d54bca88fd315a9279187421c1608d4c63af39b.zip
media-gfx/graphite2: 1.3.14 version bump
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/graphite2/Manifest1
-rw-r--r--media-gfx/graphite2/graphite2-1.3.14.ebuild115
2 files changed, 116 insertions, 0 deletions
diff --git a/media-gfx/graphite2/Manifest b/media-gfx/graphite2/Manifest
index d1930261a2b9..e1d0dd2638a5 100644
--- a/media-gfx/graphite2/Manifest
+++ b/media-gfx/graphite2/Manifest
@@ -1 +1,2 @@
DIST graphite2-1.3.13.tgz 6664757 BLAKE2B 3faad44f7ba5e0729f722fd4589c5f6a4c53cffc2bb93615c8220d03c759dedf05924b1f56cafcf1c28e0a4b50fba0d319da30572fffde4baab6bc240528a0d3 SHA512 44ac2f353c1a795a55c78b4ff72df35a3a5a94700356c0eefe105d66cd499ac93f9cfd5ab7b3ea842b575156cb8df19e0b57ff8b9dbaee8a576319ff5889c131
+DIST graphite2-1.3.14.tgz 6630061 BLAKE2B 72bf6736aaa8476a89e44ef53c5b6c94f45d815fe1a451ba6b3696bfe023971210975dee4a9c8cb3042f36442e4efecf5baf171ef4230ad2b10694a89865f918 SHA512 14b5eb2ba8158b8b62ffa7fb142100a0af1de0f0c45b2673801b636714a106b46fcd423b05c722d963c9543fafcf10fec811975308211a54f20a3ba322d7b295
diff --git a/media-gfx/graphite2/graphite2-1.3.14.ebuild b/media-gfx/graphite2/graphite2-1.3.14.ebuild
new file mode 100644
index 000000000000..89ce22d2c571
--- /dev/null
+++ b/media-gfx/graphite2/graphite2-1.3.14.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+CMAKE_ECLASS=cmake
+GENTOO_DEPEND_ON_PERL="no"
+inherit perl-module python-any-r1 cmake-multilib
+
+DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
+HOMEPAGE="https://scripts.sil.org/cms/scripts/page.php?site_id=projects&item_id=graphite_home"
+SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="perl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ perl? ( dev-lang/perl:= )
+"
+DEPEND="${RDEPEND}
+ perl? (
+ dev-perl/Locale-Maketext-Lexicon
+ dev-perl/Module-Build
+ )
+ test? (
+ ${PYTHON_DEPS}
+ dev-libs/glib:2
+ $(python_gen_any_dep 'dev-python/fonttools[${PYTHON_USEDEP}]')
+ media-libs/fontconfig
+ perl? ( virtual/perl-Test-Simple )
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3.5-includes-libs-perl.patch" )
+
+pkg_setup() {
+ use perl && perl_set_version
+ use test && python-any-r1_pkg_setup
+}
+
+python_check_deps() {
+ has_version "dev-python/fonttools[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # make tests optional
+ if ! use test; then
+ sed -e '/tests/d' -i CMakeLists.txt || die
+ fi
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ # Renamed VM_MACHINE_TYPE to GRAPHITE2_VM_TYPE
+ -DGRAPHITE2_VM_TYPE=direct
+ )
+ # https://sourceforge.net/p/silgraphite/bugs/49/
+ [[ ${CHOST} == powerpc*-apple* ]] && mycmakeargs+=(
+ -DGRAPHITE2_NSEGCACHE:BOOL=ON
+ )
+
+ cmake_src_configure
+
+ # fix perl linking
+ if multilib_is_native_abi && use perl; then
+ # we rely on the fact that cmake_src_configure sets BUILD_DIR
+ sed -e "s:@BUILD_DIR@:\"${BUILD_DIR}/src\":" \
+ -i "${S}"/contrib/perl/Build.PL || die
+ fi
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+ if use perl; then
+ cd contrib/perl || die
+ perl-module_src_configure
+ perl-module_src_compile
+ fi
+}
+
+multilib_src_test() {
+ if multilib_is_native_abi; then
+ cmake_src_test
+ else
+ einfo "Cannot test since python is not multilib."
+ fi
+}
+
+src_test() {
+ cmake-multilib_src_test
+ if use perl; then
+ # Perl tests fail due to missing POD coverage...
+ perl_rm_files "contrib/perl/t/pod.t" "contrib/perl/t/pod-coverage.t"
+ cd contrib/perl || die
+ perl-module_src_test
+ fi
+}
+
+src_install() {
+ cmake-multilib_src_install
+ if use perl; then
+ cd contrib/perl || die
+ perl-module_src_install
+ perl_delete_localpod
+ fi
+
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}