summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-09-07 13:29:52 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-09-07 13:33:23 -0400
commit3e828ee766a6ebaa5c71ed1764f7998d59c24054 (patch)
tree5a9656054994abd214db55840332ad757902d0ed
parentsci-calculators/calculator: amd64 stable, bug #535832 (diff)
downloadgentoo-3e828ee766a6ebaa5c71ed1764f7998d59c24054.tar.gz
gentoo-3e828ee766a6ebaa5c71ed1764f7998d59c24054.tar.bz2
gentoo-3e828ee766a6ebaa5c71ed1764f7998d59c24054.zip
net-nntp/pan: fix newsrc-* files created in wrong place with g++-5
Gentoo-Bug: 559666 Reported-by: Holger Hoffstätte Upstream-Bug-url: https://bugzilla.gnome.org/show_bug.cgi?id=754698 Package-Manager: portage-2.2.20.1
-rw-r--r--net-nntp/pan/files/pan-0.139-get_pan_home.patch41
-rw-r--r--net-nntp/pan/pan-0.139-r1.ebuild55
2 files changed, 96 insertions, 0 deletions
diff --git a/net-nntp/pan/files/pan-0.139-get_pan_home.patch b/net-nntp/pan/files/pan-0.139-get_pan_home.patch
new file mode 100644
index 000000000000..6a2d5fc45143
--- /dev/null
+++ b/net-nntp/pan/files/pan-0.139-get_pan_home.patch
@@ -0,0 +1,41 @@
+From cef1d28d4a27fe383a74f4e5d0286aca3a28ff99 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 7 Sep 2015 13:21:22 -0400
+Subject: [PATCH] file::get_pan_home() : fix for g++-5 non-CoW std::string
+ semantics
+
+https://bugzilla.gnome.org/show_bug.cgi?id=754698
+---
+ pan/general/file-util.cc | 2 +-
+ pan/general/file-util.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pan/general/file-util.cc b/pan/general/file-util.cc
+index 4ea2e77..473e426 100644
+--- a/pan/general/file-util.cc
++++ b/pan/general/file-util.cc
+@@ -77,7 +77,7 @@ file :: print_file_info (std::ostream& os, const char* file)
+ ****
+ ***/
+
+-std::string
++const std::string &
+ file :: get_pan_home ()
+ {
+ static std::string pan_home;
+diff --git a/pan/general/file-util.h b/pan/general/file-util.h
+index 7c211a8..4b6d04f 100644
+--- a/pan/general/file-util.h
++++ b/pan/general/file-util.h
+@@ -59,7 +59,7 @@ namespace pan
+ * Returns the home pan directory, which falls back to $HOME/.pan2
+ * if the PAN_HOME environmental variable isn't set.
+ */
+- std::string get_pan_home ();
++ const std::string & get_pan_home ();
+
+ /**
+ * Returns an absolute filename of a file
+--
+2.5.1
+
diff --git a/net-nntp/pan/pan-0.139-r1.ebuild b/net-nntp/pan/pan-0.139-r1.ebuild
new file mode 100644
index 000000000000..382c8c2799d3
--- /dev/null
+++ b/net-nntp/pan/pan-0.139-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A newsreader for GNOME"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dbus gnome-keyring libnotify spell ssl"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-2.16:2
+ dev-libs/gmime:2.6
+ gnome-keyring? ( >=gnome-base/libgnome-keyring-3.2 )
+ libnotify? ( >=x11-libs/libnotify-0.4.1:0= )
+ spell? (
+ >=app-text/enchant-1.6
+ >=app-text/gtkspell-2.0.7:2 )
+ ssl? ( >=net-libs/gnutls-3:0= )"
+
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.35.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ # in next release
+ epatch "${FILESDIR}/${P}-pan.desktop.patch"
+
+ # g++-5 fix, https://bugzilla.gnome.org/show_bug.cgi?id=754698
+ epatch "${FILESDIR}"/${PN}-0.139-get_pan_home.patch
+
+ # upstream release was in 2012 - users may want to apply patches
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ --without-gtk3 \
+ $(use_with dbus) \
+ $(use_enable gnome-keyring gkr) \
+ $(use_with spell gtkspell) \
+ $(use_enable libnotify) \
+ $(use_with ssl gnutls)
+}