summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-14 09:36:15 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-14 09:36:56 +0200
commit45eaa6b8e646f975e9efdab763c87142a03a5c34 (patch)
tree7a7f8e180eae7ca39ed8f86aeed8936cd65a13fd
parentsys-kernel/gentoo-sources-4.9.122-r0: alpha stable (diff)
downloadgentoo-45eaa6b8e646f975e9efdab763c87142a03a5c34.tar.gz
gentoo-45eaa6b8e646f975e9efdab763c87142a03a5c34.tar.bz2
gentoo-45eaa6b8e646f975e9efdab763c87142a03a5c34.zip
app-editors/nano: Revbump to fix misbinding with upstream patch.
Removed old. Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--app-editors/nano/files/nano-3.0-misbinding.patch46
-rw-r--r--app-editors/nano/nano-3.0-r1.ebuild (renamed from app-editors/nano/nano-3.0.ebuild)4
2 files changed, 50 insertions, 0 deletions
diff --git a/app-editors/nano/files/nano-3.0-misbinding.patch b/app-editors/nano/files/nano-3.0-misbinding.patch
new file mode 100644
index 000000000000..2312edcff06c
--- /dev/null
+++ b/app-editors/nano/files/nano-3.0-misbinding.patch
@@ -0,0 +1,46 @@
+From 09ab2e3d0eeb33bc4d0702623404ba01b1f8fa9a Mon Sep 17 00:00:00 2001
+From: Benno Schulenberg <bensberg@telfort.nl>
+Date: Wed, 12 Sep 2018 13:18:17 +0200
+Subject: [PATCH] bindings: when Ctrl+Shift+Delete has no keycode, don't
+ use KEY_BSP
+
+When curses gives no code for Ctrl+Shift+Delete, do not fall back
+to KEY_BACKSPACE, because then ^H and/or <Backspace> get bound to
+'cutwordleft'.
+
+This fixes https://savannah.gnu.org/bugs/?54642.
+
+Bug was introduced with version 3.0, commit e6429e78.
+---
+ src/nano.c | 2 +-
+ src/nano.h | 1 +
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/nano.c b/src/nano.c
+index c7e0ca2d..74e12439 100644
+--- a/src/nano.c
++++ b/src/nano.c
+@@ -2580,7 +2580,7 @@ int main(int argc, char **argv)
+ controlhome = get_keycode("kHOM5", CONTROL_HOME);
+ controlend = get_keycode("kEND5", CONTROL_END);
+ controldelete = get_keycode("kDC5", CONTROL_DELETE);
+- controlshiftdelete = get_keycode("kDC6", KEY_BACKSPACE);
++ controlshiftdelete = get_keycode("kDC6", CONTROL_SHIFT_DELETE);
+ #ifndef NANO_TINY
+ /* Ask for the codes for Shift+Control+Left/Right/Up/Down. */
+ shiftcontrolleft = get_keycode("kLFT6", SHIFT_CONTROL_LEFT);
+diff --git a/src/nano.h b/src/nano.h
+index e1042759..7de34bf3 100644
+--- a/src/nano.h
++++ b/src/nano.h
+@@ -588,6 +588,7 @@ enum
+ #define SHIFT_CONTROL_DOWN 0x414
+ #define SHIFT_CONTROL_HOME 0x415
+ #define SHIFT_CONTROL_END 0x416
++#define CONTROL_SHIFT_DELETE 0x417
+ #define ALT_LEFT 0x421
+ #define ALT_RIGHT 0x422
+ #define ALT_UP 0x423
+--
+2.17.1
+
diff --git a/app-editors/nano/nano-3.0.ebuild b/app-editors/nano/nano-3.0-r1.ebuild
index 4d2b8d0818ed..44b716308be0 100644
--- a/app-editors/nano/nano-3.0.ebuild
+++ b/app-editors/nano/nano-3.0-r1.ebuild
@@ -31,6 +31,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
static? ( ${LIB_DEPEND} )"
+PATCHES=(
+ "${FILESDIR}"/${P}-misbinding.patch
+)
+
src_prepare() {
default
if [[ ${PV} == "9999" ]] ; then