summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <stefan.strogin@gmail.com>2019-02-10 18:03:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-16 00:07:33 +0100
commit4b67f7e3d266afb5df9af44e56c974189eefefc3 (patch)
treee634dcb95666fd70bf92da3624d6dab0fd6afd40
parentmedia-sound/vimpc: add myself as co-maintainer (diff)
downloadgentoo-4b67f7e3d266afb5df9af44e56c974189eefefc3.tar.gz
gentoo-4b67f7e3d266afb5df9af44e56c974189eefefc3.tar.bz2
gentoo-4b67f7e3d266afb5df9af44e56c974189eefefc3.zip
media-sound/vimpc: version bump to 0.09.2
Closes: https://bugs.gentoo.org/677664 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/vimpc/Manifest1
-rw-r--r--media-sound/vimpc/vimpc-0.09.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/media-sound/vimpc/Manifest b/media-sound/vimpc/Manifest
index d1360715c5a4..5308c771f44a 100644
--- a/media-sound/vimpc/Manifest
+++ b/media-sound/vimpc/Manifest
@@ -1 +1,2 @@
DIST vimpc-0.09.1.tar.gz 583073 BLAKE2B e2ab728a202cc7e5b9a1ffbca979274ae3f6b0f43acdacad51fdbbcd2c45f28dd9cf2f4372d085abc28633aec318f92a7632e54732516c51f20392c2d059e04f SHA512 cf40ae43ac21af80e1b5897f1fa83b4d730fb7dfa4c21b80c296a8e6f2c40e643325fd2aa96bd4dda1abca0ccd2d12545cf91ffcdb8017e5b9cd88917ca96222
+DIST vimpc-0.09.2.tar.gz 452593 BLAKE2B b6cbeab32318e723d7be114255fba7360fa2608d03bde6b2186d47b1cb8e74b4369d0d2b1d683cf5668232bf4581e9acb79d726308b18ff0d82122aa979f81a1 SHA512 456e2d2c0510273c071b24c2dd8f90b73d40a0b02565c00ea986a78f1231cb26fb053ce5b0d1476647c813b84684e400c21948086299e445ffd651c2af46d4c9
diff --git a/media-sound/vimpc/vimpc-0.09.2.ebuild b/media-sound/vimpc/vimpc-0.09.2.ebuild
new file mode 100644
index 000000000000..04c0f9dd2743
--- /dev/null
+++ b/media-sound/vimpc/vimpc-0.09.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="An ncurses based mpd client with vi-like key bindings"
+HOMEPAGE="https://github.com/boysetsfrog/vimpc"
+SRC_URI="https://github.com/boysetsfrog/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost taglib"
+
+RDEPEND="dev-libs/libpcre
+ media-libs/libmpdclient
+ boost? ( dev-libs/boost:= )
+ taglib? ( media-libs/taglib )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS README.md doc/vimpcrc.example )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable boost) \
+ $(use_enable taglib) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+}
+
+src_install() {
+ default
+
+ # vimpc will look for help.txt
+ docompress -x /usr/share/doc/${PF}/help.txt
+}