summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-02-24 20:36:14 -0500
committerCraig Andrews <candrews@gentoo.org>2018-02-24 20:37:58 -0500
commit4c1a66830d941bebb25edcce199b9b9709f33d40 (patch)
tree83cf8948dc7dffff1c4741649b517eb44e821ebb
parentnet-vpn/tor: Fix tor.service failure when /var/run is tmpfs (diff)
downloadgentoo-4c1a66830d941bebb25edcce199b9b9709f33d40.tar.gz
gentoo-4c1a66830d941bebb25edcce199b9b9709f33d40.tar.bz2
gentoo-4c1a66830d941bebb25edcce199b9b9709f33d40.zip
net-p2p/cpuminer-opt: 3.8.3.2 version bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.8.3.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index d46d875a5892..51482a022bed 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -3,3 +3,4 @@ DIST cpuminer-opt-3.8.0.tar.gz 1656474 BLAKE2B 145126762aeb245d042c1a208b60fd472
DIST cpuminer-opt-3.8.1.1.tar.gz 1657624 BLAKE2B d408d3da10ea6c0d91d0aa7097e52fb233f9a3c8f921c638899d18f99c1b1522c2d627d6869af6e650929da251f2bf6df87882ffb7169ac5a5633608d9399565 SHA512 f41e175492514c96d088c7f11aec88796b63d91aa8496794fac2222db24090685b4c76439bff39b5c074a5527494dfa8d1be6611b0040f5fca6436a80ea933f4
DIST cpuminer-opt-3.8.1.tar.gz 1654969 BLAKE2B b8805e748b71d3c7049d5c97dd74a51da55f88c697963c938a372ff5ff0ac72fcabce81b86f373fdca2dcef7393bba3f53c049bc30dfbd02691ff5e9630cf5bc SHA512 800edbecf5edb0902adc54480a4984602c19087d55675212832ce24df109b7d66544d9db78112a04c3c374521737e2680013d354b6ff8195a17abeb213e2a556
DIST cpuminer-opt-3.8.2.1.tar.gz 1668854 BLAKE2B d05238c27bb2fdc806937fde0db8fad81ad07a8f3a19414cf338a5262f112a2b6378657b7c901c41a8461f3ce62662da2758941eecb04f7efad809ffeb9403a3 SHA512 2ff1ac4923c90ebd59a1336cf0114be67571c8eb3d526467546c22a2a291778d77ef842fc814cdf88c589643faaad87dada95cc718680ffba91a19e7f53f1178
+DIST cpuminer-opt-3.8.3.2.tar.gz 1675230 BLAKE2B a0176c1152c695c1fde4f06911407b1aaf88fec8d275c64d2f117606ec82b26deda862a95ff1d866fcd7eece908be9ee1c5bb27d354e80665ab172d3d394dafc SHA512 610ce2bf8702882985d45d2db1cfa0655dcece47116908c2cd59489df1aa2a1f0b03c89af1a2cfa1ab0425e340b8e0b70c4f33b1399c414d90cabfc4f37bed3c
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.8.3.2.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.3.2.ebuild
new file mode 100644
index 000000000000..a1f4a660f6b9
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.8.3.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ curl? ( >=net-misc/curl-7.15[ssl] )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto $(use_with curl)
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}