summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-12 16:28:14 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-12 16:30:51 +0200
commit4d9805854edcd0f03423851a5c9075e936e96150 (patch)
treed16b106fc7e7a32323c491b06f4fbf23a1d6d81d
parentdev-python/pandas: Version Bump (diff)
downloadgentoo-4d9805854edcd0f03423851a5c9075e936e96150.tar.gz
gentoo-4d9805854edcd0f03423851a5c9075e936e96150.tar.bz2
gentoo-4d9805854edcd0f03423851a5c9075e936e96150.zip
media-gfx/shotwell: Fix for no matching linguas
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--media-gfx/shotwell/shotwell-0.22.0-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/media-gfx/shotwell/shotwell-0.22.0-r1.ebuild b/media-gfx/shotwell/shotwell-0.22.0-r1.ebuild
index b41ec6e16cd9..8d0369b88754 100644
--- a/media-gfx/shotwell/shotwell-0.22.0-r1.ebuild
+++ b/media-gfx/shotwell/shotwell-0.22.0-r1.ebuild
@@ -79,6 +79,7 @@ pkg_setup() {
src_prepare() {
local x
+ local linguas="en_GB ${LINGUAS}"
vala_src_prepare
sed \
-e 's|CFLAGS :|CFLAGS +|g' \
@@ -88,11 +89,10 @@ src_prepare() {
# remove disabled lenguages from build
for x in ${CORE_SUPPORTED_LANGUAGES}; do
- if ! has ${x} ${LINGUAS}; then
+ if ! has ${x} ${linguas}; then
sed -i "/^${x}$/d" "${S}"/po/LINGUAS || die
fi
done
- echo en_GB >> "${S}"/po/LINGUAS
}
src_configure() {