summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-15 22:16:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-16 00:07:32 +0100
commit4e1ea675b2a75d06c0fdf8f24bc8c6847eb60f83 (patch)
tree736112f20e7b49900a942b5b5683941c0a207329
parentmedia-gfx/darktable: Add missing || die (diff)
downloadgentoo-4e1ea675b2a75d06c0fdf8f24bc8c6847eb60f83.tar.gz
gentoo-4e1ea675b2a75d06c0fdf8f24bc8c6847eb60f83.tar.bz2
gentoo-4e1ea675b2a75d06c0fdf8f24bc8c6847eb60f83.zip
app-editors/leafpad: Switch from gnome2-utils to xdg, EAPI-7 bump
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-editors/leafpad/leafpad-0.8.18.1-r1.ebuild30
1 files changed, 11 insertions, 19 deletions
diff --git a/app-editors/leafpad/leafpad-0.8.18.1-r1.ebuild b/app-editors/leafpad/leafpad-0.8.18.1-r1.ebuild
index e1af082f7930..aacccf082f76 100644
--- a/app-editors/leafpad/leafpad-0.8.18.1-r1.ebuild
+++ b/app-editors/leafpad/leafpad-0.8.18.1-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit gnome2-utils xdg-utils
+EAPI=7
-DESCRIPTION="A simple GTK2 text editor"
+inherit xdg
+
+DESCRIPTION="Simple GTK2 text editor"
HOMEPAGE="http://tarot.freeshell.org/leafpad/"
SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
@@ -13,15 +14,16 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="emacs"
-RDEPEND="
- virtual/libintl
- x11-libs/gtk+:2
-"
-DEPEND="${RDEPEND}
+BDEPEND="
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig
"
+DEPEND="
+ virtual/libintl
+ x11-libs/gtk+:2
+"
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-fdo.patch
@@ -37,13 +39,3 @@ src_configure() {
--enable-print \
$(use_enable emacs)
}
-
-pkg_postinst() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- gnome2_icon_cache_update
-}