summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2018-06-18 13:34:27 +0100
committerTony Vroon <chainsaw@gentoo.org>2018-06-18 14:31:07 +0100
commit4eb290ca49ac2270122db0c4c4420c2b2456502f (patch)
treeb345b4de4633daef14cac3c788cbe597b49d654a
parentdev-util/hadolint: Remove old (diff)
downloadgentoo-4eb290ca49ac2270122db0c4c4420c2b2456502f.tar.gz
gentoo-4eb290ca49ac2270122db0c4c4420c2b2456502f.tar.bz2
gentoo-4eb290ca49ac2270122db0c4c4420c2b2456502f.zip
net-libs/libsrtp: 2.2.0 version bump
As requested by Arfrever Frehtes Taifersar on IRC. Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--net-libs/libsrtp/Manifest1
-rw-r--r--net-libs/libsrtp/files/libsrtp-2.2.0-pcap-automagic-r0.patch20
-rw-r--r--net-libs/libsrtp/libsrtp-2.2.0.ebuild73
3 files changed, 94 insertions, 0 deletions
diff --git a/net-libs/libsrtp/Manifest b/net-libs/libsrtp/Manifest
index 84f89dd671a1..6c73f314ae53 100644
--- a/net-libs/libsrtp/Manifest
+++ b/net-libs/libsrtp/Manifest
@@ -1,3 +1,4 @@
DIST libsrtp-1.6.0.tar.gz 1648862 BLAKE2B 5526d7659db160df3b6d9f14922bd731d083f04c6dd084ef473c439d720733d0fd8b38bdfe92e30e05a8a94c41df965d04bca52601b2644352428b49b1ed9093 SHA512 5ac712d0d343c3b63ed248503cc7d33c637895a274c4434c91f513be117836f27cd5daba83088b4647bbd9c82d841e216e6346af8d485cb9ddcd35dee21d4887
DIST libsrtp-2.0.0.tar.gz 265564 BLAKE2B ebae4a88fd5c77f3ed656569ee4300e4213d5be5c788efc84d8439a14a7773cfa60dc2b7c35a044ad1b5633af581f1526d1c3caa10e3ec800a2d66d5f837ce96 SHA512 61bba9aba9bb3e888c2bbc150411d0b3d583ed71ca455c5a3d4d6d06ecd383fdd61f86ad1979fb9c04da1b824e3fb9bb63f0d97e50b4a469d56907fb9dbc42d6
DIST libsrtp-2.1.0.tar.gz 306090 BLAKE2B c5055a66bf12997cd1b0d996a930d413d144280ccf40a1bed4b1ef10caa097f9c4fa40910a66a41bd8e33732b810d8ca5f7cb8acd9cb506cc42ab7e5b5adaf6e SHA512 60f4eb6fd37517eb96df80ab8a9c6fd79dfc89d969bdb04673cd98364f7108fbc703a64b1898056f9220a55315574b6f3f796b6814086360f6fd143e3b20fb3f
+DIST libsrtp-2.2.0.tar.gz 308469 BLAKE2B 4ef318bdf5c69b69b5869f478d5f0b9ee82d7d8a52440d10e931722c75b2f3a62b59f7542bb932cc93a21b7af24e6b253d70b4722833c5e1e5afce052e3b00e2 SHA512 3a5214b02199ae8dff45a2ed225ed9b1dcb75a9c6b07669e23bf86f97ad26e3e22b4930acdf3c56b21b605211a89a53a17c61602195b391a5b29a09823ba868c
diff --git a/net-libs/libsrtp/files/libsrtp-2.2.0-pcap-automagic-r0.patch b/net-libs/libsrtp/files/libsrtp-2.2.0-pcap-automagic-r0.patch
new file mode 100644
index 000000000000..1075825945cb
--- /dev/null
+++ b/net-libs/libsrtp/files/libsrtp-2.2.0-pcap-automagic-r0.patch
@@ -0,0 +1,20 @@
+diff -uNr libsrtp-2.2.0.ORIG/configure.ac libsrtp-2.2.0/configure.ac
+--- libsrtp-2.2.0.ORIG/configure.ac 2018-06-18 13:28:52.385014993 +0100
++++ libsrtp-2.2.0/configure.ac 2018-06-18 13:31:09.217020686 +0100
+@@ -273,6 +273,8 @@
+
+ dnl Checking for PCAP
+
++AC_ARG_ENABLE([pcap], AS_HELP_STRING([--disable-pcap], [Build without `pcap' library (-lpcap)]))
++AS_IF([test "x$enable_pcap" != "xno"], [
+ PCAP_LIB=""
+ AC_CHECK_LIB([pcap], [pcap_create],
+ [PCAP_LIB="-lpcap"
+@@ -284,6 +286,7 @@
+ AC_DEFINE([HAVE_PCAP], [1], [Define to 1 if you have the `winpcap' library (-lwpcap)])
+ AC_SUBST([HAVE_PCAP], [1])])
+ AC_SUBST([PCAP_LIB])
++])
+
+ AC_MSG_CHECKING([whether to redirect logging to stdout])
+ AC_ARG_ENABLE([log-stdout],
diff --git a/net-libs/libsrtp/libsrtp-2.2.0.ebuild b/net-libs/libsrtp/libsrtp-2.2.0.ebuild
new file mode 100644
index 000000000000..05aa4830df6b
--- /dev/null
+++ b/net-libs/libsrtp/libsrtp-2.2.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Open-source implementation of the Secure Real-time Transport Protocol (SRTP)"
+HOMEPAGE="https://github.com/cisco/libsrtp"
+SRC_URI="https://github.com/cisco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="aesicm console debug doc libressl openssl static-libs syslog test"
+
+RDEPEND="
+ openssl? (
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES )
+
+PATCHES=( "${FILESDIR}/${P}-pcap-automagic-r0.patch" )
+
+src_prepare() {
+ default
+
+ # test/rtpw.c is using /usr/share/dict/words assuming it exists
+ # using test/rtpw.c guaratees the file exists in any case
+ sed -i -e "s:/usr/share/dict/words:rtpw.c:" test/rtpw.c || die
+
+ eautoreconf
+
+ # sadly, tests are too broken to even consider using work-arounds
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ # stdout: default error output for messages in debug
+ # pcap: seems to be test-only
+ # openssl-kdf: OpenSSL 1.1.0+
+ econf \
+ --enable-log-stdout \
+ --disable-pcap \
+ --disable-openssl-kdf \
+ $(use_enable debug debug-logging) \
+ $(use_enable openssl)
+}
+
+multilib_src_compile() {
+ use static-libs && emake ${PN}2.a
+ emake shared_library
+ use test && emake test
+}
+
+multilib_src_test() {
+ LD_LIBRARY_PATH="${BUILD_DIR}" emake -j1 runtest
+
+ # Makefile.in has '$(testapp): libsrtp2.a'
+ if use !static-libs; then
+ rm libsrtp2.a || die
+ fi
+}
+
+multilib_src_install_all() {
+ # libsrtp.pdf can be generated with doxygen, but it seems to be broken.
+ use doc && DOCS+=( doc/*.txt )
+ einstalldocs
+}