summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-20 07:46:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-20 11:08:33 +0200
commit50148c57a33ccf014df5a566196a16a238fe9bb2 (patch)
tree36cdf0783166459de19552b33a7c37e15670a592
parentdev-python/botocore: Bump to 1.21.2 (diff)
downloadgentoo-50148c57a33ccf014df5a566196a16a238fe9bb2.tar.gz
gentoo-50148c57a33ccf014df5a566196a16a238fe9bb2.tar.bz2
gentoo-50148c57a33ccf014df5a566196a16a238fe9bb2.zip
dev-python/boto3: Bump to 1.18.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.18.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 914a640ebb22..65a08bbec7a4 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.17.104.tar.gz 387800 BLAKE2B 928824ab0a0c091fec430c5d86b0c5663f2a98
DIST boto3-1.17.112.tar.gz 391748 BLAKE2B 071eddfe134face48b86985ccd0171e0d8994fc65cd75e26945dfcab29566f42aa965c82b736cc7dd821a920e6903e4c45917af1759214606c2448b46c528cff SHA512 dcee3f4e2dfaf8feeeecc82ca938a72d654ced7a44f32e3dab43a225d8dcf0b3d20f0699770cfcd8ede840f792d37e124597d096322b88ce54c2e27e109da6e7
DIST boto3-1.18.0.tar.gz 392345 BLAKE2B 8d464e038892cd77d7b171c27f41eee31c630ebcadce6677f76ccc270f3f8471d7a8443d174ce1b6ea5cdcfe98973faa42ddda4123ec21d225464515bdcd862d SHA512 ba5af17ae6705bfdea4a9d6bccb18d3f1593980d594be4dbb3049123089ba7d8ecaaed685d8a3181ae50e95b537e7a50fed3be694b4f61d3ba250693ae249f4d
DIST boto3-1.18.1.tar.gz 392759 BLAKE2B bfa0bcfba9a413fbb13b2698f3ef2461cac99a9fddea0fe16d790a0ddab60fcd46b13ac4026536b9f89fb65ff703d61a4f01499423aa54289f17fc0f035ea2d6 SHA512 1aca424ff105fe2049c94aeaff306a683dd4eb9ac9b88303ff4857f53ddb4d3f267ef69119f8cbdb8463ab12331b2d89149fd0b10ccd23c4fde9485e63ba0005
+DIST boto3-1.18.2.tar.gz 393528 BLAKE2B 20424f9a8ff013d1d9724f741ad6754747de504fb961688f433eba74ce1d6df7e95d68c45be1e87df1532f99b2fa4d7e8b00671a8ae9a378a4df74764924cdaa SHA512 287a1f24f62fa83fd944632799540257b2f8d6cf3b5d6add57be60e4f49dafd685bb4fcceef37fe907edba00a7f2285d92bd8d381b03e45ac794b22fdcfe8783
diff --git a/dev-python/boto3/boto3-1.18.2.ebuild b/dev-python/boto3/boto3-1.18.2.ebuild
new file mode 100644
index 000000000000..819e73691110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.18.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ ||
+ die "test failed under ${EPYTHON}"
+}