summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2019-04-04 14:26:44 +0200
committerAndrey Grozin <grozin@gentoo.org>2019-04-04 14:26:44 +0200
commit535d4369e7dd4b38787a9178e3d7151ae9a38f87 (patch)
tree931ac7b4229bdde9a434dcfb6ef2c1e34abaeba5
parentapp-text/qpdfview: cleaning old (diff)
downloadgentoo-535d4369e7dd4b38787a9178e3d7151ae9a38f87.tar.gz
gentoo-535d4369e7dd4b38787a9178e3d7151ae9a38f87.tar.bz2
gentoo-535d4369e7dd4b38787a9178e3d7151ae9a38f87.zip
app-text/qpdfview: bump to the current snapshot
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--app-text/qpdfview/Manifest1
-rw-r--r--app-text/qpdfview/qpdfview-0.4.18_pre4.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/app-text/qpdfview/Manifest b/app-text/qpdfview/Manifest
index fe1ad879fbb4..ea1c426859c8 100644
--- a/app-text/qpdfview/Manifest
+++ b/app-text/qpdfview/Manifest
@@ -1,2 +1,3 @@
DIST qpdfview-0.4.16.tar.gz 636095 BLAKE2B b25da3ed1b4bacc02701f6cd2c4e282fd1c7b1fcac8faa1687c5089baefa328854c520ba803a333ea107e7b423a004f6476eb9a7adf67287d4d0807146094fed SHA512 d3ac05fc51d48533e44e58cd19e5d222a8bfbc9da4df02ece6a405d2fdd3346eb4614816ae91e89facf28e107b920ff3ce7b2ccc8c9b7832ae2595ef70d65584
DIST qpdfview-0.4.18_pre3.tar.gz 747794 BLAKE2B 08420a350ae6f8bba65efe2a930a8941a00182900e33266a03d9b6ded4b8ba7ac446de9ed8095f8876dfd3ecfb26b20cc146c82d9c9228fd5c136ad36d749061 SHA512 c72f766b0ffb175e0577f08975490b985e859cb41ccf1d6bcdb618664b96b3c4d0fe4ffab2e493ac20b87b85aa658f3beb5b0d430d21deae78df4c503649f1c0
+DIST qpdfview-0.4.18_pre4.tar.gz 782305 BLAKE2B 0e79a30e9774a1afb7f38bd932e8e1b2a7930acca217b7ac485f4857211449f5a8f902706b4638023667002d2f98fc116a180b2ec0219a360fe8c3025023cc39 SHA512 24431a27c279c290ce95a7db52f87e6cade0683dab53a3c494823020a7df9150919af31f20f63ff4c7337f5548b3e7252df0d8a6043a8c50ebb18e41f387838d
diff --git a/app-text/qpdfview/qpdfview-0.4.18_pre4.ebuild b/app-text/qpdfview/qpdfview-0.4.18_pre4.ebuild
new file mode 100644
index 000000000000..47d005b062d9
--- /dev/null
+++ b/app-text/qpdfview/qpdfview-0.4.18_pre4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PLOCALES="ast az be bg bs ca cs da de el en_AU en_GB eo es eu fa fi fr gl he hr hu id it ja kk ko ku ky lt lv ms my nb nds oc pl pt pt_BR ro ru sk sr sv th tr ug uk uz vi zh_CN zh_TW"
+
+inherit l10n qmake-utils xdg-utils gnome2-utils
+
+DESCRIPTION="A tabbed document viewer"
+HOMEPAGE="https://launchpad.net/qpdfview"
+SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="cups +dbus djvu fitz +pdf postscript +sqlite +svg synctex"
+
+REQUIRED_USE="?? ( fitz pdf )"
+
+RDEPEND="
+ cups? ( net-print/cups )
+ djvu? ( app-text/djvu )
+ fitz? ( >=app-text/mupdf-1.7:= )
+ postscript? ( app-text/libspectre )
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5[cups?]
+ dev-qt/qtwidgets:5
+ dbus? ( dev-qt/qtdbus:5 )
+ pdf? ( >=app-text/poppler-0.35[qt5]
+ dev-qt/qtxml:5 )
+ sqlite? ( dev-qt/qtsql:5[sqlite] )
+ svg? ( dev-qt/qtsvg:5 )
+ !svg? ( virtual/freedesktop-icon-theme )
+ synctex? ( app-text/texlive-core )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( CHANGES CONTRIBUTORS README TODO )
+
+src_prepare() {
+ local mylrelease="$(qt5_get_bindir)"/lrelease
+
+ prepare_locale() {
+ "${mylrelease}" "translations/${PN}_${1}.ts" || die "preparing ${1} locale failed"
+ }
+
+ rm_help() {
+ rm -f "help/help_${1}.html" || die "removing ${1} help file failed"
+ }
+
+ l10n_find_plocales_changes translations ${PN}_ .ts
+ l10n_for_each_locale_do prepare_locale
+ l10n_for_each_disabled_locale_do rm_help
+
+ # adapt for prefix
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" qpdfview.pri || die
+
+ default
+}
+
+src_configure() {
+ local myconfig=() i=
+ for i in cups dbus djvu pdf svg synctex; do
+ use ${i} || myconfig+=(without_${i})
+ done
+ use fitz && myconfig+=(with_fitz)
+ use postscript || myconfig+=(without_ps)
+ use sqlite || myconfig+=(without_sql)
+
+ local myqmakeargs=(
+ qpdfview.pro
+ CONFIG+="${myconfig[@]}"
+ PLUGIN_INSTALL_PATH="${EPREFIX}/usr/$(get_libdir)/${PN}"
+ )
+ eqmake5 "${myqmakeargs[@]}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}