summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2020-03-09 10:08:43 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-04-04 10:38:58 +0300
commit54defbd269995d139b5f27647a52b4c99e95964d (patch)
treeac35cdacedaa8afeb8f9fa9e22b88abc7a07558c
parentdev-libs/hyperscan: clean old (diff)
downloadgentoo-54defbd269995d139b5f27647a52b4c99e95964d.tar.gz
gentoo-54defbd269995d139b5f27647a52b4c99e95964d.tar.bz2
gentoo-54defbd269995d139b5f27647a52b4c99e95964d.zip
dev-libs/hyperscan: correct python dependencies
Python is build time dependency only. It works perfectly with python3 and there is no need to depend on Python2. Closes: https://bugs.gentoo.org/710218 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/hyperscan/hyperscan-5.2.1-r1.ebuild (renamed from dev-libs/hyperscan/hyperscan-5.2.1.ebuild)14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-libs/hyperscan/hyperscan-5.2.1.ebuild b/dev-libs/hyperscan/hyperscan-5.2.1-r1.ebuild
index 8789fd913c71..aa7ab14e7067 100644
--- a/dev-libs/hyperscan/hyperscan-5.2.1.ebuild
+++ b/dev-libs/hyperscan/hyperscan-5.2.1-r1.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..8} )
-inherit cmake python-r1 flag-o-matic
+inherit cmake flag-o-matic python-any-r1
DESCRIPTION="High-performance regular expression matching library"
SRC_URI="https://github.com/intel/hyperscan/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -16,12 +16,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+cpu_flags_x86_ssse3 static-libs"
-RDEPEND="${PYTHON_DEPS}
- dev-libs/boost"
+RDEPEND="dev-libs/boost"
DEPEND="${RDEPEND}"
-BDEPEND="dev-util/ragel"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ragel
+"
-REQUIRED_USE="cpu_flags_x86_ssse3 ${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="cpu_flags_x86_ssse3"
src_prepare() {
# upstream workaround