summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-08-25 07:24:47 +0200
committerHans de Graaff <graaff@gentoo.org>2017-08-25 07:24:47 +0200
commit5a5357288cfc4d510284943729c9dd22d363347e (patch)
treee9b6287ba71172c6eb01a0bf2f56c6408d1520d9
parentdev-ruby/mocha: add 1.3.0 (diff)
downloadgentoo-5a5357288cfc4d510284943729c9dd22d363347e.tar.gz
gentoo-5a5357288cfc4d510284943729c9dd22d363347e.tar.bz2
gentoo-5a5357288cfc4d510284943729c9dd22d363347e.zip
dev-ruby/addressable: add 2.5.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ruby/addressable/Manifest1
-rw-r--r--dev-ruby/addressable/addressable-2.5.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/addressable/Manifest b/dev-ruby/addressable/Manifest
index bec590a6383a..4c18f0034193 100644
--- a/dev-ruby/addressable/Manifest
+++ b/dev-ruby/addressable/Manifest
@@ -1,2 +1,3 @@
DIST addressable-2.4.0.gem 102400 SHA256 7abfff765571b0a73549c9a9d2f7e143979cd0c252f7fa4c81e7102a973ef656 SHA512 b81fa48e7c4188827c03ac93960b6fd6fb9f5a438f5243cddea39d6820ef756ee7c0086ec330dc4a3538008b3b254757af7d30248624127649cc006a2793eda8 WHIRLPOOL 6f245a158eb13b69add13a024421e88c8b4b5344f11b74bd95d9967fb265889e0123c63c041660d74994d08bcc18c345a34e91c45b20aef40ee5cbc5abfd80b7
DIST addressable-2.5.1.gem 103424 SHA256 b09603b313a94fa3674d8fbaae77cc7c778e9d3cde5fea3b7c1fe447941818c5 SHA512 ae7232dc6cbd1aa6405135c7916697a93286fcb223b14e2c30b5897aed6fe32529c94bfb84154e0cead5af9a282cc89442cbd3249b68abd7ffd67b6c4599bff3 WHIRLPOOL aeebce579a1f2dacd8672224a0c39e1ea4c9c26e1d5ef4aa3f84726df94b1f305e6cd4ad3569dd602997ccc9ad225a69c59e2f519a34d5856ba13fa20a818b21
+DIST addressable-2.5.2.gem 103936 SHA256 73771ea960b3900d96e6b3729bd203e66f387d0717df83304411bf37efd7386e SHA512 ddd5aeb4b241efa897a636fd85bd227bd5c6a8ae56129b6bbbdfaad85cdbb74e3d0db4bb6693f7df148b66f68ca1f557ac17a1fb0ea7698d25d883ab0b690bc4 WHIRLPOOL 38da8c97eed0c7837f4534a32d387223d68c3c69758557cf72b2ac0d568a96f08aece756eab6d404ee526e2a88a601fc13f4d5c12b78f349274958ee00adf999
diff --git a/dev-ruby/addressable/addressable-2.5.2.ebuild b/dev-ruby/addressable/addressable-2.5.2.ebuild
new file mode 100644
index 000000000000..aaef66c9be59
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/public_suffix-2.0.2:* <dev-ruby/public_suffix-4:*"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm -f tasks/rspec.rake || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '/^begin/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm -f spec/addressable/net_http_compat_spec.rb || die
+
+ # Remove spec that tests against an unreleased github fork
+ rm -f spec/addressable/rack_mount_compat_spec.rb || die
+}