summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-05-11 17:24:24 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-12 22:37:46 +0200
commit61e0b49c7b44dc8fa81f6aef4d299855bac51b68 (patch)
tree58c8a123c93de9d9d626bdea947cdab2c0f354eb
parentsys-fs/udev: remove unused patch (diff)
downloadgentoo-61e0b49c7b44dc8fa81f6aef4d299855bac51b68.tar.gz
gentoo-61e0b49c7b44dc8fa81f6aef4d299855bac51b68.tar.bz2
gentoo-61e0b49c7b44dc8fa81f6aef4d299855bac51b68.zip
dev-php/composer: bump to 1.6.5
Closes: https://github.com/gentoo/gentoo/pull/8144 Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--dev-php/composer/Manifest1
-rw-r--r--dev-php/composer/composer-1.6.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-php/composer/Manifest b/dev-php/composer/Manifest
index d945a0ef3c10..de9680060485 100644
--- a/dev-php/composer/Manifest
+++ b/dev-php/composer/Manifest
@@ -1 +1,2 @@
DIST composer-1.6.3.tar.gz 396955 BLAKE2B ee455c8ff7446fe2b51180c1c719a28a5efd30b24ba0f521ce07b02007bfaad15aea4d45b2a381d4a3abef123ce67077f8bf0bc3bee447752f3ab87bb6a5d46b SHA512 d373afe1bf8a5572f1d0bf3451d29ef1ea41f96a5fe54789e906601229d9366536ff0abdc7e0afa7cd14b22ccecf9ddf8b32fec14d4cd6fb308b878034af374c
+DIST composer-1.6.5.tar.gz 398169 BLAKE2B e89fb8805a58d031d4ba1e9694fb45eefa734d5ed79e1bd7c6aef02bf8a52ace19ed7fa109270d67af973f6892a45122017bc42bbd115245dc521e4720b5a549 SHA512 5f18a43af0b94006f4d553f03574347c7f279c409e3467ee65dfff12dad810d625a06452208e2024479faa0b1608ce122a293810e69b826667072171de7d905a
diff --git a/dev-php/composer/composer-1.6.5.ebuild b/dev-php/composer/composer-1.6.5.ebuild
new file mode 100644
index 000000000000..4edcaf353687
--- /dev/null
+++ b/dev-php/composer/composer-1.6.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*[curl]
+ >=dev-php/ca-bundle-1.0.0
+ >=dev-php/cli-prompt-1.0.0
+ >=dev-php/psr-log-1.0.2
+ dev-php/fedora-autoloader
+ >=dev-php/json-schema-3.0.0
+ >=dev-php/jsonlint-1.4.0
+ >=dev-php/phar-utils-1.0.0
+ >=dev-php/semver-1.0.0
+ >=dev-php/spdx-licenses-1.2.0
+ >=dev-php/symfony-console-2.7.9
+ >=dev-php/symfony-filesystem-2.7.20
+ >=dev-php/symfony-finder-2.7.20
+ >=dev-php/symfony-process-2.8.12"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+
+ # Composer expects the LICENSE file to be there, and the
+ # easiest thing to do is to give it what it wants.
+ doins -r src res LICENSE
+
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}"/autoload.php
+
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ dodoc CHANGELOG.md README.md doc/*.md
+ dodoc -r doc/articles doc/faqs
+}