summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-01 18:58:18 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-04 19:24:48 +0300
commit61e40a40ca352e48d113070134b3a141babbdb0b (patch)
tree7e17e2748fb0eb25c5eab94c151c1f7028b1306f
parentx11-wm/enlightenment: -fno-common temporary fix (diff)
downloadgentoo-61e40a40ca352e48d113070134b3a141babbdb0b.tar.gz
gentoo-61e40a40ca352e48d113070134b3a141babbdb0b.tar.bz2
gentoo-61e40a40ca352e48d113070134b3a141babbdb0b.zip
dev-python/pytest-lazy-fixture: version bump 0.6.3
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/pytest-lazy-fixture/Manifest1
-rw-r--r--dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-lazy-fixture/Manifest b/dev-python/pytest-lazy-fixture/Manifest
index a64ac487fbc9..3d0c08dad4bc 100644
--- a/dev-python/pytest-lazy-fixture/Manifest
+++ b/dev-python/pytest-lazy-fixture/Manifest
@@ -1 +1,2 @@
DIST pytest-lazy-fixture-0.6.2.tar.gz 7737 BLAKE2B 5257a19314a1c9bd159222a170e96db12e5f7b99d2bf83fd2db94acda9726f10997a81239763d8b0d5f2b9f2be6b74acf350d996cff09cf413d3a8ac76e2d90c SHA512 d8d159e936937f4b9364e9be7fcb8228497849a1ef342878ecc8471cd3b06782d2c6029365fd1e02f1ff89eb048ccae625b8697dc5048b4dd8fa61d839ca3f36
+DIST pytest-lazy-fixture-0.6.3.tar.gz 7878 BLAKE2B f3a034678f590090a453b44b9fea938ced040c80922f139f3321ec20db856be219d039c7f4199ef67af79b5008d37425b5c08a0edaf71fdd7c8f248702acf488 SHA512 3281edc516f21f23104d7fc188b5c9aecf364f55109dab52865cbfef4a540727eb2bd42fb9806a7e8be728b249bc7a224ffdbab96473f043bef9a7aea1e4baa8
diff --git a/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild
new file mode 100644
index 000000000000..2228e8fa7606
--- /dev/null
+++ b/dev-python/pytest-lazy-fixture/pytest-lazy-fixture-0.6.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="It helps to use fixtures in pytest.mark.parametrize"
+HOMEPAGE="https://github.com/tvorog/pytest-lazy-fixture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest