summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-09 11:36:41 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-09 12:11:18 +0200
commit6e629528b2294d02258ac64d00de6db9582e4357 (patch)
tree1ff926481c8012475a2926542944c5c6831a4b49
parentmedia-plugins/gst-plugins-smoothstreaming: Drop old (diff)
downloadgentoo-6e629528b2294d02258ac64d00de6db9582e4357.tar.gz
gentoo-6e629528b2294d02258ac64d00de6db9582e4357.tar.bz2
gentoo-6e629528b2294d02258ac64d00de6db9582e4357.zip
media-plugins/gst-plugins-smoothstreaming: Version bump
Package-Manager: portage-2.3.0
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/Manifest1
-rw-r--r--media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.8.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-smoothstreaming/Manifest b/media-plugins/gst-plugins-smoothstreaming/Manifest
index 7efa38d32d44..a67cb4310ddf 100644
--- a/media-plugins/gst-plugins-smoothstreaming/Manifest
+++ b/media-plugins/gst-plugins-smoothstreaming/Manifest
@@ -1 +1,2 @@
DIST gst-plugins-bad-1.6.3.tar.xz 4216940 SHA256 971b29101d6a9c5e3fe94d99d977a227f58f0b2d29b6ca2c7f292052542b3a61 SHA512 0a3a1d3617f167e69c20db3fccf7af0c4983b8012136093dcc3d08c059d0d8687cf921309c91f94afb250e0c3b9f9ff397a98ff548ca83dc12ae762119ffc915 WHIRLPOOL eb1f1376ee9b36da09f93b14d587169a007578f7cfdce3981ae905638c28f32b85a2f2667fc347f0b9ff4aaa51512f9726377c9ab3c73040886eab9a09833612
+DIST gst-plugins-bad-1.8.2.tar.xz 4455536 SHA256 d7995317530c8773ec088f94d9320909d41da61996b801ebacce9a56af493f97 SHA512 0b8a7df6b60f24655b463dedae71de6c92dbbbc3bdf42f4b722caaee17cd701ae3c078a2ca81a9d6568123aeade20a8a3759f72a7a9806f4533375d61ab028b6 WHIRLPOOL a7af68b86bfff8c19683dd5afaaed6ea627b6d2fa54103ccc1310909ff500d36ee2c72a5bd66f2074f2bcf9f8292733dd09101ece26c47b54a18598364e39415
diff --git a/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.8.2.ebuild b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.8.2.ebuild
new file mode 100644
index 000000000000..a70e262cb1af
--- /dev/null
+++ b/media-plugins/gst-plugins-smoothstreaming/gst-plugins-smoothstreaming-1.8.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="Smooth Streaming plugin"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gsturidownloader does not have a .pc
+ # gst-libs/gst/uridownloader:gsturidownloader \
+ # gst-libs/gst/adaptativedemux:gstadaptivedemux
+ gstreamer_system_link \
+ gst-libs/gst/codecparsers:gstreamer-codecparsers
+
+ local directory libs
+ directory="gst-libs/gst/uridownloader"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgsturidownloader-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/adaptivedemux"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgstapp-1.0 -lgsturidownloader-1.0 -lgstadaptivedemux-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/smoothstreaming/Makefile.{am,in} || die
+}