summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-18 08:37:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-18 08:40:20 -0500
commit811547697983aed1f28dce6d161190afdd35970d (patch)
tree72d71d304e551d96be676a20e9437c41ca41e6cd
parentapp-admin/puppetserver: bup (diff)
downloadgentoo-811547697983aed1f28dce6d161190afdd35970d.tar.gz
gentoo-811547697983aed1f28dce6d161190afdd35970d.tar.bz2
gentoo-811547697983aed1f28dce6d161190afdd35970d.zip
app-admin/puppet-agent: bup
Package-Manager: portage-2.2.26
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-1.4.0.ebuild99
2 files changed, 101 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index 91e32943c037..229bf5cc84d0 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -4,3 +4,5 @@ DIST puppet-agent_1.3.4-1wheezy_amd64.deb 20088688 SHA256 d98026bc27d680c6d67488
DIST puppet-agent_1.3.4-1wheezy_i386.deb 19864590 SHA256 7eaf2264fc0ce048fd1fc604f384df8d601e8571e9f92fb1432bc2be73a24874 SHA512 2640a6b0daaa2a9c913a9411a7eb56914bb127610d2bf56100f9029dc94727f3c42df7c858924b22fc5ad03a9151d98a136c0c6d369501f3e38a9c179333d2ff WHIRLPOOL 88dbebd7c5217d7efc85c877bc1977c574e17ca544a59424b805cebcad637ed5762ebe37c13d82dc01cebcd1ef1259383143adff7a748c82241124b2007d5513
DIST puppet-agent_1.3.6-1wheezy_amd64.deb 20097384 SHA256 47f04c848eff486660ba5ab4cc6c9340193ae0f9d703e0aba6094ccc7d15ec4f SHA512 a079f66bd0ff0b9535e037712ff4306ec16cc5303e1a19016a7ebb2d19f39eea1d91d758996d37e6d848cd0c1d8f047bcfad64550647de99de248071626a0845 WHIRLPOOL 42013e4abf062548b0349db3ebd628bfd887877462b3f24dbd47058bda59828c0f13f2f3bb8a7aace5d835faf3be0fbbaeb097c55c665aa71eec6d78881d71b7
DIST puppet-agent_1.3.6-1wheezy_i386.deb 19873296 SHA256 aaf16cffcf33070eda0979025b72c87d1528bf017f65dadc333defe623190065 SHA512 4d6390c6f9fd3464029ae8bde02e5f7536de7ecb701bc50a7a4a24f50102fcd542448729259148bb62343ed44e4e5b41ced670aed7a8aa3897fa2f7729fff9db WHIRLPOOL 17f7231cd5c546aa8a104aadec07457abebb71cccc1f8f718e7e0e5544b46502979b3079e1d3931f58d3d2d4232eb2ac82e5ee2c49c0ed54e280ef515575b45f
+DIST puppet-agent_1.4.0-1wheezy_amd64.deb 21367140 SHA256 322f3db0e1c2cebe675f6162411eecc9aec4e6a9d20daba4416ad914a7d562f0 SHA512 9d40ca518dfe5086f9fb738c971fed06b6f634f2069a0a10ae4ea4c1595db6c7122323dcbe1f871faed114acd1a3405146fb834fce964312391159b6e66edae5 WHIRLPOOL cf5f1649083e3224cffa5c1b16164e8cdb2a7fdc4756b97e12dfd6857e74e5923e04282d885ac963ef4fc386843e1014c489346836798eec1db5ed70d187a15e
+DIST puppet-agent_1.4.0-1wheezy_i386.deb 21107662 SHA256 88adf39e5fd7dba87f497c348797207df1f3192228d8601de9cbd155d481c31f SHA512 6651bb55b7ab4db5ce738dfa8ff555d385c7ea5c3806e5e3a961afaf58fc8923e44264bbd33b920871a84ebaa8b7003374a269467fe13454f7f498c18ba3afec WHIRLPOOL bffdcf7cffc6bf6dcce925728ac032c2fd7e2e19641eef200b60b5ec3fd1e0b87b44a6fd43c001cec0b69d96f050243252a0a954240568344ddcdb481010a700
diff --git a/app-admin/puppet-agent/puppet-agent-1.4.0.ebuild b/app-admin/puppet-agent/puppet-agent-1.4.0.ebuild
new file mode 100644
index 000000000000..b449a7ad7524
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-1.4.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with mcollective hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/wheezy/PC1/${PN:0:1}/${PN}/${PN}_${PV}-1wheezy"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/mcollective
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ sys-apps/dmidecode
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-3.1.0 )"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ /opt/puppetlabs/puppet
+ /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/mathn/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/io/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/dl/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/racc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/enc/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/json/ext/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/rbconfig/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/digest/*
+ /opt/puppetlabs/puppet/lib/ruby/2.1.0/x86_64-linux/*
+ /opt/puppetlabs/puppet/lib/engines/*
+ /opt/puppetlabs/puppet/lib/virt-what/*
+ /opt/puppetlabs/puppet/lib/*
+ /opt/puppetlabs/puppet/bin/*"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/mcollective
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/mcollective
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ newinitd "${FILESDIR}/mcollective.initd" mcollective
+ systemd_dounit "${FILESDIR}/puppet.service"
+ systemd_dounit "${FILESDIR}/mcollective.service"
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym /opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym /opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym /opt/puppetlabs/bin/mco /usr/bin/mco
+ dosym /opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym /opt/puppetlabs/puppet/bin/mcollectived /usr/sbin/mcollectived
+ dosym /opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym /opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym /opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+ dosym /opt/puppetlabs/puppet/bin/extlookup2hiera /usr/bin/extlookup2hiera
+}