summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-03-04 20:52:04 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-03-04 20:52:21 +0100
commit844671a9cc203605d9940fd62a826bd5864b9340 (patch)
treec5d9d0e767d07f34973b62ab7802394aae0f2bd6
parentmedia-sound/peercast: bump EAPI (diff)
downloadgentoo-844671a9cc203605d9940fd62a826bd5864b9340.tar.gz
gentoo-844671a9cc203605d9940fd62a826bd5864b9340.tar.bz2
gentoo-844671a9cc203605d9940fd62a826bd5864b9340.zip
sys-apps/accountsservice: version bump to 0.6.54
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Bug: https://bugs.gentoo.org/658682 Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--sys-apps/accountsservice/Manifest1
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.54.ebuild66
-rw-r--r--sys-apps/accountsservice/metadata.xml1
3 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/accountsservice/Manifest b/sys-apps/accountsservice/Manifest
index a3e3d7211afc..ba050bbd4750 100644
--- a/sys-apps/accountsservice/Manifest
+++ b/sys-apps/accountsservice/Manifest
@@ -1 +1,2 @@
DIST accountsservice-0.6.50.tar.xz 384484 BLAKE2B 52c06ba85498f292204834f967211d8f0940786dc2ea3070124d3aecccd551375bfbc8fc31f23a2c3c86e23359294307656c3b927c4e819fc102d8626ae0dd82 SHA512 6e07cd318452b1cbedeacd729f0ebb200525caf1b09981abb2bac16fd90756a790ebec08aca0a0cea016f14ab27c159a68fe1332ef4bc636c5863b8c61040f64
+DIST accountsservice-0.6.54.tar.xz 93048 BLAKE2B 4172fae397aa6d85c789fa5fafedb811efd1b07352476740e7a1eb61271dea4f9ae603b82e2fa89ea2c535a3713746d5292f011e90c9c4808170254b759e3d4f SHA512 5fbcccc286dba60efba905aa79b1b51a5478fe52bf2e256d40d9fc2d7a311aea4ce397365045659a4ef2ecb2cc079130fb1d0107749c3c906c394517056ac1c0
diff --git a/sys-apps/accountsservice/accountsservice-0.6.54.ebuild b/sys-apps/accountsservice/accountsservice-0.6.54.ebuild
new file mode 100644
index 000000000000..41e9796e0314
--- /dev/null
+++ b/sys-apps/accountsservice/accountsservice-0.6.54.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+
+inherit gnome.org gnome2-utils meson systemd
+
+DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/AccountsService/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc elogind gtk-doc +introspection selinux systemd +user-heuristics"
+REQUIRED_USE="?? ( elogind systemd )"
+
+CDEPEND="
+ >=dev-libs/glib-2.44:2
+ sys-auth/polkit
+ elogind? ( >=sys-auth/elogind-229.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ systemd? ( >=sys-apps/systemd-186:0= )
+ !systemd? ( !elogind? ( sys-auth/consolekit ) )
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto )
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-accountsd )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.35-gentoo-system-users.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc docbook)
+ $(meson_use elogind)
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use systemd)
+ $(meson_use user-heuristics user_heuristics)
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Dadmin-group="wheel"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ default
+
+ keepdir "${EPREFIX}/var/lib/lib/AccountsService/icons"
+ keepdir "${EPREFIX}/var/lib/lib/AccountsService/users"
+}
diff --git a/sys-apps/accountsservice/metadata.xml b/sys-apps/accountsservice/metadata.xml
index 69657d082aea..9c48896041d5 100644
--- a/sys-apps/accountsservice/metadata.xml
+++ b/sys-apps/accountsservice/metadata.xml
@@ -10,5 +10,6 @@
<pkg>sys-auth/consolekit</pkg> for session tracking</flag>
<flag name="systemd">Use <pkg>sys-apps/systemd</pkg> instead of
<pkg>sys-auth/consolekit</pkg> for session tracking</flag>
+ <flag name="user-heuristics">Enable heuristics for guessing system vs. human users in the range 500-minimum-uid</flag>
</use>
</pkgmetadata>