summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-09 14:12:55 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-09 14:12:55 +0100
commit869fdaa5823c8d06bb8698e9adf924098205ee5a (patch)
tree66d42f3cf05281a70082cdf845f0b7ac543384f9
parentdev-util/checkbashisms: [QA] Fix OutdatedBlocker (diff)
downloadgentoo-869fdaa5823c8d06bb8698e9adf924098205ee5a.tar.gz
gentoo-869fdaa5823c8d06bb8698e9adf924098205ee5a.tar.bz2
gentoo-869fdaa5823c8d06bb8698e9adf924098205ee5a.zip
dev-util/colorgcc: Port to EAPI 7
Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-util/colorgcc/colorgcc-1.3.2-r7.ebuild30
-rw-r--r--dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch12
-rw-r--r--dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch4
-rw-r--r--dev-util/colorgcc/files/colorgcc-1.3.2-nohang.patch4
-rw-r--r--dev-util/colorgcc/files/colorgcc-1.3.2-note.patch4
5 files changed, 24 insertions, 30 deletions
diff --git a/dev-util/colorgcc/colorgcc-1.3.2-r7.ebuild b/dev-util/colorgcc/colorgcc-1.3.2-r7.ebuild
index 60880cdc1e34..899387414cc4 100644
--- a/dev-util/colorgcc/colorgcc-1.3.2-r7.ebuild
+++ b/dev-util/colorgcc/colorgcc-1.3.2-r7.ebuild
@@ -1,18 +1,15 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
DESCRIPTION="Perl script to colorise the gcc output."
HOMEPAGE="http://schlueters.de/colorgcc.html"
SRC_URI="mirror://gentoo/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~alpha amd64 hppa ~mips ppc sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE=""
DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}"
@@ -24,24 +21,21 @@ PATCHES=(
"${FILESDIR}"/${P}-nohang.patch
)
-src_prepare() {
- epatch "${PATCHES[@]}"
-}
-
src_install() {
- dobin "${PN}"
- dodir "/etc/${PN}" "/usr/lib/${PN}/bin"
- insinto "/etc/${PN}"
- doins "${PN}rc"
+ dobin ${PN}
+
+ insinto /etc/${PN}
+ doins ${PN}rc
+
einfo "Scanning for compiler front-ends"
- into "/usr/lib/${PN}/bin"
- local COMPILERS=( gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++ )
+ dodir /usr/lib/${PN}/bin
+ local c COMPILERS=( gcc cc c++ g++ ${CHOST}-gcc ${CHOST}-c++ ${CHOST}-g++ )
for c in "${COMPILERS[@]}"; do
[[ -n "$(type -p ${c})" ]] && \
- dosym "/usr/bin/${PN}" "/usr/lib/${PN}/bin/${c}"
+ dosym ../../../bin/${PN} /usr/lib/${PN}/bin/${c}
done
- dodoc CREDITS ChangeLog
+ einstalldocs
}
pkg_postinst() {
diff --git a/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch b/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch
index 68a177ba75c7..13199715c9fa 100644
--- a/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch
+++ b/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-one.patch
@@ -1,5 +1,5 @@
---- colorgcc.orig 1999-04-29 10:16:08.000000000 -0700
-+++ colorgcc 2003-04-11 16:38:52.000000000 -0700
+--- a/colorgcc
++++ b/colorgcc
@@ -88,16 +88,16 @@
#
# 1.0.0 Initial Version
@@ -188,8 +188,8 @@
+ waitpid($compiler_pid, 0);
+ exit ($? >> 8);
+}
---- colorgccrc.orig 1999-04-29 10:16:08.000000000 -0700
-+++ colorgccrc 2003-02-12 17:38:38.000000000 -0800
+--- a/colorgccrc
++++ b/colorgccrc
@@ -20,12 +20,14 @@
# For example, srcColor: bold cyan on_yellow
#
@@ -225,8 +225,8 @@
errorMessageColor: bold red
-
-
---- INSTALL.orig 1999-04-29 10:16:08.000000000 -0700
-+++ INSTALL 2003-04-07 17:12:25.000000000 -0700
+--- a/INSTALL
++++ b/INSTALL
@@ -27,9 +27,9 @@
When "g++" is invoked, colorgcc is run instead. colorgcc looks at the
program name to figure out which compiler to use.
diff --git a/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch b/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch
index 911a31b21bf3..6cc033255a2a 100644
--- a/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch
+++ b/dev-util/colorgcc/files/colorgcc-1.3.2-gentoo-two.patch
@@ -1,5 +1,5 @@
---- colorgcc.r9 2003-09-21 12:14:48.000000000 -0700
-+++ colorgcc 2003-09-21 13:11:22.000000000 -0700
+--- a/colorgcc
++++ b/colorgcc
@@ -95,6 +95,7 @@
use Cwd 'abs_path';
diff --git a/dev-util/colorgcc/files/colorgcc-1.3.2-nohang.patch b/dev-util/colorgcc/files/colorgcc-1.3.2-nohang.patch
index 9602146b0af9..b14a92b59a63 100644
--- a/dev-util/colorgcc/files/colorgcc-1.3.2-nohang.patch
+++ b/dev-util/colorgcc/files/colorgcc-1.3.2-nohang.patch
@@ -1,5 +1,5 @@
---- /usr/bin/colorgcc 2010-12-13 00:08:37.000000000 -0200
-+++ colorgcc 2011-10-05 15:26:53.000000000 -0300
+--- a/colorgcc
++++ b/colorgcc
@@ -221,17 +221,16 @@
# Figure out which compiler to invoke based on our program name.
$0 =~ m%.*/(.*)$%;
diff --git a/dev-util/colorgcc/files/colorgcc-1.3.2-note.patch b/dev-util/colorgcc/files/colorgcc-1.3.2-note.patch
index 026503e8f2c9..52cdb165cdda 100644
--- a/dev-util/colorgcc/files/colorgcc-1.3.2-note.patch
+++ b/dev-util/colorgcc/files/colorgcc-1.3.2-note.patch
@@ -1,5 +1,5 @@
---- /usr/bin/colorgcc 2009-10-29 20:24:46.717190000 +0100
-+++ colorgcc 2009-10-29 20:27:42.614162888 +0100
+--- a/colorgcc
++++ b/colorgcc
@@ -102,7 +102,8 @@
$nocolor{"dumb"} = "true";