summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-19 14:55:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-19 15:07:21 +0200
commit877d246ac5e96d5c18691e9aa6af970d4bb30681 (patch)
tree3aeae4b39f800375c27582a0c96f9407004012ea
parentdev-ros/calibration_setup_helper: Bump to 0.10.14. (diff)
downloadgentoo-877d246ac5e96d5c18691e9aa6af970d4bb30681.tar.gz
gentoo-877d246ac5e96d5c18691e9aa6af970d4bb30681.tar.bz2
gentoo-877d246ac5e96d5c18691e9aa6af970d4bb30681.zip
dev-ros/image_cb_detector: Bump to 0.10.14.
Package-Manager: portage-2.2.28
-rw-r--r--dev-ros/image_cb_detector/Manifest1
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.14.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/image_cb_detector/Manifest b/dev-ros/image_cb_detector/Manifest
index 389070489594..93fa7e068080 100644
--- a/dev-ros/image_cb_detector/Manifest
+++ b/dev-ros/image_cb_detector/Manifest
@@ -1 +1,2 @@
DIST calibration-0.10.13.tar.gz 112305 SHA256 935755f9428e6b998d1a9ce10fcf11f3c119953ebe0b65eda855804ec8b8aea8 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb WHIRLPOOL 94423d70268b053daee1da1b324582d2f8316c6feaa5c9291715b1861520cb2e67654daaa2156e8d15cd59ecb566bdd3cb76d42c7202b85680888bac3532002c
+DIST calibration-0.10.14.tar.gz 112475 SHA256 1e65e6d8f793e7a27d1975ec3c4b63bf5249c7ce859dd11187258560901d1c77 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40 WHIRLPOOL 5c1ea989d438198044933927acfd7eb8426c9f5f253710ac63117b2a20c526acfea568f4b7b4f1930a43024bbcf4033f0f04c9e48108dc7e1cc629fb9e3c127f
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.14.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.14.ebuild
new file mode 100644
index 000000000000..5c19021411e3
--- /dev/null
+++ b/dev-ros/image_cb_detector/image_cb_detector-0.10.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Extracts checkerboard corners from ROS images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"