summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Privoznik <mprivozn@redhat.com>2018-10-22 14:21:07 +0100
committerMatthias Maier <tamiko@gentoo.org>2018-10-22 09:37:53 -0500
commit884fd0dce4dd73139b50a5ce3a153db14aa7512a (patch)
treef017a6c07e647a9f4d1e4589120ae3b7a5ba09ed
parentxfce-base/xfconf: Add missing dep on glib-utils (diff)
downloadgentoo-884fd0dce4dd73139b50a5ce3a153db14aa7512a.tar.gz
gentoo-884fd0dce4dd73139b50a5ce3a153db14aa7512a.tar.bz2
gentoo-884fd0dce4dd73139b50a5ce3a153db14aa7512a.zip
app-emulation/qemu-9999: Drop gtk2 use flag
QEMU has deprecated gtk2 support nearly a year ago, and recently it dropped the support completely (upstream commit 89d85cde75143). Reflect this change in the live ebuild. Signed-off-by: Michal Privoznik <mprivozn@redhat.com> Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 833c2349a4c9..555a20f9237d 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -28,7 +28,7 @@ HOMEPAGE="http://www.qemu.org http://www.linux-kvm.org"
LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bluetooth bzip2 capstone +caps +curl debug
- +fdt glusterfs gnutls gtk gtk2 infiniband iscsi +jpeg kernel_linux
+ +fdt glusterfs gnutls gtk infiniband iscsi +jpeg kernel_linux
kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs +png
pulseaudio python rbd sasl +seccomp sdl sdl2 selinux smartcard snappy
spice ssh static static-user systemtap tci test usb usbredir vde
@@ -50,14 +50,13 @@ IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
# Allow no targets to be built so that people can get a tools-only build.
# Block USE flag configurations known to not work.
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- gtk2? ( gtk )
qemu_softmmu_targets_arm? ( fdt )
qemu_softmmu_targets_microblaze? ( fdt )
qemu_softmmu_targets_mips64el? ( fdt )
qemu_softmmu_targets_ppc? ( fdt )
qemu_softmmu_targets_ppc64? ( fdt )
sdl2? ( sdl )
- static? ( static-user !alsa !bluetooth !gtk !gtk2 !opengl !pulseaudio !snappy )
+ static? ( static-user !alsa !bluetooth !gtk !opengl !pulseaudio !snappy )
virtfs? ( xattr )
vte? ( gtk )"
@@ -100,14 +99,8 @@ SOFTMMU_TOOLS_DEPEND="
>=net-libs/gnutls-3.0:=[static-libs(+)]
)
gtk? (
- gtk2? (
- x11-libs/gtk+:2
- vte? ( x11-libs/vte:0 )
- )
- !gtk2? (
- x11-libs/gtk+:3
- vte? ( x11-libs/vte:2.91 )
- )
+ x11-libs/gtk+:3
+ vte? ( x11-libs/vte:2.91 )
)
infiniband? (
sys-fabric/libibumad:=[static-libs(+)]
@@ -495,7 +488,6 @@ qemu_src_configure() {
conf_opts+=(
--audio-drv-list="${audio_opts}"
)
- use gtk && conf_opts+=( --with-gtkabi=$(usex gtk2 2.0 3.0) )
use sdl && conf_opts+=( --with-sdlabi=$(usex sdl2 2.0 1.2) )
fi