summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-28 12:23:25 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-28 12:35:04 +0200
commit8c23a6fb32bc9bdfbecee3a11f272863412e4122 (patch)
tree815f36b36cc22ee2fd367fb9da2f97d5ce7e29ea
parentnet-libs/grpc: fix libdir in pkgconfig files (diff)
downloadgentoo-8c23a6fb32bc9bdfbecee3a11f272863412e4122.tar.gz
gentoo-8c23a6fb32bc9bdfbecee3a11f272863412e4122.tar.bz2
gentoo-8c23a6fb32bc9bdfbecee3a11f272863412e4122.zip
net-fs/nfs-utils: Bump to version 2.3.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--net-fs/nfs-utils/Manifest1
-rw-r--r--net-fs/nfs-utils/files/nfs-utils-2.3.2-junction_libs.patch45
-rw-r--r--net-fs/nfs-utils/metadata.xml1
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.3.2.ebuild188
4 files changed, 235 insertions, 0 deletions
diff --git a/net-fs/nfs-utils/Manifest b/net-fs/nfs-utils/Manifest
index 481ced342437..0448778a503e 100644
--- a/net-fs/nfs-utils/Manifest
+++ b/net-fs/nfs-utils/Manifest
@@ -5,3 +5,4 @@ DIST nfs-utils-2.2.1.tar.bz2 853812 BLAKE2B bc973f8fe781f7658161d0d5895bc32ffeea
DIST nfs-utils-2.2.2_rc1.tar.gz 509381 BLAKE2B 8429cd9d01ce2a15451d21b89cabc6b50b54bd30d2e12a21f04d4be04a6e729a8bd3a8da3f0d120caf6ba2b0c91199f65f1c878a49d437e0c689bcba9f5d162f SHA512 5cc9a19e1ebf1831f1914419c0e7f12ff12037caa35e5866dfba8bf30c5355dcf2e039928b9b336c6755df856549ccac6ea646d61b57c68f96fd586d21a27f1a
DIST nfs-utils-2.2.2_rc1_p20171107.tar.gz 509543 BLAKE2B 44c5bf63b16b7727f6cdba0d1051929f6e132b87fcb8e9e18a0ad699dfeec1b26f9988fc7b5db5dbcc1dd3c04f1dd30fa0f89616fe86cbfd4dbb36f0d8aed08b SHA512 27e38fe3ff2d94aa45a526343c88c781b39db4f85b2fd50b632516be609f7a05dced115e26f73176ba28409cd38a3c7db6ddb8370ab75071150b1cf3fba46e43
DIST nfs-utils-2.3.1.tar.bz2 854899 BLAKE2B f9541b9dc103d978f21d57d8ba0c14a3b30f6ba874b112239d014076c1c72b6654e8e02b4bfea686e658dac84d1e896b872bc2054591275ef1713ae4e7b7d005 SHA512 de3e70f8656bc5b5aa98262685a9e80929c6314234d9bbb74d4c7efcb7a8b2640d48d2100850b403157ebefc8f0eb48598b48238fae795f64c7a0e9a8bff93e3
+DIST nfs-utils-2.3.2.tar.bz2 884068 BLAKE2B c4133cc12c5c1cd33346408e2d1286cf50880a89ec97cb8ce4453266ba5b145eb1ca7a4362ac1a91ea5c1ebddd4fcd1d6a4cd12f45637cd5d845cc6d8d5f139d SHA512 4b948d92f515e9340163f53ab26dd7189fa8b13909f5c668b7c66ae13f181ed778967edc0a20753763540b5a3f93a41a2de38a7276ffbfadfd866c5ed422520c
diff --git a/net-fs/nfs-utils/files/nfs-utils-2.3.2-junction_libs.patch b/net-fs/nfs-utils/files/nfs-utils-2.3.2-junction_libs.patch
new file mode 100644
index 000000000000..f13f07a4c81f
--- /dev/null
+++ b/net-fs/nfs-utils/files/nfs-utils-2.3.2-junction_libs.patch
@@ -0,0 +1,45 @@
+From 8f3e4f4d6df9f813572051e12e974b35c26a1743 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 28 May 2018 12:13:10 +0200
+Subject: [PATCH] Fix undefined references and bad include when build with
+ junction support
+
+---
+ support/junction/Makefile.am | 2 +-
+ utils/nfsref/Makefile.am | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/support/junction/Makefile.am b/support/junction/Makefile.am
+index 97e7426..89cb532 100644
+--- a/support/junction/Makefile.am
++++ b/support/junction/Makefile.am
+@@ -31,4 +31,4 @@ libjunction_la_SOURCES = display.c export-cache.c junction.c \
+
+ MAINTAINERCLEANFILES = Makefile.in
+
+-AM_CPPFLAGS = -I. -I../include -I/usr/include/libxml2
++AM_CPPFLAGS = -I. -I../include -I/usr/include/libxml2 @TIRPC_CFLAGS@
+diff --git a/utils/nfsref/Makefile.am b/utils/nfsref/Makefile.am
+index 2b2bb53..a652b03 100644
+--- a/utils/nfsref/Makefile.am
++++ b/utils/nfsref/Makefile.am
+@@ -27,13 +27,13 @@ noinst_HEADERS = nfsref.h
+
+ sbin_PROGRAMS = nfsref
+ nfsref_SOURCES = add.c lookup.c nfsref.c remove.c
+-LDADD = $(LIBXML2) $(LIBCAP) \
+- ../../support/nfs/libnfs.la \
++LIBS += $(LIBXML2) $(LIBCAP)
++LDADD = ../../support/nfs/libnfs.la \
+ ../../support/junction/libjunction.la
+
+ man8_MANS = nfsref.man
+
+ MAINTAINERCLEANFILES = Makefile.in
+
+-AM_CPPFLAGS = -I. -I../../support/include
++AM_CPPFLAGS = -I. -I../../support/include @TIRPC_CFLAGS@
+ ##AM_LDFLAGS = -Wl,--as-needed
+--
+2.17.0
+
diff --git a/net-fs/nfs-utils/metadata.xml b/net-fs/nfs-utils/metadata.xml
index 34459d2e1627..45351e446376 100644
--- a/net-fs/nfs-utils/metadata.xml
+++ b/net-fs/nfs-utils/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<longdescription>NFS client and server daemons</longdescription>
<use>
+ <flag name="junction">Enable NFS junction support in nfsref</flag>
<flag name="ldap">Add ldap support</flag>
<flag name="libmount">Link mount.nfs with libmount</flag>
<flag name="nfsdcld">Enable nfsdcld NFSv4 clientid tracking daemon</flag>
diff --git a/net-fs/nfs-utils/nfs-utils-2.3.2.ebuild b/net-fs/nfs-utils/nfs-utils-2.3.2.ebuild
new file mode 100644
index 000000000000..c9462402c7ae
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-2.3.2.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic multilib systemd
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://linux-nfs.org/"
+
+if [[ "${PV}" = *_rc* ]] ; then
+ inherit versionator
+ MY_PV="$(replace_all_version_separators -)"
+ SRC_URI="http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=snapshot;h=refs/tags/${PN}-${MY_PV};sf=tgz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
+else
+ SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps ipv6 junction kerberos ldap +libmount nfsdcld +nfsidmap +nfsv4 nfsv41 selinux tcpd +uuid"
+REQUIRED_USE="kerberos? ( nfsv4 )"
+RESTRICT="test" #315573
+
+# kth-krb doesn't provide the right include
+# files, and nfs-utils doesn't build against heimdal either,
+# so don't depend on virtual/krb.
+# (04 Feb 2005 agriffis)
+DEPEND_COMMON="
+ net-libs/libtirpc:=
+ >=net-nds/rpcbind-0.2.4
+ sys-libs/e2fsprogs-libs
+ caps? ( sys-libs/libcap )
+ ldap? ( net-nds/openldap )
+ libmount? ( sys-apps/util-linux )
+ nfsdcld? ( >=dev-db/sqlite-3.3 )
+ nfsv4? (
+ dev-libs/libevent:=
+ >=sys-apps/keyutils-1.5.9
+ kerberos? (
+ >=net-libs/libtirpc-0.2.4-r1[kerberos]
+ app-crypt/mit-krb5
+ )
+ )
+ nfsv41? (
+ sys-fs/lvm2
+ )
+ tcpd? ( sys-apps/tcp-wrappers )
+ uuid? ( sys-apps/util-linux )"
+RDEPEND="${DEPEND_COMMON}
+ !net-libs/libnfsidmap
+ !net-nds/portmap
+ !<sys-apps/openrc-0.13.9
+ selinux? (
+ sec-policy/selinux-rpc
+ sec-policy/selinux-rpcbind
+ )
+"
+DEPEND="${DEPEND_COMMON}
+ dev-libs/libxml2
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.4-mtab-sym.patch
+ "${FILESDIR}"/${PN}-1.2.8-cross-build.patch
+ "${FILESDIR}"/${PN}-2.3.2-junction_libs.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e "/^sbindir/s:= := \"${EPREFIX}\":g" \
+ -i utils/*/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ export libsqlite3_cv_is_recent=yes # Our DEPEND forces this.
+ export ac_cv_header_keyutils_h=$(usex nfsidmap)
+ local myeconfargs=(
+ --with-statedir="${EPREFIX%/}"/var/lib/nfs
+ --enable-tirpc
+ --with-tirpcinclude="${EPREFIX%/}"/usr/include/tirpc/
+ --with-pluginpath="${EPREFIX%/}"/usr/$(get_libdir)/libnfsidmap
+ --with-systemd="$(systemd_get_systemunitdir)"
+ --without-gssglue
+ $(use_enable caps)
+ $(use_enable ipv6)
+ $(use_enable junction)
+ $(use_enable kerberos gss)
+ $(use_enable kerberos svcgss)
+ $(use_enable ldap)
+ $(use_enable libmount libmount-mount)
+ $(use_enable nfsdcld nfsdcltrack)
+ $(use_enable nfsv4)
+ $(use_enable nfsv41)
+ $(use_enable uuid)
+ $(use_with tcpd tcp-wrappers)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile(){
+ # remove compiled files bundled in the tarball
+ emake clean
+ default
+}
+
+src_install() {
+ default
+ rm linux-nfs/Makefile* || die
+ dodoc -r linux-nfs README
+
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ keepdir /var/lib/nfs/{,sm,sm.bak}
+ mv "${ED%/}"/var/lib/nfs "${ED%/}"/usr/$(get_libdir)/ || die
+
+ # Install some client-side binaries in /sbin
+ dodir /sbin
+ mv "${ED%/}"/usr/sbin/rpc.statd "${ED%/}"/sbin/ || die
+
+ if use nfsv4 && use nfsidmap ; then
+ # Install a config file for idmappers in newer kernels. #415625
+ insinto /etc/request-key.d
+ echo 'create id_resolver * * /usr/sbin/nfsidmap -t 600 %k %d' > id_resolver.conf
+ doins id_resolver.conf
+ fi
+
+ insinto /etc
+ doins "${FILESDIR}"/exports
+ keepdir /etc/exports.d
+
+ local f list=() opt_need=""
+ if use nfsv4 ; then
+ opt_need="rpc.idmapd"
+ list+=( rpc.idmapd rpc.pipefs )
+ use kerberos && list+=( rpc.gssd rpc.svcgssd )
+ fi
+ for f in nfs nfsclient rpc.statd "${list[@]}" ; do
+ newinitd "${FILESDIR}"/${f}.initd ${f}
+ done
+ newinitd "${FILESDIR}"/nfsmount.initd-1.3.1 nfsmount # Nuke after 2015/08/01
+ for f in nfs nfsclient ; do
+ newconfd "${FILESDIR}"/${f}.confd ${f}
+ done
+ sed -i \
+ -e "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" \
+ "${ED%/}"/etc/conf.d/nfs || die #234132
+
+ local systemd_systemunitdir="$(systemd_get_systemunitdir)"
+ sed -i \
+ -e 's:/usr/sbin/rpc.statd:/sbin/rpc.statd:' \
+ "${ED%/}${systemd_systemunitdir}"/* || die
+
+ keepdir /var/lib/nfs #368505
+ keepdir /var/lib/nfs/v4recovery #603628
+
+}
+
+pkg_postinst() {
+ # Install default xtab and friends if there's none existing. In
+ # src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. #30486
+ local f
+ for f in "${EROOT%/}"/usr/$(get_libdir)/nfs/*; do
+ [[ -e ${EROOT%/}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from ${EPREFIX}/usr/$(get_libdir)/nfs to ${EPREFIX}/var/lib/nfs"
+ cp -pPR "${f}" "${EROOT%/}"/var/lib/nfs/
+ done
+
+ if systemd_is_booted; then
+ if [[ ${REPLACING_VERSIONS} < 1.3.0 ]]; then
+ ewarn "We have switched to upstream systemd unit files. Since"
+ ewarn "they got renamed, you should probably enable the new ones."
+ ewarn "You can run 'equery files nfs-utils | grep systemd'"
+ ewarn "to know what services you need to enable now."
+ fi
+ else
+ ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
+ ewarn "If you were using nfsmount, please add nfsclient and netmount to the"
+ ewarn "same runlevel as nfsmount."
+ fi
+}