summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-01-27 23:49:47 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-01-27 23:49:47 +0100
commit90fec4c639c41d18e1da04ce35e36a019f5762c2 (patch)
tree06a281fb22f65c4d62a4c539787707d846935e7b
parentRevert "dev-python/setuptools: bump to 40.7.0" (diff)
downloadgentoo-90fec4c639c41d18e1da04ce35e36a019f5762c2.tar.gz
gentoo-90fec4c639c41d18e1da04ce35e36a019f5762c2.tar.bz2
gentoo-90fec4c639c41d18e1da04ce35e36a019f5762c2.zip
app-shells/zsh: Revbump to fix inifinite recursion.
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch35
-rw-r--r--app-shells/zsh/zsh-5.7-r1.ebuild (renamed from app-shells/zsh/zsh-5.7.ebuild)6
2 files changed, 40 insertions, 1 deletions
diff --git a/app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch b/app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch
new file mode 100644
index 000000000000..042b948b23d7
--- /dev/null
+++ b/app-shells/zsh/files/zsh-5.7-fix_infinite_recursion.patch
@@ -0,0 +1,35 @@
+From b70919e0d9dadc93893e9d18bc3ef13b88756ecf Mon Sep 17 00:00:00 2001
+From: dana <dana@dana.is>
+Date: Sun, 27 Jan 2019 00:26:31 -0600
+Subject: [PATCH] 44020: VCS_INFO_detect_p4: Fix infinite recursion
+
+---
+ ChangeLog | 5 +++++
+ Functions/VCS_Info/Backends/VCS_INFO_detect_p4 | 1 -
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/ChangeLog b/ChangeLog
+index 81668ccc9..be243c1b8 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,8 @@
++2018-01-27 dana <dana@dana.is>
++
++ * 44020: Functions/VCS_Info/Backends/VCS_INFO_detect_p4: Fix
++ infinite recursion
++
+ 2018-01-24 dana <dana@dana.is>
+
+ * unposted: Config/version.mk: Post-release version bump
+diff --git a/Functions/VCS_Info/Backends/VCS_INFO_detect_p4 b/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
+index d171c68ee..5ec21da9f 100644
+--- a/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
++++ b/Functions/VCS_Info/Backends/VCS_INFO_detect_p4
+@@ -44,7 +44,6 @@ VCS_INFO_p4_get_server() {
+ }
+
+
+-(( ${+functions[VCS_INFO_detect_p4]} )) ||
+ VCS_INFO_detect_p4() {
+ local serverport p4where
+
diff --git a/app-shells/zsh/zsh-5.7.ebuild b/app-shells/zsh/zsh-5.7-r1.ebuild
index a0de20264a86..113f397ad17a 100644
--- a/app-shells/zsh/zsh-5.7.ebuild
+++ b/app-shells/zsh/zsh-5.7-r1.ebuild
@@ -51,6 +51,10 @@ if [[ ${PV} == 9999* ]] ; then
)"
fi
+PATCHES=(
+ "${FILESDIR}"/${P}-fix_infinite_recursion.patch
+)
+
src_prepare() {
if [[ ${PV} != 9999* ]]; then
# fix zshall problem with soelim
@@ -62,7 +66,7 @@ src_prepare() {
eapply "${FILESDIR}"/${PN}-5.3-init.d-gentoo.diff
fi
- eapply_user
+ default
if [[ ${PV} == 9999* ]] ; then
sed -i "/^VERSION=/s/=.*/=${PV}/" Config/version.mk || die