summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-01 09:07:30 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-01 09:13:43 +0300
commit931e346b5055d430f6bee9ba70687f0bb229827f (patch)
treee0a6a6016ba939ba51ef5ccede87da5c3892eb0b
parentdev-python/cliff: enable py3.10 (diff)
downloadgentoo-931e346b5055d430f6bee9ba70687f0bb229827f.tar.gz
gentoo-931e346b5055d430f6bee9ba70687f0bb229827f.tar.bz2
gentoo-931e346b5055d430f6bee9ba70687f0bb229827f.zip
dev-python/requestsexceptions: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
index 4190db1fe6dd..737ec3344353 100644
--- a/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
+++ b/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Finds the correct path to exceptions in the requests library."
@@ -15,5 +14,5 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 x86"
-DEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
RDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"