summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <stha09@googlemail.com>2020-04-11 09:30:20 +0200
committerMike Gilbert <floppym@gentoo.org>2020-04-11 12:43:01 -0400
commit9a15744e17581ce14ea2db4dc38dd68c7d395da7 (patch)
treef7bbc56aed5baf381a0498657e677f194b6d1531
parentdev-perl/HTTP-Daemon: keyword 6.60.0 for ~riscv (diff)
downloadgentoo-9a15744e17581ce14ea2db4dc38dd68c7d395da7.tar.gz
gentoo-9a15744e17581ce14ea2db4dc38dd68c7d395da7.tar.bz2
gentoo-9a15744e17581ce14ea2db4dc38dd68c7d395da7.zip
www-client/chromium: dev channel bump to 83.0.4103.7
Closes: https://bugs.gentoo.org/716478 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Stephan Hartmann <stha09@googlemail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--www-client/chromium/Manifest2
-rw-r--r--www-client/chromium/chromium-83.0.4103.7.ebuild (renamed from www-client/chromium/chromium-83.0.4100.3.ebuild)2
-rw-r--r--www-client/chromium/files/chromium-82-gcc-constexpr.patch8
-rw-r--r--www-client/chromium/files/chromium-82-gcc-incomplete-type.patch29
-rw-r--r--www-client/chromium/files/chromium-83-gcc-10.patch64
-rw-r--r--www-client/chromium/files/chromium-83-gcc-include.patch50
-rw-r--r--www-client/chromium/files/chromium-83-gcc-iterator.patch41
-rw-r--r--www-client/chromium/files/chromium-83-gcc-permissive.patch5
-rw-r--r--www-client/chromium/files/chromium-83-gcc-template.patch8
9 files changed, 191 insertions, 18 deletions
diff --git a/www-client/chromium/Manifest b/www-client/chromium/Manifest
index 35be393a4e1d..5084dd9bb66f 100644
--- a/www-client/chromium/Manifest
+++ b/www-client/chromium/Manifest
@@ -1,2 +1,2 @@
DIST chromium-81.0.4044.92.tar.xz 785906276 BLAKE2B af8e40391362c5ea182b917b085cfc1c2fe605503621316196e4a60d7031fe3b3075af9040ad756bddbad77058b5210d265731990a828ca6a11829e41c7cb807 SHA512 2d5817c84ac17e7b4d2e4473df841f53a074528e0ac997345ee68db4a9f8b45d84ef50c1d475608428f49ae40fe5315cda9d501ee22b829156c9e533044fb5af
-DIST chromium-83.0.4100.3.tar.xz 801342020 BLAKE2B 504c4d905f7ed91050f54e19e215fc2827c7299dff75e57282895f6f550ad323070ab49a2c597abfe0e88308d31fe613e8bd5bbcbfbc1b63bbc968148f939332 SHA512 d9037a7db5adad46d562f22e5ee53016170f257678d25acb124c432dc4ed4c0eb936ff9c4e0e39653a33621208e5037924ff94a9c98730da6ef68cb29a5a0f52
+DIST chromium-83.0.4103.7.tar.xz 802381832 BLAKE2B 5e1d204dd799a11726e9e8247598e28268e0689462cdd0b35867c63b1f578fcd356fbaa0f9181e26ed67f798100464f0cd218d83874df6d3b9c55f29aa4e176f SHA512 42bc38921ece136cfc24a5b9c15739f336524a5a178e57b11ffebd897b1092354e35da144f9b11d91569f07ed480c3e565e4d6086ca3be84d139633e000a71d6
diff --git a/www-client/chromium/chromium-83.0.4100.3.ebuild b/www-client/chromium/chromium-83.0.4103.7.ebuild
index 3170dfcdcbc1..57c680190c42 100644
--- a/www-client/chromium/chromium-83.0.4100.3.ebuild
+++ b/www-client/chromium/chromium-83.0.4103.7.ebuild
@@ -159,6 +159,8 @@ PATCHES=(
"${FILESDIR}/chromium-83-gcc-template.patch"
"${FILESDIR}/chromium-83-gcc-include.patch"
"${FILESDIR}/chromium-83-gcc-permissive.patch"
+ "${FILESDIR}/chromium-83-gcc-iterator.patch"
+ "${FILESDIR}/chromium-83-gcc-10.patch"
)
pre_build_checks() {
diff --git a/www-client/chromium/files/chromium-82-gcc-constexpr.patch b/www-client/chromium/files/chromium-82-gcc-constexpr.patch
index 139b458c1969..30a83395d087 100644
--- a/www-client/chromium/files/chromium-82-gcc-constexpr.patch
+++ b/www-client/chromium/files/chromium-82-gcc-constexpr.patch
@@ -14,10 +14,10 @@ Change-Id: Ic1fed89c5480ce4eedaaf7add2779d000b77cc48
---
diff --git a/third_party/blink/renderer/core/geometry/dom_rect_read_only.h b/third_party/blink/renderer/core/geometry/dom_rect_read_only.h
-index 77398f0..dda1f33 100644
+index 0c3f84c..71f193e 100644
--- a/third_party/blink/renderer/core/geometry/dom_rect_read_only.h
+++ b/third_party/blink/renderer/core/geometry/dom_rect_read_only.h
-@@ -30,10 +30,10 @@
+@@ -31,10 +31,10 @@ class CORE_EXPORT DOMRectReadOnly : public ScriptWrappable {
DOMRectReadOnly(double x, double y, double width, double height);
@@ -30,5 +30,5 @@ index 77398f0..dda1f33 100644
+ constexpr double width() const { return width_; }
+ constexpr double height() const { return height_; }
- double top() const { return std::min(y_, y_ + height_); }
- double right() const { return std::max(x_, x_ + width_); }
+ double top() const { return geometry_util::NanSafeMin(y_, y_ + height_); }
+ double right() const { return geometry_util::NanSafeMax(x_, x_ + width_); }
diff --git a/www-client/chromium/files/chromium-82-gcc-incomplete-type.patch b/www-client/chromium/files/chromium-82-gcc-incomplete-type.patch
index 9e46ad7f51b7..a3393405b49a 100644
--- a/www-client/chromium/files/chromium-82-gcc-incomplete-type.patch
+++ b/www-client/chromium/files/chromium-82-gcc-incomplete-type.patch
@@ -1,8 +1,20 @@
+From c0b32910da192edf1b41eb52c088d0213ab2807a Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Sun, 05 Apr 2020 08:29:21 +0000
+Subject: [PATCH] libstdc++: fix incomplete-type in AXTree for NodeSetSizePosInSetInfo
+
+std::unordered_map<T, U> requires U to be fully declared. ax_tree.h
+has only forward declaration of NodeSetSizePosInSetInfo. Therefore,
+move declaration from ax_tree.cc.
+Bug: 957519
+Change-Id: Ic1f4bf3ebfea229ece84251e46d4461b31873868
+---
+
diff --git a/ui/accessibility/ax_tree.cc b/ui/accessibility/ax_tree.cc
-index 616d53f..26749e3 100644
+index 7b8d9b1..e915402 100644
--- a/ui/accessibility/ax_tree.cc
+++ b/ui/accessibility/ax_tree.cc
-@@ -565,15 +565,6 @@ struct AXTreeUpdateState {
+@@ -567,14 +567,8 @@
const AXTree& tree;
};
@@ -14,22 +26,23 @@ index 616d53f..26749e3 100644
- int32_t set_size = 0;
- base::Optional<int> lowest_hierarchical_level;
-};
--
++AXTree::NodeSetSizePosInSetInfo::NodeSetSizePosInSetInfo() = default;
++AXTree::NodeSetSizePosInSetInfo::~NodeSetSizePosInSetInfo() = default;
+
struct AXTree::OrderedSetContent {
explicit OrderedSetContent(const AXNode* ordered_set = nullptr)
- : ordered_set_(ordered_set) {}
diff --git a/ui/accessibility/ax_tree.h b/ui/accessibility/ax_tree.h
-index 3bbbe0c..e4288f5 100644
+index a51ca8d..8c1c575 100644
--- a/ui/accessibility/ax_tree.h
+++ b/ui/accessibility/ax_tree.h
-@@ -323,7 +323,14 @@ class AX_EXPORT AXTree : public AXNode::OwnerTree {
+@@ -328,7 +328,14 @@
bool enable_extra_mac_nodes_ = false;
// Contains pos_in_set and set_size data for an AXNode.
- struct NodeSetSizePosInSetInfo;
+ struct NodeSetSizePosInSetInfo {
-+ NodeSetSizePosInSetInfo() = default;
-+ ~NodeSetSizePosInSetInfo() = default;
++ NodeSetSizePosInSetInfo();
++ ~NodeSetSizePosInSetInfo();
+
+ int32_t pos_in_set = 0;
+ int32_t set_size = 0;
diff --git a/www-client/chromium/files/chromium-83-gcc-10.patch b/www-client/chromium/files/chromium-83-gcc-10.patch
new file mode 100644
index 000000000000..974b49cde703
--- /dev/null
+++ b/www-client/chromium/files/chromium-83-gcc-10.patch
@@ -0,0 +1,64 @@
+From e473f41284ccc8fa4bc4622d087194b18a1ec23a Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Tue, 7 Apr 2020 16:37:10 +0000
+Subject: [PATCH] GCC: fix includes for gcc-10
+
+---
+ chrome/browser/search/background/ntp_backgrounds.h | 1 +
+ third_party/webrtc/call/rtx_receive_stream.h | 1 +
+ .../webrtc/modules/audio_processing/aec3/clockdrift_detector.h | 1 +
+ ui/gfx/linux/drm_util_linux.h | 2 ++
+ 5 files changed, 6 insertions(+)
+
+diff --git a/chrome/browser/search/background/ntp_backgrounds.h b/chrome/browser/search/background/ntp_backgrounds.h
+index 7afc0a2..ea5818e 100644
+--- a/chrome/browser/search/background/ntp_backgrounds.h
++++ b/chrome/browser/search/background/ntp_backgrounds.h
+@@ -6,6 +6,7 @@
+ #define CHROME_BROWSER_SEARCH_BACKGROUND_NTP_BACKGROUNDS_H_
+
+ #include <array>
++#include <cstddef>
+
+ class GURL;
+
+diff --git a/third_party/webrtc/call/rtx_receive_stream.h b/third_party/webrtc/call/rtx_receive_stream.h
+index 8ffa440..113a816 100644
+--- a/third_party/webrtc/call/rtx_receive_stream.h
++++ b/third_party/webrtc/call/rtx_receive_stream.h
+@@ -12,6 +12,7 @@
+ #define CALL_RTX_RECEIVE_STREAM_H_
+
+ #include <map>
++#include <cstdint>
+
+ #include "call/rtp_packet_sink_interface.h"
+
+diff --git a/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h b/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h
+index 22528c9..69e624e 100644
+--- a/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h
++++ b/third_party/webrtc/modules/audio_processing/aec3/clockdrift_detector.h
+@@ -12,6 +12,7 @@
+ #define MODULES_AUDIO_PROCESSING_AEC3_CLOCKDRIFT_DETECTOR_H_
+
+ #include <array>
++#include <cstddef>
+
+ namespace webrtc {
+
+diff --git a/ui/gfx/linux/drm_util_linux.h b/ui/gfx/linux/drm_util_linux.h
+index 86ff2eb..990f12c 100644
+--- a/ui/gfx/linux/drm_util_linux.h
++++ b/ui/gfx/linux/drm_util_linux.h
+@@ -7,6 +7,8 @@
+
+ #include "ui/gfx/buffer_types.h"
+
++#include <cstdint>
++
+ namespace ui {
+
+ int GetFourCCFormatFromBufferFormat(gfx::BufferFormat format);
+--
+2.24.1
+
diff --git a/www-client/chromium/files/chromium-83-gcc-include.patch b/www-client/chromium/files/chromium-83-gcc-include.patch
index 466539007b05..9c405e840024 100644
--- a/www-client/chromium/files/chromium-83-gcc-include.patch
+++ b/www-client/chromium/files/chromium-83-gcc-include.patch
@@ -23,3 +23,53 @@ index a9765bb..bd0d3e3 100644
--
2.24.1
+From 80044e30e0014c4c322178e4b56ddbb10eede304 Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Thu, 9 Apr 2020 17:58:06 +0000
+Subject: [PATCH] IWYU: std::unique_ptr is defined in memory
+
+---
+ .../blink/renderer/core/html/trust_token_attribute_parsing.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/third_party/blink/renderer/core/html/trust_token_attribute_parsing.h b/third_party/blink/renderer/core/html/trust_token_attribute_parsing.h
+index f5a7ab0..ef19cfa 100644
+--- a/third_party/blink/renderer/core/html/trust_token_attribute_parsing.h
++++ b/third_party/blink/renderer/core/html/trust_token_attribute_parsing.h
+@@ -5,6 +5,8 @@
+ #ifndef THIRD_PARTY_BLINK_RENDERER_CORE_HTML_TRUST_TOKEN_ATTRIBUTE_PARSING_H_
+ #define THIRD_PARTY_BLINK_RENDERER_CORE_HTML_TRUST_TOKEN_ATTRIBUTE_PARSING_H_
+
++#include <memory>
++
+ #include "base/optional.h"
+ #include "services/network/public/mojom/trust_tokens.mojom-blink-forward.h"
+ #include "third_party/blink/renderer/core/core_export.h"
+--
+2.24.1
+
+From 4f4d0a6d453bc22a6397dadaf6d866b4eb2d6b95 Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Fri, 10 Apr 2020 08:31:08 +0000
+Subject: [PATCH] IWYU: std::numeric_limits is defined in limits
+
+---
+ .../graph/policies/background_tab_loading_policy_helpers.cc | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/chrome/browser/performance_manager/graph/policies/background_tab_loading_policy_helpers.cc b/chrome/browser/performance_manager/graph/policies/background_tab_loading_policy_helpers.cc
+index 6ab117b..43aa602 100644
+--- a/chrome/browser/performance_manager/graph/policies/background_tab_loading_policy_helpers.cc
++++ b/chrome/browser/performance_manager/graph/policies/background_tab_loading_policy_helpers.cc
+@@ -2,6 +2,8 @@
+ // Use of this source code is governed by a BSD-style license that can be
+ // found in the LICENSE file.
+
++#include <limits>
++
+ #include "chrome/browser/performance_manager/graph/policies/background_tab_loading_policy_helpers.h"
+ #include "base/logging.h"
+
+--
+2.24.1
+
diff --git a/www-client/chromium/files/chromium-83-gcc-iterator.patch b/www-client/chromium/files/chromium-83-gcc-iterator.patch
new file mode 100644
index 000000000000..3df032751dbc
--- /dev/null
+++ b/www-client/chromium/files/chromium-83-gcc-iterator.patch
@@ -0,0 +1,41 @@
+From 4abcf0a76a7cb5c343be7d17c60cb908f3673c3d Mon Sep 17 00:00:00 2001
+From: Stephan Hartmann <stha09@googlemail.com>
+Date: Thu, 9 Apr 2020 17:03:38 +0000
+Subject: [PATCH] libstdc++: replace std::any_of in blink::SerializedScriptValue
+
+Use of std::any_of requires STL compliant iterator. However,
+HashTableIterator does not define iterator_tag and therefore
+is no STL iterator.
+---
+ .../core/v8/serialization/serialized_script_value.h | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/third_party/blink/renderer/bindings/core/v8/serialization/serialized_script_value.h b/third_party/blink/renderer/bindings/core/v8/serialization/serialized_script_value.h
+index bbf10ef..53d98c9 100644
+--- a/third_party/blink/renderer/bindings/core/v8/serialization/serialized_script_value.h
++++ b/third_party/blink/renderer/bindings/core/v8/serialization/serialized_script_value.h
+@@ -268,12 +268,17 @@ class CORE_EXPORT SerializedScriptValue
+ MessagePortChannelArray& GetStreamChannels() { return stream_channels_; }
+
+ bool IsLockedToAgentCluster() const {
++ auto AnyOfIsLockedToAgentCluster = [&]() {
++ for (auto entry = attachments_.begin();
++ entry != attachments_.end(); ++entry) {
++ if (entry->value->IsLockedToAgentCluster())
++ return true;
++ }
++ return false;
++ };
+ return !wasm_modules_.IsEmpty() ||
+ !shared_array_buffers_contents_.IsEmpty() ||
+- std::any_of(attachments_.begin(), attachments_.end(),
+- [](const auto& entry) {
+- return entry.value->IsLockedToAgentCluster();
+- });
++ AnyOfIsLockedToAgentCluster();
+ }
+
+ // Returns true after serializing script values that remote origins cannot
+--
+2.24.1
+
diff --git a/www-client/chromium/files/chromium-83-gcc-permissive.patch b/www-client/chromium/files/chromium-83-gcc-permissive.patch
index f7f19b44ba8f..a87f1c44b0f0 100644
--- a/www-client/chromium/files/chromium-83-gcc-permissive.patch
+++ b/www-client/chromium/files/chromium-83-gcc-permissive.patch
@@ -15,7 +15,7 @@ apps::AppServiceProxy::BrowserAppLauncher()' changes meaning of
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/chrome/browser/apps/app_service/app_service_proxy.h b/chrome/browser/apps/app_service/app_service_proxy.h
-index 1ebadfd..83f9c71 100644
+index b7fff63..1ecd49d 100644
--- a/chrome/browser/apps/app_service/app_service_proxy.h
+++ b/chrome/browser/apps/app_service/app_service_proxy.h
@@ -79,7 +79,7 @@ class AppServiceProxy : public KeyedService,
@@ -25,8 +25,7 @@ index 1ebadfd..83f9c71 100644
- BrowserAppLauncher& BrowserAppLauncher();
+ apps::BrowserAppLauncher& BrowserAppLauncher();
- apps::PreferredApps& PreferredApps();
+ apps::PreferredAppsList& PreferredApps();
--
2.24.1
-
diff --git a/www-client/chromium/files/chromium-83-gcc-template.patch b/www-client/chromium/files/chromium-83-gcc-template.patch
index 0c5c20ea19d9..27365220b031 100644
--- a/www-client/chromium/files/chromium-83-gcc-template.patch
+++ b/www-client/chromium/files/chromium-83-gcc-template.patch
@@ -1,6 +1,6 @@
-From 7f1503a80edc5ccd73559b227a242eeb9c1bea93 Mon Sep 17 00:00:00 2001
+From 8d115ddda495d0d2e1e1447392db6e9e6a8a1b32 Mon Sep 17 00:00:00 2001
From: Stephan Hartmann <stha09@googlemail.com>
-Date: Mon, 30 Mar 2020 07:26:49 +0000
+Date: Tue, 07 Apr 2020 00:23:57 +0000
Subject: [PATCH] GCC: fix template specialization in WTF::VectorMover
GCC complains that explicit specialization in non-namespace scope
@@ -10,6 +10,10 @@ into MoveOverlappingImpl method without changing generated code.
Bug: 819294
Change-Id: I90b893b9701748302f7b900fbcc2c341685fe0d3
+Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/2126290
+Reviewed-by: Kent Tamura <tkent@chromium.org>
+Commit-Queue: Kent Tamura <tkent@chromium.org>
+Cr-Commit-Position: refs/heads/master@{#756880}
---
diff --git a/third_party/blink/renderer/platform/wtf/vector.h b/third_party/blink/renderer/platform/wtf/vector.h