summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 14:35:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-12 15:28:43 +0200
commita636e65a9e0e72adadd46265d8c18e7850337667 (patch)
treea47e93e2ebd32f0c67e6852b09a142dd3c71cc05
parentprofiles: arm: Update/drop obsolete USE=kde masks (diff)
downloadgentoo-a636e65a9e0e72adadd46265d8c18e7850337667.tar.gz
gentoo-a636e65a9e0e72adadd46265d8c18e7850337667.tar.bz2
gentoo-a636e65a9e0e72adadd46265d8c18e7850337667.zip
profiles: arm64: Update/drop obsolete USE=kde masks
-rw-r--r--profiles/arch/arm64/package.use.force5
-rw-r--r--profiles/arch/arm64/package.use.mask8
2 files changed, 2 insertions, 11 deletions
diff --git a/profiles/arch/arm64/package.use.force b/profiles/arch/arm64/package.use.force
index c20ec5920cd8..35055867c2fc 100644
--- a/profiles/arch/arm64/package.use.force
+++ b/profiles/arch/arm64/package.use.force
@@ -1,11 +1,6 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# Alexis Ballier <aballier@gentoo.org> (27 Jun 2017)
-# qtphonon requires gstreamer:0.10 which we would want to avoid
-# Forcing kde useflag on designer just switched the dep to media-libs/phonon
-dev-qt/designer:4 kde
-
# Michał Górny <mgorny@gentoo.org> (24 Sep 2016)
# Force the host target to avoid dependency hell
sys-devel/clang llvm_targets_AArch64
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index c5118665a547..b51015dfce76 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -250,10 +250,6 @@ sci-libs/linux-gpib firmware
# unkeyworded deps for dev-python/ipython
dev-python/ipython mongodb
-# Markus Meier <maekke@gentoo.org> (09 May 2013)
-# unkeyworded deps for x11-misc/lightdm
-x11-misc/lightdm kde
-
# Agostino Sarubbo <ago@gentoo.org> (05 May 2013)
# dev-util/google-perftools is not keyworded for arm
>=dev-libs/libmemcached-0.50 tcmalloc
@@ -378,8 +374,8 @@ net-libs/libproxy kde
net-misc/mediatomb lastfm
# Raúl Porcel <armin76@gentoo.org> (28 Mar 2010)
-# Needs kde-4 stable
-dev-vcs/subversion kde
+# Needs kde-frameworks/kwallet and kde-frameworks/kdelibs stable
+dev-vcs/subversion kwallet
# Markus Meier <maekke@gentoo.org> (27 Sep 2009)
# mask media-gfx/imagemagick[autotrace] as autotrace is not keyworded