summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 14:19:43 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 15:42:11 +0100
commita7d432a61be60ab70c9bf3c1d5b502bb2a4ea05f (patch)
tree68107d98c7d40d4776ff0a1be6e4b37a362e7245
parentapp-benchmarks/os-autoinst: [QA] Port to git-r3 (diff)
downloadgentoo-a7d432a61be60ab70c9bf3c1d5b502bb2a4ea05f.tar.gz
gentoo-a7d432a61be60ab70c9bf3c1d5b502bb2a4ea05f.tar.bz2
gentoo-a7d432a61be60ab70c9bf3c1d5b502bb2a4ea05f.zip
app-crypt/ima-evm-utils: [QA] Port to git-r3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild33
1 files changed, 22 insertions, 11 deletions
diff --git a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
index a7366acbcaa0..6252285e3f18 100644
--- a/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
+++ b/app-crypt/ima-evm-utils/ima-evm-utils-9999.ebuild
@@ -1,21 +1,32 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-EGIT_REPO_URI="git://git.code.sf.net/p/linux-ima/ima-evm-utils"
-EGIT_BOOTSTRAP="autogen.sh"
-
-inherit git-2 eutils
+inherit autotools git-r3
DESCRIPTION="Supporting tools for IMA and EVM"
HOMEPAGE="http://linux-ima.sourceforge.net"
-SRC_URI=""
+EGIT_REPO_URI="git://git.code.sf.net/p/linux-ima/ima-evm-utils"
-DEPEND="sys-apps/keyutils"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ dev-libs/openssl:0=
+ sys-apps/keyutils"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+IUSE="debug"
+
+src_prepare() {
+ default
+
+ sed -i '/^MANPAGE_DOCBOOK_XSL/s:/usr/share/xml/docbook/stylesheet/docbook-xsl/manpages/docbook.xsl:/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl:' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}