summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-11-21 11:29:51 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-21 20:02:21 +0100
commita971872a633d7f89832cee02fcf7d2a593bc9c1d (patch)
treef8579d7850cb77b10a2c0e991ccc6fcedcde7faf
parentLinux patch 4.8.10. Update gentoo kconfig patch adding CHECKPOINT_RESTORE for... (diff)
downloadgentoo-a971872a633d7f89832cee02fcf7d2a593bc9c1d.tar.gz
gentoo-a971872a633d7f89832cee02fcf7d2a593bc9c1d.tar.bz2
gentoo-a971872a633d7f89832cee02fcf7d2a593bc9c1d.zip
media-sound/bitmeter: Fix build with GCC-5
Gentoo-bug: 586148 Fix desktop file. Update HOMEPAGE, DESCRIPTION, SRC_URI, bump to EAPI 6. Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2877
-rw-r--r--media-sound/bitmeter/bitmeter-1.2-r1.ebuild37
-rw-r--r--media-sound/bitmeter/bitmeter-1.2.ebuild26
-rw-r--r--media-sound/bitmeter/files/bitmeter-1.2-fix-build-system.patch30
-rw-r--r--media-sound/bitmeter/files/bitmeter-1.2-qa-desktop-file.patch18
4 files changed, 85 insertions, 26 deletions
diff --git a/media-sound/bitmeter/bitmeter-1.2-r1.ebuild b/media-sound/bitmeter/bitmeter-1.2-r1.ebuild
new file mode 100644
index 000000000000..6d68c85107d2
--- /dev/null
+++ b/media-sound/bitmeter/bitmeter-1.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Diagnosis tool for JACK audio software"
+HOMEPAGE="http://devel.tlrmx.org/audio/"
+SRC_URI="http://devel.tlrmx.org/audio/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="x11-libs/gtk+:2
+ media-sound/jack-audio-connection-kit"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2-fix-build-system.patch
+ "${FILESDIR}"/${PN}-1.2-qa-desktop-file.patch
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/*.{png,html} )
+ default
+}
diff --git a/media-sound/bitmeter/bitmeter-1.2.ebuild b/media-sound/bitmeter/bitmeter-1.2.ebuild
deleted file mode 100644
index 04d8290eca0d..000000000000
--- a/media-sound/bitmeter/bitmeter-1.2.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-
-DESCRIPTION="a diagnosis tool for JACK audio software"
-HOMEPAGE="http://users.ecs.soton.ac.uk/njl98r/code/audio/bitmeter"
-SRC_URI="http://users.ecs.soton.ac.uk/njl98r/code/audio/source/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND="media-sound/jack-audio-connection-kit
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- !media-sound/bitscope"
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc README
- use doc && dohtml doc/{*.png,*.html}
-}
diff --git a/media-sound/bitmeter/files/bitmeter-1.2-fix-build-system.patch b/media-sound/bitmeter/files/bitmeter-1.2-fix-build-system.patch
new file mode 100644
index 000000000000..37c75266887f
--- /dev/null
+++ b/media-sound/bitmeter/files/bitmeter-1.2-fix-build-system.patch
@@ -0,0 +1,30 @@
+Look for log10f function in libm.
+See also: https://bugs.gentoo.org/show_bug.cgi?id=586148
+
+--- a/configure.in
++++ b/configure.in
+@@ -1,8 +1,8 @@
+ dnl Process this file with autoconf to produce a configure script.
+
+-AC_INIT(configure.in)
+-AM_INIT_AUTOMAKE(bitmeter, 1.2)
+-AM_CONFIG_HEADER(config.h)
++AC_INIT([bitmeter], [1.2])
++AM_INIT_AUTOMAKE
++AC_CONFIG_HEADERS([config.h])
+ AM_MAINTAINER_MODE
+
+ AC_ISC_POSIX
+@@ -10,6 +10,12 @@
+ AM_PROG_CC_STDC
+ AC_HEADER_STDC
+
++dnl Find log10f
++dnl Gentoo-bug: 586148
++AC_SEARCH_LIBS([log10f], [m], [], [
++ AC_MSG_ERROR([unable to find the log10f() function])
++])
++
+ pkg_modules="gtk+-2.0 >= 2.0.0"
+ PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+ AC_SUBST(PACKAGE_CFLAGS)
diff --git a/media-sound/bitmeter/files/bitmeter-1.2-qa-desktop-file.patch b/media-sound/bitmeter/files/bitmeter-1.2-qa-desktop-file.patch
new file mode 100644
index 000000000000..25bfa77340e9
--- /dev/null
+++ b/media-sound/bitmeter/files/bitmeter-1.2-qa-desktop-file.patch
@@ -0,0 +1,18 @@
+Fix broken .desktop file to comply with FDO specifications.
+
+--- a/bitmeter.desktop
++++ b/bitmeter.desktop
+@@ -4,10 +4,10 @@
+ Comment=JACK diagnostic tool
+ TryExec=bitmeter
+ Exec=bitmeter
+-Icon=bitmeter.xpm
+-Terminal=0
++Icon=bitmeter
++Terminal=false
+ Type=Application
+ StartupWMClass=Bitmeter
+-Categories=Application;Audio;AudioVideo;X-Jack
++Categories=Audio;AudioVideo;X-Jack
+
+