summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWade Cline <wadecline@hotmail.com>2020-05-03 15:12:58 -0700
committerJoonas Niilola <juippis@gentoo.org>2020-05-04 20:26:09 +0300
commita9cf4e5334506f320179f110caa4df037feba60f (patch)
treec5dc0c165153e1c3daa9dbc3f6566e8359a9f6af
parentnet-irc/inspircd: Add 2.0.29 (diff)
downloadgentoo-a9cf4e5334506f320179f110caa4df037feba60f.tar.gz
gentoo-a9cf4e5334506f320179f110caa4df037feba60f.tar.bz2
gentoo-a9cf4e5334506f320179f110caa4df037feba60f.zip
net-irc/inspircd: Add 3.6.0
Signed-off-by: Wade Cline <wadecline@hotmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-irc/inspircd/Manifest1
-rw-r--r--net-irc/inspircd/inspircd-3.6.0.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/net-irc/inspircd/Manifest b/net-irc/inspircd/Manifest
index cbd3522380bb..3c2da679b34c 100644
--- a/net-irc/inspircd/Manifest
+++ b/net-irc/inspircd/Manifest
@@ -2,3 +2,4 @@ DIST inspircd-2.0.28.tar.gz 735981 BLAKE2B d467b4d31db4cbafeba655a4e129766ec780b
DIST inspircd-2.0.29.tar.gz 736116 BLAKE2B bd634b81e5a21f4d5e12a4057c4dfb65a241b696be373d24a047594d1d175028dcabff2f28defcf4c340859cfc50637afec755f399c24366e1134c7d69c843f2 SHA512 83da7b089dca8035ffa4f30a2e757661150bb9337aa8124958daa317b44a98fb15fdcb872f8512737b5a39f1b641616eb27c4398d4c8d8fcd40d1f8872bd2052
DIST inspircd-3.4.0.tar.gz 809845 BLAKE2B 6529d53c3cbff07727eceea5e1eb321bb8b7f6b231b3d5ea3ed0ced01fe5b66c2da83039a1ac11ff49e6536ef482483a9be26762feb30511a0016bab07d6790a SHA512 871fefff5e337dc6228fae223ff7ac534e159b5bfb838419247b1d16339c860b0b939a28dd4610cf3b8c37328b5e6ccba2ddd80adbd27638f4f3fa28e4f99066
DIST inspircd-3.5.0.tar.gz 835283 BLAKE2B d070d8f299ea2460eb58062b345e9fdef04f1aa94cbedda15bc2ed9c32a7627af383a250359dc77ee6cf2c53dd1841c9a77ce0da236d0b9852c5e9d5a0964aae SHA512 64e7be4b013c418577362b33be73b8f7045f1071ccb2c4e83fdf1a96b98656a3541e20c005bc32532007da21d9ba963f534cd14d16c2e1cf8afcf34b22ffad8c
+DIST inspircd-3.6.0.tar.gz 851768 BLAKE2B e1cbad4e5f00e769e804abc432dbac24ae4c988aac690d009dd87f28d75c4229a174c1703395cae42306b45ba167268c2032a3c2533fdde8154a67f53f2e18f8 SHA512 b1feaf983f30aa3192860d931f85bb2e5b5f10d3b7582b7e5faa8fc16a349c79506f5a7ba9e1f4f8b24d62639c0e0e88f2d97a3130473ee10eda93dd5c131630
diff --git a/net-irc/inspircd/inspircd-3.6.0.ebuild b/net-irc/inspircd/inspircd-3.6.0.ebuild
new file mode 100644
index 000000000000..92c0dfe18f1a
--- /dev/null
+++ b/net-irc/inspircd/inspircd-3.6.0.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Inspire IRCd - The Stable, High-Performance Modular IRCd"
+HOMEPAGE="https://inspircd.github.com/"
+SRC_URI="https://github.com/inspircd/inspircd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug gnutls ldap maxminddb mbedtls mysql pcre postgres re2 regex-posix regex-stdlib sqlite ssl sslrehashsignal tre"
+
+RDEPEND="
+ acct-group/inspircd
+ acct-user/inspircd
+ dev-lang/perl
+ gnutls? ( net-libs/gnutls:= dev-libs/libgcrypt:0 )
+ ldap? ( net-nds/openldap )
+ maxminddb? ( dev-libs/libmaxminddb )
+ mbedtls? ( net-libs/mbedtls:= )
+ mysql? ( dev-db/mysql-connector-c:= )
+ pcre? ( dev-libs/libpcre )
+ postgres? ( dev-db/postgresql:= )
+ re2? ( dev-libs/re2:= )
+ sqlite? ( >=dev-db/sqlite-3.0 )
+ ssl? ( dev-libs/openssl:= )
+ tre? ( dev-libs/tre )"
+DEPEND="${RDEPEND}"
+
+DOCS=( docs/. )
+PATCHES=( "${FILESDIR}"/${PN}-3.5.0-fix-path-builds.patch )
+
+src_prepare() {
+ default
+
+ # Patch the inspircd launcher with the inspircd user
+ sed -i -e "s/@UID@/${PN}/" "make/template/${PN}" || die
+}
+
+src_configure() {
+ local extras=""
+
+ use gnutls && extras+="m_ssl_gnutls.cpp,"
+ use ldap && extras+="m_ldap.cpp,"
+ use maxminddb && extras+="m_geo_maxmind.cpp,"
+ use mbedtls && extras+="m_ssl_mbedtls.cpp,"
+ use mysql && extras+="m_mysql.cpp,"
+ use pcre && extras+="m_regex_pcre.cpp,"
+ use postgres && extras+="m_pgsql.cpp,"
+ use re2 && extras+="m_regex_re2.cpp,"
+ use regex-posix && extras+="m_regex_posix.cpp,"
+ use regex-stdlib && extras+="m_regex_stdlib.cpp,"
+ use sqlite && extras+="m_sqlite3.cpp,"
+ use ssl && extras+="m_ssl_openssl.cpp,"
+ use sslrehashsignal && extras+="m_sslrehashsignal.cpp,"
+ use tre && extras+="m_regex_tre.cpp,"
+
+ # The first configuration run enables certain "extra" InspIRCd
+ # modules, the second run generates the actual makefile.
+ if [[ -n "${extras}" ]]; then
+ ./configure --disable-interactive --enable-extras=${extras%,}
+ fi
+
+ local myconf=(
+ --disable-interactive
+ --disable-auto-extras
+ --prefix="/usr/$(get_libdir)/${PN}"
+ --config-dir="/etc/${PN}"
+ --data-dir="/var/lib/${PN}/data"
+ --log-dir="/var/log/${PN}"
+ --binary-dir="/usr/bin"
+ --module-dir="/usr/$(get_libdir)/${PN}/modules"
+ --manual-dir="/usr/share/man")
+ CXX="$(tc-getCXX)" ./configure "${myconf[@]}"
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CXXFLAGS="${CXXFLAGS}" $(usex debug 'INSPIRCD_DEBUG=2' '') INSPIRCD_VERBOSE=1
+}
+
+src_install() {
+ default
+
+ insinto "/usr/include/${PN}"
+ doins -r include/.
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ keepdir "/var/log/${PN}"
+
+ diropts -o"${PN}" -g"${PN}" -m0700
+ keepdir "/var/lib/${PN}/data"
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You will find example configuration files under "
+ elog "/usr/share/doc/${PN}"
+ elog "Read the ${PN}.conf.example file carefully before "
+ elog "starting the service."
+ fi
+ local pv
+ for pv in ${REPLACING_VERSIONS}; do
+ if ver_test "${pv}" -lt "2.0.24-r1"; then
+ elog "Starting with 2.0.24-r1 the daemon is no longer started"
+ elog "with the --logfile option and you are thus expected to define"
+ elog "logging in the InspIRCd configuration file if you want it."
+ fi
+ if ver_test "${pv}" -lt "3.0.0"; then
+ elog "Version 3.0 is a major upgrade which contains breaking"
+ elog "changes. You will need to update your configuration files."
+ elog "See: https://docs.inspircd.org/3/configuration-changes"
+ fi
+ done
+}