summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2018-11-18 00:24:12 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2018-11-18 00:24:12 +0000
commitae06f9e9ad9d1b18c5ab2c24fb9fb7f2ab26ca91 (patch)
treebda2ad1aa0c1e03e0acc830c5c91a39dc64efbb4
parent2018-11-18 00:04:43 UTC (diff)
parentkde-apps/dolphin: Move kcrash link to dolphin app (diff)
downloadgentoo-ae06f9e9ad9d1b18c5ab2c24fb9fb7f2ab26ca91.tar.gz
gentoo-ae06f9e9ad9d1b18c5ab2c24fb9fb7f2ab26ca91.tar.bz2
gentoo-ae06f9e9ad9d1b18c5ab2c24fb9fb7f2ab26ca91.zip
Merge updates from master
-rw-r--r--kde-apps/dolphin/dolphin-18.08.3.ebuild2
-rw-r--r--kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch56
-rw-r--r--kde-plasma/kwin/files/kwin-5.14.3-kcrash-init.patch48
-rw-r--r--kde-plasma/kwin/kwin-5.14.3-r1.ebuild5
-rw-r--r--www-plugins/adobe-flash/Manifest8
-rw-r--r--www-plugins/adobe-flash/adobe-flash-31.0.0.148.ebuild (renamed from www-plugins/adobe-flash/adobe-flash-31.0.0.122.ebuild)0
6 files changed, 113 insertions, 6 deletions
diff --git a/kde-apps/dolphin/dolphin-18.08.3.ebuild b/kde-apps/dolphin/dolphin-18.08.3.ebuild
index 47da3a35d622..e38021b24876 100644
--- a/kde-apps/dolphin/dolphin-18.08.3.ebuild
+++ b/kde-apps/dolphin/dolphin-18.08.3.ebuild
@@ -62,6 +62,8 @@ RDEPEND="${DEPEND}
RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${P}-kcrash-init.patch" )
+
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package semantic-desktop KF5Baloo)
diff --git a/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch b/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch
new file mode 100644
index 000000000000..cb7923534c3e
--- /dev/null
+++ b/kde-apps/dolphin/files/dolphin-18.08.3-kcrash-init.patch
@@ -0,0 +1,56 @@
+From a4cddf7517dab5f666f1c1ede2a58900f3bc5e53 Mon Sep 17 00:00:00 2001
+From: Harald Sitter <sitter@kde.org>
+Date: Thu, 15 Nov 2018 14:43:57 +0100
+Subject: move kcrash link to dolphin app (which is the effective user)
+
+Summary:
+to successfully use kcrash when linking with as-needed (which is a default
+flag on many linux distros) one also needs to call KCrash::initialize.
+this call happens in the app's main.cpp. as such the kcrash link target
+on the dolphinprivate library doesn't do anything for dolphinprivate but
+only kicks into action for dolphin itself.
+to avoid confusion and make it clear that kcrash is only initialized in the
+application scope the KF5::Crash link target is now on the application
+target, not the library target.
+
+(this makes no difference in the output, kcrash was still correctly linked
+ via dolphinprivate; but only for kdeinit_dolphin, dolphinprivate did
+ not get linked to it with as-needed)
+
+Test Plan: builds; links as expected
+
+Reviewers: elvisangelaccio, #dolphin
+
+Reviewed By: elvisangelaccio, #dolphin
+
+Subscribers: kfm-devel
+
+Tags: #dolphin
+
+Differential Revision: https://phabricator.kde.org/D16896
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 4a1f173..d5206be 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -136,7 +136,6 @@ target_link_libraries(
+ dolphinvcs
+ Qt5::Concurrent
+ Qt5::Gui
+- KF5::Crash
+ KF5::I18n
+ KF5::IconThemes
+ KF5::KIOCore
+@@ -301,6 +300,7 @@ kf5_add_kdeinit_executable(dolphin ${dolphin_SRCS})
+ target_link_libraries(kdeinit_dolphin PRIVATE
+ dolphinstatic
+ dolphinprivate
++ KF5::Crash
+ )
+
+ include(DbusInterfaceMacros)
+--
+cgit v0.11.2
diff --git a/kde-plasma/kwin/files/kwin-5.14.3-kcrash-init.patch b/kde-plasma/kwin/files/kwin-5.14.3-kcrash-init.patch
new file mode 100644
index 000000000000..fc9c3007f840
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-5.14.3-kcrash-init.patch
@@ -0,0 +1,48 @@
+From aace9b1675819feab81d50f694391c7d854d9822 Mon Sep 17 00:00:00 2001
+From: Harald Sitter <sitter@kde.org>
+Date: Fri, 16 Nov 2018 12:50:53 +0100
+Subject: actually initialize kcrash for xclipboardsync
+
+Summary:
+to successfully use kcrash when linking with as-needed (which is a default
+flag on many linux distros) one also needs to call KCrash::initialize.
+
+https://markmail.org/thread/zv5pheijaze72bzs
+
+Test Plan: builds; correctly links kcrash
+
+Reviewers: davidedmundson
+
+Reviewed By: davidedmundson
+
+Subscribers: kwin
+
+Tags: #kwin
+
+Differential Revision: https://phabricator.kde.org/D16923
+---
+ helpers/xclipboardsync/main.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/helpers/xclipboardsync/main.cpp b/helpers/xclipboardsync/main.cpp
+index 2f06e9c..1a5e5ee 100644
+--- a/helpers/xclipboardsync/main.cpp
++++ b/helpers/xclipboardsync/main.cpp
+@@ -19,6 +19,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ *********************************************************************/
+ #include "waylandclipboard.h"
+
++#include <KCrash>
+ #include <QGuiApplication>
+
+ #include <config-kwin.h>
+@@ -40,6 +41,7 @@ int main(int argc, char *argv[])
+ argv[0], qPrintable(app.platformName()));
+ return 1;
+ }
++ KCrash::initialize();
+ new WaylandClipboard(&app);
+ return app.exec();
+ }
+--
+cgit v0.11.2
diff --git a/kde-plasma/kwin/kwin-5.14.3-r1.ebuild b/kde-plasma/kwin/kwin-5.14.3-r1.ebuild
index a2ab760c9bed..c74288ae8cb1 100644
--- a/kde-plasma/kwin/kwin-5.14.3-r1.ebuild
+++ b/kde-plasma/kwin/kwin-5.14.3-r1.ebuild
@@ -89,8 +89,9 @@ PDEPEND="
RESTRICT+=" test"
PATCHES=(
- "${FILESDIR}/${PN}-5.14.3-virtualdesktop-crash.patch"
- "${FILESDIR}/${PN}-5.14.3-resizewindows-crash.patch"
+ "${FILESDIR}/${P}-virtualdesktop-crash.patch"
+ "${FILESDIR}/${P}-resizewindows-crash.patch"
+ "${FILESDIR}/${P}-kcrash-init.patch"
)
src_prepare() {
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index 986fbd3ee592..3bb21429e522 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -1,4 +1,4 @@
-DIST adobe-flash-31.0.0.122-npapi.i386.tar.gz 8529106 BLAKE2B 71984e263ec5fb1720288208371551a74a22a982832dc16b2da314fc1fc1ee1009faf36b2648e9ed52a6eb4b7a34a5ffef5af266e31daca0fc3049162cc6c4f9 SHA512 8383f15cf14528a9b3bbf15b880b530f15fbec18708ccbfce83bdd6ec6bef8b7b7fd8f8231dfa534e42d077ef7b5bf92627a6fcc14749abefca748b307680e4b
-DIST adobe-flash-31.0.0.122-npapi.x86_64.tar.gz 9044791 BLAKE2B 4f659381aeffd1a46e8a72cad7612c9b626ff0bf208492502c887a9bcd5beb9888bd8063265a81dd3b848fa97dedde327ab4563b262719fab7620912efe2c1e6 SHA512 c8f27ef630ac6797c0879b444499e954ba5e46564a9d35842134fb963cf7866bbc1badbc773ccdce928c158c716d63d91b79e47b10f8388c97493dd16bd66911
-DIST adobe-flash-31.0.0.122-ppapi.i386.tar.gz 8563099 BLAKE2B 0951b14ed7a3c8ea7dbb7ab2de93521435a164a4358f20084cb3e407fb45d19561fd17871553bb2a39da9caf7dec17388d825b51ccafa8184e6fbfd006c328e0 SHA512 fc2efd870a6a2fabd53b1c6d095fd0ffc6c9e1d05a13ebaec93ea31bc84e022e8b54e8c2194a42a54dd3258c8d2fb378fa14205acb3c4a876b07c48e40c18d96
-DIST adobe-flash-31.0.0.122-ppapi.x86_64.tar.gz 9482137 BLAKE2B 25585e857de26917880aa09289b7ea2e3b0191f958495d2523461ffd55869a67808c604b9bd5d80c9ea4326df9b72a5a4a3c47a8f2cb32071093df9a7f7ea673 SHA512 64e18f58ce7abda62aa098c47c260226f67d78e17698175629f2777fbcde84b2bd88e80b6247af34bcfe6bed3a558e767b43f45fdf2164cb974d59e70751a4fc
+DIST adobe-flash-31.0.0.148-npapi.i386.tar.gz 8529825 BLAKE2B 3b73bb3f4d1a235f02c6a1819253e9a60489bd388aa00370d7a98d49127f8f666bb99f03a33fbdd9d0ccf12033b38d87d3ecbada13cf3dec185bcc8a988d4a85 SHA512 16dc46da7c71e159845cbd862490fd682ff0c1e97467e42a56ace172fcba07326ed87272f250e9c96b5d3057b08dbb980973567cdc8fe24b0c5463f465056819
+DIST adobe-flash-31.0.0.148-npapi.x86_64.tar.gz 9046263 BLAKE2B 359b08d6bfd3725211bac32fddd28dd18654133c99cdd761879fd48eae1697ab06b6f8d5a22aba98ce44ec484e5fc7b669d13066d0bc90d312aab54fd109edd8 SHA512 79b5a170d63e84d88c74b9ccdbe55a2ec517a28cd69df60eea9c0255ed95d4c0fb8db3a56f7343256b58c4e0aebdb0e421714d92feba494826d06c95f53a54ea
+DIST adobe-flash-31.0.0.148-ppapi.i386.tar.gz 8565088 BLAKE2B b700cc95c8328acbe54b2754afb697dec20287ade78d3b0db687c4dc04c0587c15d6f247a93d74035cb896cc044c28bd85815975b4b5c26399e26e7480d79948 SHA512 695c7df7d224bfd90458980e4e8e12385a12fe6b4586abd1043563a7bc96ae2cc8569ec979c2f6305dd4a99e9373ec1deb210cbf762391122427828b652b3de3
+DIST adobe-flash-31.0.0.148-ppapi.x86_64.tar.gz 9482344 BLAKE2B 4de2c9b9c1580d5badc3b01ec1457d27bb935254b24aa5bbf1cc846a158b8a2f2c08ab7bcd839f9d25cb7ec31be982c1ab9e0fae634855bc6ffbed120cf6442d SHA512 5c0bcd5d2530bc1930d8b2900601b863102a9f22acfcd0a02f29883c43a0e1663d67cfd1065e27a613428829c92c3806824ebc6cf85c83a992755074eed4d82f
diff --git a/www-plugins/adobe-flash/adobe-flash-31.0.0.122.ebuild b/www-plugins/adobe-flash/adobe-flash-31.0.0.148.ebuild
index 43c2833801f5..43c2833801f5 100644
--- a/www-plugins/adobe-flash/adobe-flash-31.0.0.122.ebuild
+++ b/www-plugins/adobe-flash/adobe-flash-31.0.0.148.ebuild