summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-15 17:59:25 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-06-04 17:16:21 +0200
commitaf99c2a69218075f25107d22b5495b7550815d04 (patch)
tree8ad4104b157a8997ff73559f372006f372494835
parentmate-base/mate-menus: Version bump to 1.18.0 (diff)
downloadgentoo-af99c2a69218075f25107d22b5495b7550815d04.tar.gz
gentoo-af99c2a69218075f25107d22b5495b7550815d04.tar.bz2
gentoo-af99c2a69218075f25107d22b5495b7550815d04.zip
mate-base/mate-panel: Version bump to 1.18.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--mate-base/mate-panel/Manifest1
-rw-r--r--mate-base/mate-panel/mate-panel-1.18.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/mate-base/mate-panel/Manifest b/mate-base/mate-panel/Manifest
index 727b8fcb2d2c..9c4fe50950f5 100644
--- a/mate-base/mate-panel/Manifest
+++ b/mate-base/mate-panel/Manifest
@@ -1,3 +1,4 @@
DIST mate-panel-1.12.2.tar.xz 1930792 SHA256 b757bb5ea3da1b36fcf599d4f123534e936f0e46859b3307816085f486667fa1 SHA512 7810c3b3585e9def59c192914a91e2e64173b5b44cf43496808f6be46df798fc97358bb7bc300e52985fc401feb5201daad60bb0181e72e5e2512e7712aba6a4 WHIRLPOOL 2af7cdf4b38aab536497196dd8abd67583d93d915288d2a2eda67f31e9eba5030ee5360f6ad47cbc4d21389160b3209e99d84eecde1b2093ee9ce566b7cacd5a
DIST mate-panel-1.14.2.tar.xz 1981716 SHA256 ae3d2106f830583115e58fc8782fff63b27023f717068d407b239bfe548b6d24 SHA512 296a74fcbdd3a58337987c0e8bcc804a203fbf5f134183c2fe09016c609bbd67bfab4dc6e46e333c7714e9c264965f1c3897c9645a5003405866fbdaf0a04944 WHIRLPOOL b0e7d0c0ce2595bac3cc858b2a284166e4f6aeb7831419b833e9b194fc13f6902e4b95a7946da3f30bda38004987cb346ccff06b1cd0521e578c3f97f5f9e0c7
DIST mate-panel-1.16.0.tar.xz 1945868 SHA256 085b4236f793556381769aeb11744abdebff37254b2ab3eb9f57008d9f93094a SHA512 96ea6e71dc602b2ff81294984f22854079e0daeb41d00a52646a6f2eb211f26b51eba43f97a3548707f3948b1f226480e3a8242c84de7eb4cd7f69e9b143fa36 WHIRLPOOL f7ecb648cb3cccfb7aa930a76f025c409724c076ca4e90f50f1b977bf86b535d0eab82570ecd8eb840c07fed7d37acd18db39216ad028c0bbe0788fa9e071ff5
+DIST mate-panel-1.18.2.tar.xz 1946680 SHA256 6c4f5d63b173079c298ae2d05375081c2e452745f3ccf339da757bf83e5d3e17 SHA512 c0b7b25a2f2aee928324badeb577707e856f1c6669190e0967592dc86b0991006d6cabdbabf8aa8e24807a974e120b096312916ff2acb4601e73aaad2208f869 WHIRLPOOL 3d4ef30fa95e8b1ecf70f93dec5c952ae5b760984c867406099cd69915e389ec86d84f822bb6101f95d8b7b2922e3ab1a97d3197d823fb5149475158fafee0ec
diff --git a/mate-base/mate-panel/mate-panel-1.18.2.ebuild b/mate-base/mate-panel/mate-panel-1.18.2.ebuild
new file mode 100644
index 000000000000..c0c96905cb5a
--- /dev/null
+++ b/mate-base/mate-panel/mate-panel-1.18.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="The MATE panel"
+LICENSE="GPL-2 FDL-1.1 LGPL-2"
+SLOT="0"
+
+IUSE="X +introspection"
+
+COMMON_DEPEND="
+ dev-libs/atk:0
+ >=dev-libs/dbus-glib-0.80:0
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libmateweather-1.17.0
+ dev-libs/libxml2:2
+ >=gnome-base/dconf-0.13.4:0
+ >=gnome-base/librsvg-2.36.2:2
+ >=mate-base/mate-desktop-1.17.0
+ >=mate-base/mate-menus-1.10.0
+ >=sys-apps/dbus-1.1.2:0
+ >=x11-libs/cairo-1:0
+ >=x11-libs/gdk-pixbuf-2.7.1:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ x11-libs/libICE:0
+ x11-libs/libSM:0
+ >=x11-libs/libwnck-3.0:3[introspection?]
+ x11-libs/libX11:0
+ >=x11-libs/pango-1.15.4:0[introspection?]
+ x11-libs/libXau:0
+ >=x11-libs/libXrandr-1.3:0
+ virtual/libintl:0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools:0
+ >=dev-lang/perl-5:0=
+ dev-util/gdbus-codegen:0
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.50.1:*
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure \
+ --libexecdir=/usr/libexec/mate-applets \
+ --disable-deprecation-flags \
+ $(use_with X x) \
+ $(use_enable introspection)
+}