summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-05-23 21:35:40 -0400
committerTim Harder <radhermit@gentoo.org>2017-05-23 21:36:36 -0400
commitb1630f4a57f694e4cb4cefdd48aaf3dd76d4af9d (patch)
treee92e6d12657d6462bea00cf9bd703dce9eab400e
parentnet-wireless/gnuradio: missing dep on app-text/docbook-xml-dtd:4.2 causes bui... (diff)
downloadgentoo-b1630f4a57f694e4cb4cefdd48aaf3dd76d4af9d.tar.gz
gentoo-b1630f4a57f694e4cb4cefdd48aaf3dd76d4af9d.tar.bz2
gentoo-b1630f4a57f694e4cb4cefdd48aaf3dd76d4af9d.zip
dev-libs/npth: version bump to 1.4
-rw-r--r--dev-libs/npth/Manifest1
-rw-r--r--dev-libs/npth/npth-1.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/npth/Manifest b/dev-libs/npth/Manifest
index fad554dd66ce..c2dc53d4dc45 100644
--- a/dev-libs/npth/Manifest
+++ b/dev-libs/npth/Manifest
@@ -1 +1,2 @@
DIST npth-1.3.tar.bz2 295998 SHA256 bca81940436aed0734eb8d0ff8b179e04cc8c087f5625204419f5f45d736a82a SHA512 97b0278cc9448adb42c4a83b8e7bafeed939acaf3dd3a201a1b103df4e48f24224d4bdaeb97903ad1884914ce363cbceffe948a7c1db4f19abf87ca5964f5699 WHIRLPOOL 786dd42c0bb097f47c708cae633f32789d9724cfb5d0e0a12667c754ba32a273ddda6b1c061ad10be1fa2e98dbbcf6850d404e909243fd2e566ba17825f63526
+DIST npth-1.4.tar.bz2 299106 SHA256 8915141836a3169a502d65c1ebd785fcc6d406cae5ee84474272ebf2fa96f1f2 SHA512 649009b4fbd2bbbb8fce2911c2f9070a758d037be0d147a63754e3c1f5a9ffb73b907cd09c79314fe60c25084ca7a7b3b387139dd83cc0e11a7e7ba64630ae1f WHIRLPOOL 02642a82d11be58fe5807d178a1fdac0fbcf935e6553d4eebe4d4d24601f04181e6892df0aa532e9b3db198141e6f1b68491bf8c92d18f24686e36492f37f0ab
diff --git a/dev-libs/npth/npth-1.4.ebuild b/dev-libs/npth/npth-1.4.ebuild
new file mode 100644
index 000000000000..02fb9ddf559e
--- /dev/null
+++ b/dev-libs/npth/npth-1.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool
+
+DESCRIPTION="New GNU Portable Threads Library"
+HOMEPAGE="https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ elibtoolize # for Solaris shared library
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}