summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-23 12:56:20 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-23 12:56:40 +0200
commitb1ecf54d9e26f1c9b1f357d1fa191e93d0e87202 (patch)
tree6bf7c6f3fc4ba665448df439b3c852c43ea278e5
parentsys-apps/mount-gtk: Clean up patch (diff)
downloadgentoo-b1ecf54d9e26f1c9b1f357d1fa191e93d0e87202.tar.gz
gentoo-b1ecf54d9e26f1c9b1f357d1fa191e93d0e87202.tar.bz2
gentoo-b1ecf54d9e26f1c9b1f357d1fa191e93d0e87202.zip
sys-apps/mount-gtk: Version 1.4.4
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--sys-apps/mount-gtk/Manifest1
-rw-r--r--sys-apps/mount-gtk/mount-gtk-1.4.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/mount-gtk/Manifest b/sys-apps/mount-gtk/Manifest
index 61e597d8b400..8eaaf53068f5 100644
--- a/sys-apps/mount-gtk/Manifest
+++ b/sys-apps/mount-gtk/Manifest
@@ -1 +1,2 @@
DIST mount-gtk-1.4.2.tar.gz 232132 BLAKE2B 7c6be675db2fd11ce36501e8b247ddbb5a786b28698c4195c329b310cabc710f6df65f7869ec2bbece2edfd54820b8de88a0a7b20d442fe3d6e27ab5e93689fc SHA512 90fa174238d19bf009f5863e5571030091681038ddbfdc06c7a39f8859b78d9864b398899d66463d0f8a189e484201c7a32753b38898e0f5d55970feb85420ba
+DIST mount-gtk-1.4.4.tar.gz 240716 BLAKE2B 25244bfea0db577c3bfb61abb9acea4cdab41e9cad3173dc472c57ca39b7739e3cfef0501ecb874faf1bd8cd92e0cfd8b48ecc5aadcbe4294309aa692593c376 SHA512 85ed7e5bd92d6ea15a8fd907a0bca4bc7e64861b03e922bc28827108820f1fb4daa87b94a16f468c87d741a8d456f27f755e06b2049f2a95ce4ab00d395763d2
diff --git a/sys-apps/mount-gtk/mount-gtk-1.4.4.ebuild b/sys-apps/mount-gtk/mount-gtk-1.4.4.ebuild
new file mode 100644
index 000000000000..563968c6477e
--- /dev/null
+++ b/sys-apps/mount-gtk/mount-gtk-1.4.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="GTK+ based UDisks2 frontend"
+HOMEPAGE="http://mount-gtk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.28
+ sys-fs/udisks:2
+ x11-libs/c++-gtk-utils:0
+ x11-libs/libX11
+ x11-libs/libnotify:=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS BUGS ChangeLog )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.2-c++11.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # acinclude.m4 is broken and environment flags override these:
+ append-cxxflags -fexceptions -frtti -fsigned-char -fno-check-new -pthread
+ econf --docdir=/usr/share/doc/${PF}
+}