summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-03-03 13:43:14 -0800
committerMatt Turner <mattst88@gentoo.org>2019-03-03 13:55:56 -0800
commitb51d6fe7309a5a4806629fec54162a1cc6fd42bb (patch)
tree5775642942747bca190628f2476a66af0fe4b1a5
parentx11-apps/xmore: Version bump to 1.0.3 (diff)
downloadgentoo-b51d6fe7309a5a4806629fec54162a1cc6fd42bb.tar.gz
gentoo-b51d6fe7309a5a4806629fec54162a1cc6fd42bb.tar.bz2
gentoo-b51d6fe7309a5a4806629fec54162a1cc6fd42bb.zip
media-libs/mesa: Add support for libglvnd
Bug: https://bugs.gentoo.org/606924 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/mesa/mesa-19.0.0_rc6.ebuild8
-rw-r--r--media-libs/mesa/mesa-9999.ebuild8
-rw-r--r--profiles/base/package.use.mask6
3 files changed, 15 insertions, 7 deletions
diff --git a/media-libs/mesa/mesa-19.0.0_rc6.ebuild b/media-libs/mesa/mesa-19.0.0_rc6.ebuild
index dd35b9d8a136..0056e74d3ec0 100644
--- a/media-libs/mesa/mesa-19.0.0_rc6.ebuild
+++ b/media-libs/mesa/mesa-19.0.0_rc6.ebuild
@@ -36,9 +36,9 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm lm_sensors
- opencl osmesa pax_kernel pic selinux test unwind vaapi valgrind vdpau
- vulkan wayland xa xvmc"
+ +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +libglvnd +llvm
+ lm_sensors opencl osmesa pax_kernel pic selinux test unwind vaapi valgrind
+ vdpau vulkan wayland xa xvmc"
REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
@@ -106,6 +106,7 @@ RDEPEND="
vdpau? ( >=x11-libs/libvdpau-1.1:=[${MULTILIB_USEDEP}] )
xvmc? ( >=x11-libs/libXvMC-1.0.8:=[${MULTILIB_USEDEP}] )
)
+ libglvnd? ( media-libs/libglvnd )
wayland? (
>=dev-libs/wayland-1.15.0:=[${MULTILIB_USEDEP}]
>=dev-libs/wayland-protocols-1.8
@@ -458,6 +459,7 @@ multilib_src_configure() {
$(meson_use gbm)
$(meson_use gles1)
$(meson_use gles2)
+ $(meson_use libglvnd glvnd)
$(meson_use selinux)
-Dvalgrind=$(usex valgrind auto false)
-Ddri-drivers=$(driver_list "${DRI_DRIVERS[*]}")
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 919f2e68bb28..075bfa0b5a7c 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -36,9 +36,9 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm lm_sensors
- opencl osmesa pax_kernel pic selinux test unwind vaapi valgrind vdpau
- vulkan wayland xa xvmc"
+ +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +libglvnd +llvm
+ lm_sensors opencl osmesa pax_kernel pic selinux test unwind vaapi valgrind
+ vdpau vulkan wayland xa xvmc"
REQUIRED_USE="
d3d9? ( dri3 || ( video_cards_r300 video_cards_r600 video_cards_radeonsi video_cards_nouveau video_cards_vmware ) )
@@ -106,6 +106,7 @@ RDEPEND="
vdpau? ( >=x11-libs/libvdpau-1.1:=[${MULTILIB_USEDEP}] )
xvmc? ( >=x11-libs/libXvMC-1.0.8:=[${MULTILIB_USEDEP}] )
)
+ libglvnd? ( media-libs/libglvnd )
wayland? (
>=dev-libs/wayland-1.15.0:=[${MULTILIB_USEDEP}]
>=dev-libs/wayland-protocols-1.8
@@ -458,6 +459,7 @@ multilib_src_configure() {
$(meson_use gbm)
$(meson_use gles1)
$(meson_use gles2)
+ $(meson_use libglvnd glvnd)
$(meson_use selinux)
-Dvalgrind=$(usex valgrind auto false)
-Ddri-drivers=$(driver_list "${DRI_DRIVERS[*]}")
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 861e64519eba..5cb9b0add6b5 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -7,7 +7,11 @@
# This file is only for generic masks. For arch-specific masks (i.e.
# mask everywhere, unmask on arch/*) use arch/base.
-# Georgy Yakovlev <gyakovlev@gentoo.org> (17 Jan 2019 )
+# Matt Turner <mattst88@gentoo.org> (03 Mar 2019)
+# Mask for testing. Bug 606924
+media-libs/mesa libglvnd
+
+# Georgy Yakovlev <gyakovlev@gentoo.org> (17 Jan 2019)
# Mask openjdk:8 for use as system java-vm until it's proven to work
dev-java/openjdk:8 gentoo-vm
dev-java/openjdk-bin:8 gentoo-vm