summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-09-30 12:15:10 -0500
committerAustin English <wizardedit@gentoo.org>2016-10-03 14:11:17 -0500
commitb643b12349090d4baa7cf134998b827033c940b7 (patch)
tree6cbf3e0694f01dea60febd189d5b65f16444133a
parentapp-crypt/gpgme: enforce qt5/moc location (diff)
downloadgentoo-b643b12349090d4baa7cf134998b827033c940b7.tar.gz
gentoo-b643b12349090d4baa7cf134998b827033c940b7.tar.bz2
gentoo-b643b12349090d4baa7cf134998b827033c940b7.zip
games-sports/ultimatestunts: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
-rw-r--r--games-sports/ultimatestunts/files/ultimatestunts-0.7.7-gcc-4.7.patch4
-rw-r--r--games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild60
2 files changed, 62 insertions, 2 deletions
diff --git a/games-sports/ultimatestunts/files/ultimatestunts-0.7.7-gcc-4.7.patch b/games-sports/ultimatestunts/files/ultimatestunts-0.7.7-gcc-4.7.patch
index 0ce375c1a86c..f323bce22aa5 100644
--- a/games-sports/ultimatestunts/files/ultimatestunts-0.7.7-gcc-4.7.patch
+++ b/games-sports/ultimatestunts/files/ultimatestunts-0.7.7-gcc-4.7.patch
@@ -4,8 +4,8 @@ Subject: fix compilation on gcc-4.7
https://bugs.gentoo.org/show_bug.cgi?id=426612
---- simulation/metaserver.cpp
-+++ simulation/metaserver.cpp
+--- a/simulation/metaserver.cpp
++++ b/simulation/metaserver.cpp
@@ -16,6 +16,7 @@
***************************************************************************/
#include <cstdio>
diff --git a/games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild b/games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild
new file mode 100644
index 000000000000..e6f0860ba6b9
--- /dev/null
+++ b/games-sports/ultimatestunts/ultimatestunts-0.7.7-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils flag-o-matic versionator
+
+MY_P=${PN}-srcdata-$(replace_all_version_separators)1
+DESCRIPTION="Remake of the famous Stunts game"
+HOMEPAGE="http://www.ultimatestunts.nl/"
+SRC_URI="mirror://sourceforge/ultimatestunts/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ media-libs/freealut
+ media-libs/libsdl[joystick,opengl,video]
+ media-libs/libvorbis
+ >=media-libs/openal-1
+ media-libs/sdl-image
+ virtual/opengl
+ virtual/glu
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-paths.patch
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+)
+
+src_prepare() {
+ default
+
+ esvn_clean
+ append-cppflags $(sdl-config --cflags)
+}
+
+src_configure() {
+ econf \
+ --with-openal \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake -C trackedit libtrackedit.a
+ emake
+}
+
+src_install() {
+ default
+
+ newicon data/cars/diablo/steer.png ${PN}.png
+ make_desktop_entry ustunts "Ultimate Stunts"
+}