summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-30 18:27:00 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-30 19:05:41 +0100
commitb8e92c33ba86587922d7e25858b272784aea14e3 (patch)
tree0d5b9c74312da7a9236ade99527c664a7907fd5f
parentdev-python/flask: Backport PyPy3 fix, #601298 (diff)
downloadgentoo-b8e92c33ba86587922d7e25858b272784aea14e3.tar.gz
gentoo-b8e92c33ba86587922d7e25858b272784aea14e3.tar.bz2
gentoo-b8e92c33ba86587922d7e25858b272784aea14e3.zip
dev-python/pytest: Enable pypy3
The tests are no worse than on other implementations.
-rw-r--r--dev-python/pytest/pytest-3.0.3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/pytest/pytest-3.0.3.ebuild b/dev-python/pytest/pytest-3.0.3.ebuild
index bb11033afe91..d154d2ef9403 100644
--- a/dev-python/pytest/pytest-3.0.3.ebuild
+++ b/dev-python/pytest/pytest-3.0.3.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
inherit distutils-r1
@@ -53,7 +53,7 @@ python_prepare_all() {
python_test() {
# test_nose.py not written to suit py3.2 in pypy3
if [[ "${EPYTHON}" == pypy3 ]]; then
- "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -x -v \
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py -vv \
--ignore=testing/BUILD_nose.py \
|| die "tests failed with ${EPYTHON}"
else