summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-17 13:22:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-17 13:22:45 +0200
commitbe3ad5ab84f2e687fde019acb679a67b2e2631cf (patch)
tree3b97672b693b89846d0e6633fa8628314cfa8d27
parentdev-util/wstool: initial import. ebuild by me. (diff)
downloadgentoo-be3ad5ab84f2e687fde019acb679a67b2e2631cf.tar.gz
gentoo-be3ad5ab84f2e687fde019acb679a67b2e2631cf.tar.bz2
gentoo-be3ad5ab84f2e687fde019acb679a67b2e2631cf.zip
dev-util/rosinstall: initial import. ebuild by me.
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-util/rosinstall/Manifest1
-rw-r--r--dev-util/rosinstall/metadata.xml5
-rw-r--r--dev-util/rosinstall/rosinstall-0.7.6.ebuild61
-rw-r--r--dev-util/rosinstall/rosinstall-9999.ebuild61
4 files changed, 128 insertions, 0 deletions
diff --git a/dev-util/rosinstall/Manifest b/dev-util/rosinstall/Manifest
new file mode 100644
index 000000000000..c68cf3b8a7fb
--- /dev/null
+++ b/dev-util/rosinstall/Manifest
@@ -0,0 +1 @@
+DIST rosinstall-0.7.6.tar.gz 64788 SHA256 e5abe3ddb34a84cb77ce926a71112ccda985ed95462f757a24cb67f0e6aa3d9e SHA512 e7e480995e612557e146c9f8c5158aa3109dbc3a3b324f67d9a533cae75a10bae45bdd1573e63bb8bda2b3d7d1ef494c2de3eb06e8ee4f1e05d50f10e5015997 WHIRLPOOL 3affdbb949906007382bd1e2f59b48d0cb8d842d3f93ce6027066dbe644954b1ba337e44ea2d02acd26e9381a308452f84dd2d8ff3993eeb3d180ee82431e734
diff --git a/dev-util/rosinstall/metadata.xml b/dev-util/rosinstall/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-util/rosinstall/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-util/rosinstall/rosinstall-0.7.6.ebuild b/dev-util/rosinstall/rosinstall-0.7.6.ebuild
new file mode 100644
index 000000000000..57d4b294b2bb
--- /dev/null
+++ b/dev-util/rosinstall/rosinstall-0.7.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
+HOMEPAGE="http://wiki.ros.org/rosinstall http://wiki.ros.org/roslocate"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/vcstools[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-util/wstool[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ app-shells/zsh
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ # Local tests work even if ros.org is down
+ export ROSINSTALL_SKIP_PYTHON3=1
+ nosetests test || die
+}
diff --git a/dev-util/rosinstall/rosinstall-9999.ebuild b/dev-util/rosinstall/rosinstall-9999.ebuild
new file mode 100644
index 000000000000..57d4b294b2bb
--- /dev/null
+++ b/dev-util/rosinstall/rosinstall-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/vcstools/rosinstall"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Command-line tools for maintaining a workspace of projects for ROS"
+HOMEPAGE="http://wiki.ros.org/rosinstall http://wiki.ros.org/roslocate"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ https://github.com/vcstools/rosinstall/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/vcstools[${PYTHON_USEDEP}]
+ dev-python/rosdistro[${PYTHON_USEDEP}]
+ dev-util/wstool[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-vcs/git
+ dev-vcs/bzr
+ dev-vcs/mercurial
+ app-shells/zsh
+ )
+"
+
+python_test() {
+ # From travis.yml
+ # Set git config to silence some stuff in the tests
+ git config --global user.email "foo@example.com"
+ git config --global user.name "Foo Bar"
+ # Set the hg user
+ echo -e "[ui]\nusername = Your Name <your@mail.com>" >> ~/.hgrc
+ # Set the bzr user
+ bzr whoami "Your Name <name@example.com>"
+ # command to run tests
+ # Local tests work even if ros.org is down
+ export ROSINSTALL_SKIP_PYTHON3=1
+ nosetests test || die
+}