summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-07 14:14:44 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-07 14:47:00 -0500
commitc3ef0d77ddf5221185872f062f10233d5d844aa9 (patch)
treef8a25ff72e4e20a082462ac3dabd7f8f3d087d01
parentdev-cpp/luabind: bump to EAPI 6, add maintainer-needed (diff)
downloadgentoo-c3ef0d77ddf5221185872f062f10233d5d844aa9.tar.gz
gentoo-c3ef0d77ddf5221185872f062f10233d5d844aa9.tar.bz2
gentoo-c3ef0d77ddf5221185872f062f10233d5d844aa9.zip
x11-misc/xdotool: bump to EAPI 6, add maintainer-needed
Package-Manager: portage-2.2.28
-rw-r--r--x11-misc/xdotool/metadata.xml2
-rw-r--r--x11-misc/xdotool/xdotool-3.20150503.1-r1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/xdotool/metadata.xml b/x11-misc/xdotool/metadata.xml
index c2d5578b1376..2355eb9e058c 100644
--- a/x11-misc/xdotool/metadata.xml
+++ b/x11-misc/xdotool/metadata.xml
@@ -1,10 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <!-- maintainer-needed -->
<longdescription>This tool lets you programatically (or manually) simulate keyboard input and
mouse activity, move and resize windows, etc. It does this using X11's XTEST
extension and other Xlib functions. </longdescription>
<upstream>
<remote-id type="google-code">semicomplete</remote-id>
+ <remote-id type="github">jordansissel/xdotool</remote-id>
</upstream>
</pkgmetadata>
diff --git a/x11-misc/xdotool/xdotool-3.20150503.1-r1.ebuild b/x11-misc/xdotool/xdotool-3.20150503.1-r1.ebuild
new file mode 100644
index 000000000000..5cb1c6e785b3
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-3.20150503.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs flag-o-matic multilib
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
+HOMEPAGE="http://www.semicomplete.com/projects/xdotool/"
+SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND="x11-libs/libXtst
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}"
+
+# The test wants to manualy start Xvfb, wont use VirtualX and it tries
+# to run a full gnome-session. For such a tiny application i consider
+# it overkill to rewrite the test scripts to not use it's own X server
+# and add a full blown gnome just to run the tests.
+RESTRICT="test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/installheader post-install$/installheader/" \
+ -e 's:\<pkg-config\>:$(PKG_CONFIG):' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC LD PKG_CONFIG
+ default
+}
+
+src_install() {
+ emake PREFIX="${D}usr" INSTALLMAN="${D}usr/share/man" INSTALLLIB="${D}usr/$(get_libdir)" install
+
+ dodoc CHANGELIST README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}