summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-11 13:04:59 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-11 13:16:15 +0100
commitc4f888a67bdb246f969f7a3218d18f54cc477109 (patch)
tree0e0e430d75d24beb7073980af6a09749ca46d70e
parentnet-analyzer/speedtest-cli: Remove py2 (diff)
downloadgentoo-c4f888a67bdb246f969f7a3218d18f54cc477109.tar.gz
gentoo-c4f888a67bdb246f969f7a3218d18f54cc477109.tar.bz2
gentoo-c4f888a67bdb246f969f7a3218d18f54cc477109.zip
net-irc/limnoria: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-irc/limnoria/limnoria-20191123.ebuild9
-rw-r--r--net-irc/limnoria/limnoria-99999999.ebuild9
2 files changed, 6 insertions, 12 deletions
diff --git a/net-irc/limnoria/limnoria-20191123.ebuild b/net-irc/limnoria/limnoria-20191123.ebuild
index 87f53168aaae..77d3858ab954 100644
--- a/net-irc/limnoria/limnoria-20191123.ebuild
+++ b/net-irc/limnoria/limnoria-20191123.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1
@@ -25,7 +25,7 @@ DESCRIPTION="Python based extensible IRC infobot and channel bot"
HOMEPAGE="https://supybot.aperio.fr/"
LICENSE="BSD"
SLOT="0"
-IUSE="crypt ssl test"
+IUSE="crypt ssl"
RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
@@ -40,10 +40,7 @@ RDEPEND="
!net-irc/supybot
!net-irc/supybot-plugins
"
-DEPEND="${RDEPEND}
- test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
-
-RESTRICT="!test? ( test )"
+DEPEND="${RDEPEND}"
src_unpack() {
if [[ ${PV} == "99999999" ]]; then
diff --git a/net-irc/limnoria/limnoria-99999999.ebuild b/net-irc/limnoria/limnoria-99999999.ebuild
index 87f53168aaae..77d3858ab954 100644
--- a/net-irc/limnoria/limnoria-99999999.ebuild
+++ b/net-irc/limnoria/limnoria-99999999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1
@@ -25,7 +25,7 @@ DESCRIPTION="Python based extensible IRC infobot and channel bot"
HOMEPAGE="https://supybot.aperio.fr/"
LICENSE="BSD"
SLOT="0"
-IUSE="crypt ssl test"
+IUSE="crypt ssl"
RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
@@ -40,10 +40,7 @@ RDEPEND="
!net-irc/supybot
!net-irc/supybot-plugins
"
-DEPEND="${RDEPEND}
- test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
-
-RESTRICT="!test? ( test )"
+DEPEND="${RDEPEND}"
src_unpack() {
if [[ ${PV} == "99999999" ]]; then