summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-07-13 10:28:24 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-07-13 10:29:30 +0200
commitc7daa85b73bcbe4f3ee5a1ae4c27a0c871298da6 (patch)
tree4360b5cf29cb9caafa9fbcd54f279dc68cebadc8
parentx11-libs/fltk: add AR autodetection with tuple prefix (diff)
downloadgentoo-c7daa85b73bcbe4f3ee5a1ae4c27a0c871298da6.tar.gz
gentoo-c7daa85b73bcbe4f3ee5a1ae4c27a0c871298da6.tar.bz2
gentoo-c7daa85b73bcbe4f3ee5a1ae4c27a0c871298da6.zip
dev-libs/xerces-c: Bump to version 3.2.3
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-libs/xerces-c/Manifest1
-rw-r--r--dev-libs/xerces-c/xerces-c-3.2.3.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/dev-libs/xerces-c/Manifest b/dev-libs/xerces-c/Manifest
index 6a69a800d6b3..51b28cd065e1 100644
--- a/dev-libs/xerces-c/Manifest
+++ b/dev-libs/xerces-c/Manifest
@@ -1 +1,2 @@
DIST xerces-c-3.2.2.tar.gz 7100953 BLAKE2B d167299797189ef181c384ac49095e8bc4cf4e0c7d646e72840a19f56c6eea060168d2c2d29c29ce6cc76dd44e403bea4c3dcde67f964b87f3abc807ad0b14ad SHA512 13709b47b61d957d736f34b774dbc7fbd85171eedebd0cada41fd1d17929e6c42904c882b1e1d4f9b4fd464938b62e5ebb127187b4974dfade6a593e31471e80
+DIST xerces-c-3.2.3.tar.gz 7120270 BLAKE2B d622621657f33ada75a9ef330e77772b8f9cff717d8efc06f2a1fffea77360596e5192b48a6a015403a1045aa2492c626ba05f1de15eb5b997a80ca19b032db8 SHA512 206c5c31510224b8f6963b051f27968e4fe70374a0adb2c2990ac1f865b3bac41f63e6bfb7279faa21477f8878a3b9671ba70726fc75a84e51f037ef158639ad
diff --git a/dev-libs/xerces-c/xerces-c-3.2.3.ebuild b/dev-libs/xerces-c/xerces-c-3.2.3.ebuild
new file mode 100644
index 000000000000..627bdbc2f2f9
--- /dev/null
+++ b/dev-libs/xerces-c/xerces-c-3.2.3.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+
+inherit cmake-utils prefix
+
+DESCRIPTION="A validating XML parser written in a portable subset of C++"
+HOMEPAGE="https://xerces.apache.org/xerces-c/"
+
+if [[ ${PV} == *9999 ]] ; then
+ ESVN_REPO_URI="https://svn.apache.org/repos/asf/xerces/c/trunk"
+ inherit subversion
+else
+ SRC_URI="mirror://apache/xerces/c/3/sources/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="cpu_flags_x86_sse2 curl doc elibc_Darwin elibc_FreeBSD examples iconv icu static-libs test threads"
+RESTRICT="!test? ( test )"
+
+RDEPEND="icu? ( dev-libs/icu:0= )
+ curl? ( net-misc/curl )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-lang/perl )"
+
+DOCS=( CREDITS KEYS NOTICE README )
+
+pkg_setup() {
+ export ICUROOT="${EPREFIX}/usr"
+
+ if use iconv && use icu; then
+ ewarn "This package can use iconv or icu for loading messages"
+ ewarn "and transcoding, but not both. ICU takes precedence."
+ fi
+}
+
+src_configure() {
+ # 'cfurl' is only available on OSX and 'socket' isn't supposed to work.
+ # But the docs aren't clear about it, so we would need some testing...
+ local netaccessor
+ if use curl; then
+ netaccessor="curl"
+ elif use elibc_Darwin; then
+ netaccessor="cfurl"
+ else
+ netaccessor="socket"
+ fi
+
+ local msgloader
+ if use icu; then
+ msgloader="icu"
+ elif use iconv; then
+ msgloader="iconv"
+ else
+ msgloader="inmemory"
+ fi
+
+ local transcoder
+ if use icu; then
+ transcoder="icu"
+ elif use elibc_Darwin; then
+ transcoder="macosunicodeconverter"
+ elif use elibc_FreeBSD; then
+ transcoder="iconv"
+ else
+ transcoder="gnuiconv"
+ fi
+ # for interix maybe: transcoder="windows"
+
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ -Dnetwork-accessor="${netaccessor}"
+ -Dmessage-loader="${msgloader}"
+ -Dtranscoder="${transcoder}"
+ -Dthreads:BOOL="$(usex threads)"
+ -Dsse2:BOOL="$(usex cpu_flags_x86_sse2)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_compile doc-style createapidocs doc-xml
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # package provides .pc files
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ # clean out object files, executables, Makefiles
+ # and the like before installing examples
+ find samples/ \( -type f -executable -o -iname 'runConfigure' -o -iname '*.o' \
+ -o -iname '.libs' -o -iname 'Makefile*' \) -exec rm -rf '{}' + || die
+ docinto examples
+ dodoc -r samples/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ # To make sure an appropriate NLS msg file is around when using
+ # the iconv msgloader ICU has the messages compiled in.
+ if use iconv && ! use icu; then
+ doenvd "$(prefixify_ro "${FILESDIR}/50xerces-c")"
+ fi
+}