summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-04-03 15:53:39 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-04-03 16:10:02 -0700
commitcb0ca61319ecb831a5c87f0e2d09dbbe5bd9c319 (patch)
tree0872ddeb74f419674cb11ae420398f07102816d9
parentsys-apps/util-linux: capture automagic librtas dep (diff)
downloadgentoo-cb0ca61319ecb831a5c87f0e2d09dbbe5bd9c319.tar.gz
gentoo-cb0ca61319ecb831a5c87f0e2d09dbbe5bd9c319.tar.bz2
gentoo-cb0ca61319ecb831a5c87f0e2d09dbbe5bd9c319.zip
sys-apps/util-linux: support libaudit usage
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--sys-apps/util-linux/metadata.xml1
-rw-r--r--sys-apps/util-linux/util-linux-2.35.1-r1.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/sys-apps/util-linux/metadata.xml b/sys-apps/util-linux/metadata.xml
index d707189c1c8d..121dd51cf546 100644
--- a/sys-apps/util-linux/metadata.xml
+++ b/sys-apps/util-linux/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Base System</name>
</maintainer>
<use>
+ <flag name="audit">Use <pkg>sys-process/audit</pkg> to emit audit messages about system changes</flag>
<flag name="caps">build setpriv helper (run programs with diff capabilities)</flag>
<flag name="cramfs">build mkfs/fsck helpers for cramfs filesystems</flag>
<flag name="cryptsetup">Use <pkg>sys-fs/cryptsetup</pkg> to have built-in dm-verity in libmount</flag>
diff --git a/sys-apps/util-linux/util-linux-2.35.1-r1.ebuild b/sys-apps/util-linux/util-linux-2.35.1-r1.ebuild
index 9abd2b066aab..aeb4cff8ef2f 100644
--- a/sys-apps/util-linux/util-linux-2.35.1-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.35.1-r1.ebuild
@@ -25,12 +25,13 @@ HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/
LICENSE="GPL-2 GPL-3 LGPL-2.1 BSD-4 MIT public-domain"
SLOT="0"
-IUSE="build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
+IUSE="audit build caps +cramfs cryptsetup fdformat hardlink kill +logger ncurses nls pam python +readline selinux slang static-libs su +suid systemd test tty-helpers udev unicode userland_GNU"
# Most lib deps here are related to programs rather than our libs,
# so we rarely need to specify ${MULTILIB_USEDEP}.
RDEPEND="
virtual/libcrypt:=
+ audit? ( >=sys-process/audit-2.6:= )
caps? ( sys-libs/libcap-ng )
cramfs? ( sys-libs/zlib:= )
cryptsetup? ( sys-fs/cryptsetup )
@@ -171,6 +172,7 @@ multilib_src_configure() {
$(multilib_native_use_with udev)
$(multilib_native_usex ncurses "$(use_with unicode ncursesw)" '--without-ncursesw')
$(multilib_native_usex ncurses "$(use_with !unicode ncurses)" '--without-ncurses')
+ $(multilib_native_use_with audit)
$(tc-has-tls || echo --disable-tls)
$(use_enable nls)
$(use_enable unicode widechar)