summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-07-24 09:06:42 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-07-24 09:06:42 +0000
commitcb5c19c411d97b335800b4e1091140d7bc5ffaf8 (patch)
tree76d3aab319c9142090f0ed74a228c4b139724e2c
parent2021-07-24 08:51:45 UTC (diff)
parentprofiles/arch/powerpc/ppc64/64ul/package.mask: drop sys-libs/libstdc++-v3 mask (diff)
downloadgentoo-cb5c19c411d97b335800b4e1091140d7bc5ffaf8.tar.gz
gentoo-cb5c19c411d97b335800b4e1091140d7bc5ffaf8.tar.bz2
gentoo-cb5c19c411d97b335800b4e1091140d7bc5ffaf8.zip
Merge updates from master
-rw-r--r--profiles/arch/powerpc/ppc64/64ul/package.mask3
-rw-r--r--x11-wm/xmonad/Manifest1
-rw-r--r--x11-wm/xmonad/xmonad-0.15-r1.ebuild87
3 files changed, 88 insertions, 3 deletions
diff --git a/profiles/arch/powerpc/ppc64/64ul/package.mask b/profiles/arch/powerpc/ppc64/64ul/package.mask
index a4cdefb56030..053f87a07a01 100644
--- a/profiles/arch/powerpc/ppc64/64ul/package.mask
+++ b/profiles/arch/powerpc/ppc64/64ul/package.mask
@@ -10,6 +10,3 @@ net-im/telegram-desktop
# to build openjdk:11, but it's possible to build openjdk:8 with icedtea{,-bin}
dev-java/openjdk:11
dev-java/openjdk-bin
-
-# <gcc-4 does not compile with >=gcc-4 on ppc64
-sys-libs/libstdc++-v3
diff --git a/x11-wm/xmonad/Manifest b/x11-wm/xmonad/Manifest
index 41cf1312cbb4..de7acaf13f0b 100644
--- a/x11-wm/xmonad/Manifest
+++ b/x11-wm/xmonad/Manifest
@@ -1 +1,2 @@
DIST xmonad-0.15.tar.gz 68822 BLAKE2B 9ee9a070f6743fbab2cffe05ee9e60b64fded0b4916fdec03a550f5d5ec5a34102ab2d4e9586b9a0ca534db284a8058f11ee248072f3f3b312ae30c09873feff SHA512 f881f3faa4f5a0de7a5a37118cd7041083ae3a7569c7094b55dedb9aa858176789aff459d426b237ebae5cc4598b06de790938775a7ac968c2d76be3f0efc8ba
+DIST xmonad-259.patch 1452 BLAKE2B 869d11ae762c43b9e749169d6b691fdee52e9fc17848fc4ee494e075501528d4c0c040deea617f8fbeab003dd7bc277254498b0089b60f8e6e47b6b96430eb69 SHA512 9edb155a74d170e612cd84aad4fb004176fe5e5fc7017f1985aa2b4628b2cc995b157ba42ab6f7b546d5e3467358292234b3926254e1e831cc7ef38844e14c6d
diff --git a/x11-wm/xmonad/xmonad-0.15-r1.ebuild b/x11-wm/xmonad/xmonad-0.15-r1.ebuild
new file mode 100644
index 000000000000..0d981be7a180
--- /dev/null
+++ b/x11-wm/xmonad/xmonad-0.15-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.5.6.9999
+#hackport: flags: -generatemanpage,-testing,-profiling
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A tiling window manager"
+HOMEPAGE="https://xmonad.org"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://patch-diff.githubusercontent.com/raw/xmonad/xmonad/pull/259.patch -> ${PN}-259.patch"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="no-autorepeat-keys"
+
+RDEPEND="dev-haskell/data-default:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/setlocale:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/x11-1.8:=[profile?] <dev-haskell/x11-1.10:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/quickcheck-2 )
+"
+
+DOCS=( CONFIG README.md CHANGES.md )
+HTML_DOCS=( man/${PN}.1.html )
+
+SAMPLE_CONFIG="${PN}.hs"
+
+src_prepare() {
+ default
+ use no-autorepeat-keys && eapply "${FILESDIR}"/${PN}-0.14-check-repeat.patch
+ eapply "${DISTDIR}/${PN}-259.patch"
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-generatemanpage \
+ --flag=-profiling \
+ --flag=-testing
+}
+
+src_install() {
+ default
+
+ cabal_src_install
+
+ echo -e "#!/bin/sh\n/usr/bin/${PN}" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ insinto /usr/share/${PF}/ghc-$(ghc-version)/man
+ doins man/${SAMPLE_CONFIG}
+
+ doman man/${PN}.1
+}
+
+pkg_postinst() {
+ haskell-cabal_pkg_postinst
+
+ elog "A sample ${SAMPLE_CONFIG} configuration file can be found here:"
+ elog " /usr/share/${PF}/ghc-$(ghc-version)/man/${SAMPLE_CONFIG}"
+ elog "The parameters in this file are the defaults used by ${PN}."
+ elog "To customize ${PN}, copy this file to:"
+ elog " ~/.${PN}/${SAMPLE_CONFIG}"
+ elog "After editing, use 'mod-q' to dynamically restart ${PN} "
+ elog "(where the 'mod' key defaults to 'Alt')."
+ elog ""
+ elog "Read the README or man page for more information, and to see "
+ elog "other possible configurations go to:"
+ elog " http://haskell.org/haskellwiki/Xmonad/Config_archive"
+ elog "Please note that many of these configurations will require the "
+ elog "x11-wm/xmonad-contrib package to be installed."
+}